LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-25-2010, 02:54 AM   #1
aalexand
LQ Newbie
 
Registered: Dec 2008
Location: Near Orléans in France
Distribution: Slackware
Posts: 4

Rep: Reputation: 0
Repairing a lilo from a live CD


Hello,

During the upgrade of my slackware from 13.0 to 13.1 an electric problem
happen on my sony laptop. So the upgrade is fine, disk is fine but
no time to run the lilo for configure the new boot. Now impossible to boot. I boot on a backtrack live CD, and can't repair my lilo.
Is someone could help me.
I use slackware since the 3.2 (kheops in french).
regards
aalexand
 
Old 06-25-2010, 03:03 AM   #2
kumar.manoj412
Member
 
Registered: May 2007
Location: India
Distribution: Mandriva, Ubuntu
Posts: 43
Blog Entries: 1

Rep: Reputation: 16
Quote:
Originally Posted by aalexand View Post
Hello,

During the upgrade of my slackware from 13.0 to 13.1 an electric problem
happen on my sony laptop. So the upgrade is fine, disk is fine but
no time to run the lilo for configure the new boot. Now impossible to boot. I boot on a backtrack live CD, and can't repair my lilo.
Is someone could help me.
I use slackware since the 3.2 (kheops in french).
regards
aalexand
Hello,

You can try the this How TO
http://www.faqs.org/docs/Linux-HOWTO...cue-HOWTO.html
 
Old 06-25-2010, 03:08 AM   #3
sahko
Senior Member
 
Registered: Sep 2008
Distribution: Slackware
Posts: 1,041

Rep: Reputation: Disabled
Theres a nice howto here: http://blog.tpa.me.uk/2009/09/29/re-...kware-boot-cd/
 
Old 06-25-2010, 07:05 AM   #4
aalexand
LQ Newbie
 
Registered: Dec 2008
Location: Near Orléans in France
Distribution: Slackware
Posts: 4

Original Poster
Rep: Reputation: 0
Hello,

Thanks to kumar.manoj412 and sahko for their respond.

The how-to rescue didn't work because I used an old version of backtrack
based on the 2.26 kernel which too old to do chroot.

So I burned a cd of the cd1 of the slackware and boot on it.
With the link http://blog.tpa.me.uk/2009/09/29/re-...kware-boot-cd/
I recreate the lilo and can watch a new error message in dmesg.
Problem with hard disk (e2fsck -b 8193 /dev/sda2)

As The sony is an old laptop, I don't have sata disk inside so after running
a cfdisk I see it's reconized as /dev/sda and not /dev/hda

I change the fstab
And It runs

So thanks for the help (and sorry for the bad english).

If a moderator can put the thread as resolved.

Alain
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] LILO fails when run from live CD after installing Slack (skipped LILO during setup) sysfce2 Linux - Newbie 7 08-04-2009 12:16 AM
Lilo and Grub conflict, installed Slackware but cant run the Helix Live CD mongoosecage Slackware 2 06-25-2008 09:22 PM
installing lilo from a live cd on a working computer j0ck Slackware 4 01-17-2006 06:50 PM
Lilo just broke, how do i fix with a live distro? e1000 General 1 08-01-2004 07:50 PM
can I fix lilo with slax live cd? walterbyrd Slackware - Installation 1 04-01-2004 11:44 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration