-   Slackware (
-   -   Removing KDE menu items from XFCE menu (

kr4ey 09-26-2007 01:01 PM

Removing KDE menu items from XFCE menu
I have set up a few users on Slackware 12 that use different desktop managers.
Is there a way to remove or disable the KDE items in the XFCE menu without affecting other users?

MS3FGX 09-26-2007 05:42 PM

I was not actually aware that FluxBox would load KDE items.

In any case, the menu is created and stored for each user individually. It can be edited for the current user by making changes to the "~/.fluxbox/menu" file. By default it needs to be edited by hand, it is not configured through any application (though they are available, just not included in Slackware).

kr4ey 09-27-2007 07:26 AM

Yes I know FluxBox won't show KDE items, but I'm looking for a fix to disable items in XFCE.

kr4ey 09-27-2007 05:00 PM


Log in as root and go to /usr/share/applications/kde

pick the desktop file (menu item that you want to be removed)
open it in text editor, at the end of the file add


save and exit the editor.

The item will be removed from the menu.

gene_x 03-09-2011 05:23 PM

NoDisplay=true will hide the menu entry from all desktop enviroments (or at least from kde, xfce...tested)
use instead the option OnlyShowIn or NotShowIn
eg. i added OnlyShowIn=KDE to all my files under /usr/share/applications/kde4

as root
cd /usr/share/applications/kde4
for i in `ls *desktop`; do echo OnlyShowIn=KDE >> $i; done



Woodsman 03-09-2011 06:39 PM

You mentioned Slackware 12. You might want to read OnlyShowIn and NotShowIn Directives Do Not Work in XFCE.

frankbell 03-09-2011 11:28 PM


Originally Posted by kr4ey (Post 2905286)
Yes I know FluxBox won't show KDE items, but I'm looking for a fix to disable items in XFCE.

Just an aside.

Fluxbox may not show KDE items when you first fire it up unless they are on the default menu in /usr/, but it's easy enough to add them.

I run lots of KDE and Gnome applications from my Fluxbox menu.

In fact, in Slack 13, I think (I don't have it handy) that Konqueror was on the default Fluxbox menu from Pat.

gene_x 03-12-2011 07:55 AM

Hi Woodsman.

Tks. I've read the thread and its says bug fixed at the end. The OnlyShowIn=KDE worked here for me in Xfce 4.8. Just in case, I went to /usr/share/applications/kde4 and edited amarok.desktop, commenting the line OnlyShowIn. Then Killall xfce4-panel and xfce4-panel (to reload the menu).
The amarok shortcut appeared again in the menu.

Kind Regards

disturbed1 03-14-2011 04:29 AM

Xfce has a wiki on this. Haven't tried it myself. We always use an extra panel with application icons, and personally alt+F2. Xfce's menu is a cluster though :(

All times are GMT -5. The time now is 12:33 AM.