LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-07-2018, 09:13 PM   #1
Lysander666
Member
 
Registered: Apr 2017
Location: London
Distribution: Slackware 14.2 + Xfce
Posts: 788
Blog Entries: 1

Rep: Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680
Redshift under Xfce making screen twice as dark when restarting x


Or rather, exponentially. This is an interesting issue: I have configured Redshift to start when x starts on a second-hand laptop I have acquired. The weird thing is that if I restart the x session, logout/login, Redshift is now twice as dark as before. If I restart x again, the screen is darker still and almost unreadable. Is there any way to stop Redshift doing this? It's not a problem under my netbook which runs LXDE.

Some info - redshift.conf:

Code:
; Global settings for redshift
[redshift]
; Set the day and night screen temperatures
temp-day=5700
temp-night=4200

; Disable the smooth fade between temperatures when Redshift starts and stops.
; 0 will cause an immediate change between screen temperatures.
; 1 will gradually apply the new screen temperature over a couple of seconds.
fade=1

; Solar elevation thresholds.
; By default, Redshift will use the current elevation of the sun to determine
; whether it is daytime, night or in transition (dawn/dusk). When the sun is
; above the degrees specified with elevation-high it is considered daytime and
; below elevation-low it is considered night.
;elevation-high=3
;elevation-low=-6

; Custom dawn/dusk intervals.
; Instead of using the solar elevation, the time intervals of dawn and dusk
; can be specified manually. The times must be specified as HH:MM in 24-hour
; format.
;dawn-time=6:00-7:45
;dusk-time=18:35-20:15

; Set the screen brightness. Default is 1.0.
;brightness=0.9
; It is also possible to use different settings for day and night
; since version 1.8.
;brightness-day=0.7
;brightness-night=0.4
; Set the screen gamma (for all colors, or each color channel
; individually)
gamma=0.8
;gamma=0.8:0.7:0.8
; This can also be set individually for day and night since
; version 1.10.
;gamma-day=0.8:0.7:0.8
;gamma-night=0.6

; Set the location-provider: 'geoclue2', 'manual'
; type 'redshift -l list' to see possible values.
; The location provider settings are in a different section.
location-provider=manual

; Set the adjustment-method: 'randr', 'vidmode'
; type 'redshift -m list' to see all possible values.
; 'randr' is the preferred method, 'vidmode' is an older API.
; but works in some cases when 'randr' does not.
; The adjustment method settings are in a different section.
adjustment-method=randr

; Configuration of the location-provider:
; type 'redshift -l PROVIDER:help' to see the settings.
; ex: 'redshift -l manual:help'
; Keep in mind that longitudes west of Greenwich (e.g. the Americas)
; are negative numbers.
[manual]
lat=50.5
lon=-0.1

; Configuration of the adjustment-method
; type 'redshift -m METHOD:help' to see the settings.
; ex: 'redshift -m randr:help'
; In this example, randr is configured to adjust only screen 0.
; Note that the numbering starts from 0, so this is actually the first screen.
; If this option is not specified, Redshift will try to adjust _all_ screens.
[randr]
screen=0
and inxi -F:

Code:
lysander@lysplorer_iv:~$ inxi -F
System:    Host: lysplorer_iv.netstark Kernel: 4.4.132 x86_64 bits: 64 Desktop: Xfce 4.12.3 
           Distro: Slackware 14.2 
Machine:   Type: Laptop System: Dell product: Latitude E6320 v: 01 serial: <root required> 
           Mobo: Dell model: 0719TN v: A00 serial: <root required> BIOS: Dell v: A08 date: 10/18/2011 
Battery:   ID-1: BAT0 charge: 37.7 Wh condition: 48.6/60.0 Wh (81%) 
CPU:       Topology: Dual Core model: Intel Core i3-2330M bits: 64 type: MT MCP L2 cache: 3072 KiB 
           Speed: 800 MHz min/max: 800/2200 MHz Core speeds (MHz): 1: 800 2: 1175 3: 839 4: 933 
Graphics:  Card-1: Intel 2nd Generation Core Processor Family Integrated Graphics driver: i915 v: kernel 
           Display: server: X.Org 1.18.3 driver: intel unloaded: fbdev,modesetting,vesa 
           resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile v: 3.3 Mesa 11.2.2 
Audio:     Card-1: Intel 6 Series/C200 Series Family High Definition Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k4.4.132 
Network:   Card-1: Intel 82579LM Gigabit Network Connection driver: e1000e 
           IF: eth0 state: down mac: d4:be:d9:1d:43:cf 
           Card-2: Broadcom BCM4313 802.11bgn Wireless Network Adapter driver: bcma-pci-bridge 
           IF-ID-1: wlan0 state: up mac: 7c:e9:d3:68:45:31 
           IF-ID-2: wwan0 state: down mac: 02:80:37:ec:02:00 
Drives:    HDD Total Size: 232.89 GiB used: 11.52 GiB (4.9%) 
           ID-1: /dev/sda vendor: Western Digital model: WD2500BEVT-75A23T0 size: 232.89 GiB 
Partition: ID-1: / size: 29.40 GiB used: 10.46 GiB (35.6%) fs: ext4 dev: /dev/root 
           ID-2: /home size: 196.59 GiB used: 1.06 GiB (0.5%) fs: ext4 dev: /dev/sda4 
           ID-3: swap-1 size: 3.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 54.0 C mobo: 39.0 C sodimm: 44.0 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 202 Uptime: 6m Memory: 2.75 GiB used: 592.4 MiB (21.0%) Shell: bash inxi: 3.0.09

Last edited by Lysander666; 07-07-2018 at 09:15 PM.
 
Old 07-08-2018, 02:44 PM   #2
Lysander666
Member
 
Registered: Apr 2017
Location: London
Distribution: Slackware 14.2 + Xfce
Posts: 788

Original Poster
Blog Entries: 1

Rep: Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680
Well, I have uninstalled Redshift for now. This display is funny and never really looks good with it, no matter the settings. For now I'm just adjusting the brightness.
 
Old 07-13-2018, 06:25 PM   #3
Lysander666
Member
 
Registered: Apr 2017
Location: London
Distribution: Slackware 14.2 + Xfce
Posts: 788

Original Poster
Blog Entries: 1

Rep: Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680
Well, I can confirm this is an issue. Not on restart but on logging out and logging in. I have brightness set to 4500 at night which looks great on this machine, but logging out and logging in will make Redshift twice as dark. Nothing in the config file I can see which might explain why. Any ideas would be greatly appreciated.
 
Old 07-13-2018, 07:11 PM   #4
Skaendo
Member
 
Registered: Dec 2014
Location: West Texas, USA
Distribution: Slackware64-14.2
Posts: 773

Rep: Reputation: Disabled
I use redshift (my own SlackBuild) on Slackware64-current with Cinnamon and never have any issues.
I am using geoclue2 with auto-location and a lot more compile time options.

I can set up my test rig later tonight and play around with some other DE's and get back to this thread probably tomorrow.
 
1 members found this post helpful.
Old 07-13-2018, 08:14 PM   #5
Lysander666
Member
 
Registered: Apr 2017
Location: London
Distribution: Slackware 14.2 + Xfce
Posts: 788

Original Poster
Blog Entries: 1

Rep: Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680
duplicate

Last edited by Lysander666; 07-13-2018 at 08:15 PM.
 
Old 07-13-2018, 08:14 PM   #6
Lysander666
Member
 
Registered: Apr 2017
Location: London
Distribution: Slackware 14.2 + Xfce
Posts: 788

Original Poster
Blog Entries: 1

Rep: Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680
Thanks, Skaendo. Let me know how it goes. I think this is an issue with the Xfce session manager, I also run Redshift on my LXDE Slack netbook and it's never a problem. If I logout and login in LXDE, Redshift just restarts, but in Xfce it just adds the darkness setting to the that of the last session.

I wonder if unticking "save session" on the logout screen would solve this issue in Xfce. I'm on a different machine now though.
 
Old 07-13-2018, 11:15 PM   #7
Skaendo
Member
 
Registered: Dec 2014
Location: West Texas, USA
Distribution: Slackware64-14.2
Posts: 773

Rep: Reputation: Disabled
I just did a fresh full Slackware64-current install and installed (in this order):
Code:
libdaemon
avahi
geoclue2 (2.4.7)
pyxdg (python 3 bindings only)
redshift
Redshift is working normal in XFCE and KDE for me with auto-location.

All default settings; 6500k-day, 4500k-night
I have logged out (to console and kdm) and logged back in many times no problem.
I have "Save session for future logins" checked (default) in XFCE.

Nothing in your config looks like it should have any effect like you are experiencing.

My only guess is that LXDE is doing something weird to it (maybe hardware related with brightness settings?) or try using geoclue2 and auto-location. If you decide to try geoclue2, I would recommend to use 2.4.7 because 2.4.10 has some permission issues somewhere that I have not yet the desire to figure out.
 
1 members found this post helpful.
Old 07-19-2018, 04:13 PM   #8
Lysander666
Member
 
Registered: Apr 2017
Location: London
Distribution: Slackware 14.2 + Xfce
Posts: 788

Original Poster
Blog Entries: 1

Rep: Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680
Skaendo - thank you so much for this. I haven't had a chance yet to try geoclue2 but will do very shortly. Thanks for your help so far, I will report back.
 
Old 07-19-2018, 04:25 PM   #9
Skaendo
Member
 
Registered: Dec 2014
Location: West Texas, USA
Distribution: Slackware64-14.2
Posts: 773

Rep: Reputation: Disabled
Another note, On my Dell ('07 Inspiron 1520 / Intel GM965 graphics) I have to enable and set it to 'vidmode' instead of 'randr'. That might be worth a try as well.

Without looking at my build script, I think that vidmode might need to be enabled at build time.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Qemu hangs with dark screen after install boot screen kayla2 Linux - Virtualization and Cloud 4 01-02-2017 07:52 PM
dark theme in programs after upgrading xfce 0zMe Slackware 5 08-03-2012 06:34 AM
[SOLVED] Slackware/Xfce - the terminal colors are way too dark. joeBuffer Slackware 3 08-16-2009 11:55 PM
Dark screen after screen saver O_o!! elekt Ubuntu 0 07-25-2007 10:54 PM
Screen is very dark Imerion Linux - Laptop and Netbook 19 01-23-2005 05:07 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 06:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration