LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 10-03-2015, 07:26 AM   #1
glupa4e
Member
 
Registered: Jan 2011
Posts: 242

Rep: Reputation: 2
Unhappy Recorded stream in mp4 - Audio and video are out of sync


Dear Slackers,

this is not a Slackware problem. I have recorded an internet stream in mp4 format.

When i play the recording in Kaffeine, the audio and video are out of synchronisation.

If i play the recording with VLC, it is OK.

The YouTube video editor says that the recording has a problem, although i was able to edit with it other similar recordings (which also seemed to be out of sync in Kaffeine). This particular video is rejected by YouTube.

I searched on the internet and found this article. When i play that video recording with Aviedmux, the application becomes unresponsive and i have to kill the process.

Kdenlive also says that the video is not valid.

OpenShot does not support such file extensions.

There is no SlackBuild for MKVToolNix to try this.

Anyone who has experience with ffmpeg or some other tool under Linux? I would like to get this video somehow synchronised. Any advice would be appreciated.
 
Old 10-03-2015, 10:36 AM   #2
Roberto Neri
LQ Newbie
 
Registered: Nov 2012
Location: Palermo, Italy
Distribution: Slackware
Posts: 10

Rep: Reputation: Disabled
Hi,
I used to have the same problem with MPEG-2 recorded streams, and found the solution in this Avidemux Wiki page (the ProjectX SlackBuild is here).
HTH
 
Old 10-03-2015, 02:47 PM   #3
glupa4e
Member
 
Registered: Jan 2011
Posts: 242

Original Poster
Rep: Reputation: 2
Hello Roberto, thanks for the post!

I accidentally found MKVToolNix Slackware Package by Alien. This helped me solve my issue. I had to additionally process the recording, but finally the aim was fulfilled.

Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mp4 files - video but no audio Cammigirl Linux - Software 9 05-25-2016 02:42 AM
ffmpeg mixing audio/video - trying to end vid after video stream completes joejoe99 Linux - Software 2 06-22-2012 12:44 AM
ffmpeg and mencoder slice mp4 video audio out of sync lindylex Linux - Software 5 01-10-2010 04:26 AM
mp4 files suffer audio de-sync after simple cuts widda Mandriva 0 10-13-2009 02:41 AM
MP4 with Xine.. I have video but no audio darkone66669 Linux - Software 1 03-04-2008 06:37 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration