LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Slackware (http://www.linuxquestions.org/questions/forumdisplay.php?f=14)
-   -   Reconnect failure with D-LINK DWM-156 modem (http://www.linuxquestions.org/questions/showthread.php?t=4175437094)

v2george 11-14-2012 06:49 AM

Reconnect failure with D-LINK DWM-156 modem
 
This modem connected successfully, sometimes, first time after reboot. If it is disconnected then trying to connect fails afterwords.
Seems /dev/ttyUSB0 is not getting freed up after the first
connection, and running fuser as root ( not as user ) revealed
that modem-manager is still using the device. I could get it to reconnect by killing modem-manager process as follows
1. /etc/rc.d/rc.networkmanager stop
2. killall -9 modem-manager
3. NetworkManager --no-daemon

What would be the best way to fix this problem ?

Thanks

markush 11-14-2012 08:55 AM

When I've disconnected my UMTS-modem, I use to plug it off. I've never left it plugged in until reconnecting.

Markus

v2george 11-14-2012 10:18 AM

Even if the modem is physically removed and plugged back in, I am not able to connect again. First time connection also goes fine only once in a while. Strangely, if I kill the running modem-manager, and start network manager as 'NetworkManager --no-daemon', it is found to connect at the next attempt. And the connection stays stable.

markush 11-14-2012 10:39 AM

I don't use Networkmanager. I connect only with the ppp-program and additionally I have comgt installed.

I start the connection as root on the commandline and when I want to disconnect I simply kill it, but I have a disconnect-script which then runs.

Markus

v2george 11-14-2012 11:53 AM

I had to setup a broadband connection for a less technical person.

I chose NetworkManager option in netconfig during setup, which allowed
me to use nm-applet with xfce window manager which were quite appropriate for the user. A Vodafone modem seemed to work quite fine with that setup and in the not so very stable network environment. When I switched to the D-link modem, these problems started.

Getting reconnect working fine from the nm-applet or so is pretty much a requirement for the user.

I also tried to get wvdial working as another easy option, but seems it no longer works fine with Slackware. When tried, wvdial failed similarly under Ubuntu UE. From what I understood wvdial uses ppp directly.

Seems like using ppp directly is the only other option left.

markush 11-14-2012 11:57 AM

Yes, I had also problems with wvdial, I wanted to build the package from slackbuilds.org, but wvstreams failed to build.

Markus

v2george 11-14-2012 12:21 PM

I could get it compiled with some "const" additions and #includes which were missing. But wvdial failed with assertion failure in utils/wvtask.cc or so, involving magic_number WVTASK_MAGIC.

v2george 11-15-2012 05:45 AM

If I start modem-manager in --debug mode as follows:

/etc/rc.d/rc.networkmanager stop
killall -9 modem-manager
modem-manager --debug
/etc/rc.d/rc.networkmanager start

everything seems fine with the d-link modem. I can connect and disconnect any
number of times with no problem at all!

manual pppd method also works fine!


All times are GMT -5. The time now is 08:37 AM.