-   Slackware (
-   -   Recommended Xorg Upgrade Procedure? (

botnet 06-02-2009 08:28 PM

Recommended Xorg Upgrade Procedure?
Or is this not considered a wise move?

I am asking because I have an intel card, and some new drivers have been being released that require a more recent xorg version and with my current drivers i am unable to play Portal. I really do not like to have to use another operating system just to play a game. (The problem by the way is after the intro screen loads, right before the menu selection appears, the window goes black and locks up)

I tried once before to upgrade Xorg by manually untarring, configuring, and make && make installing each package myself, but something went awry somewhere with libxcb giving me invalid libtool errors all over the place and i was unable to determine the exact cause.


veerain 06-03-2009 06:10 AM

Better upgrade with a package manager. Using the binary xorg files is not good. You may have library incompatibilities as you perhaps have.

rvdboom 06-03-2009 08:44 AM

I've done something like this to have compositing with my laptop, which uses an ATI integrated chip not well supported by current slack.
I finally ended compiling the following packages by myself to get the latest version:

xf86-video-ati-6.12.2 (replace this with xf86-video-intel)

Most sources can be found in
I don't recall exactly the order of compiling, but usually xorg-server comes after the libs and proto, then drivers like input or videos.
I also had to recompile Qt and KDE, as they seem to have issues with the newer mesa.
Hope it helps.

botnet 06-03-2009 05:10 PM

Thanks, I think I will just go ahead and try it. I should be able to restore everything off the Slackware DVD if it doesn't go well, right?

dugan 06-03-2009 05:14 PM


vinegaroon 06-03-2009 06:01 PM


Originally Posted by dugan (Post 3562115)
Slackware 13 will include the new drivers. And Slackware 13 will be out soon.

If you can wait for Slackware 13, it's probably easier than rebuilding X.

How do you know this? Just wondering...

dugan 06-03-2009 08:05 PM


rworkman 06-03-2009 08:57 PM

Please don't share contents of private mails in public fora.

dugan 06-03-2009 09:01 PM

You're right. That was a lapse in my judgement.

botnet 06-04-2009 02:51 PM

I ended up using src2pkg (great utility gnashley, thanks) to build and install the necessary packages to upgrade to xorg-1.6.0

Here is what I had to install and in the order:
First, in order to get the rest compiled I needed to install these three:

After this I could build everything save for xorg-server itself which entailed:

After these were installed I was able to build xorg-server-1.6.0 and install it, then of course the x11 drivers that I needed (mouse keyboard evdev synaptics vesa fbdev and intel)

It all works more or less. No instability or anything weird as of yet.

The only issue is I can only startx as root now, which means I have to use GDM which I do not like (qingy user here). Could that be fixed with a chmod a+x? The error I get is "Fatal Server Error: xf86OpenConsole: cannot open /dev/tty0 no such file or directory" Of course /dev/tty0 does exist.

Portal still doesn't want to work correctly though, and I still don't have GEM or UXA capabilities (both work in Gentoo on this laptop though) so I must be missing something, but I will look around to fixing that before I make another thread about that issue.

Thanks again gnashley, src2pkg made this endeavor much much easier than a manual installation.

Edit: Apparently KMS is needed in the kernel for GEM/UXA and from what I can gather this conflicts with PAE. Last time I used KMS it was a mess, but that was on the .29 kernel tree and I like having access to all my RAM with PAE...Maybe I can wait until Slackware 13 and go 64bit...

Additional edit: KMS enabled, PAE disabled GEM and UXA both work, still no problems, chmod u+s /usr/bin/Xorg lets me startx as normal user now.
but...oh well

All times are GMT -5. The time now is 10:12 AM.