LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 08-01-2019, 03:47 AM   #1
medictruck
LQ Newbie
 
Registered: Nov 2017
Location: Kathmandu, Nepal
Distribution: Slackware
Posts: 6

Rep: Reputation: Disabled
Recommended way of installing packages in Slackware Current


Hello all,

I have installed and used Slackware 13.37 for many years in the past. Now, I want to try the Current branch of Slackware.

However, I have quickly come to notice that the Slackbuild repository is not configured for Current(makes sense).

I was trying to install Mnemosyne which build as per queue (sbopkg pointing to Slackware 14.2) upto but not further -

1. Qt5
2. Qt5-webkit
3. python3-sip
4. python3-Pyqt5
5. Mnemosyne


From this endeavor, I quickly gathered that obviously there will be incompatabilities(but not all) with the stable branch. Also, I consider this a way of learning so for the question as posed above -

1. What is the correct method to go about for the above sequence in the Current Branch (if at all possible)?

2. What are the general guidelines when dealing with installing packages in the Current branch as I have never felt any need to go outside of Slackbuilds and the system defaults itself?

Regards,
medictruck

Last edited by medictruck; 08-01-2019 at 03:48 AM. Reason: Grammar mistakes.
 
Old 08-01-2019, 04:31 AM   #2
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 8,957

Rep: Reputation: Disabled
Hello,

You will get some answers in this post.
 
2 members found this post helpful.
Old 08-01-2019, 12:31 PM   #3
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 9,093

Rep: Reputation: 3929Reputation: 3929Reputation: 3929Reputation: 3929Reputation: 3929Reputation: 3929Reputation: 3929Reputation: 3929Reputation: 3929Reputation: 3929Reputation: 3929
I use sbotools and Ponce's repo.

https://www.linuxquestions.org/quest...9/#post5467075
 
1 members found this post helpful.
Old 08-02-2019, 02:35 AM   #4
kgha
Member
 
Registered: May 2018
Location: Sweden
Distribution: Slackware 64 -current multilib from AlienBob's LiveSlak MATE
Posts: 173

Rep: Reputation: 112Reputation: 112
When in need of a 3rd party package I always check AlienBOB's repo first. In your case, this will get you -current packages of Qt5 and Qt5-webkit. Next step is slackbuilds.org - in my experience most Sbo scripts works fine in -current, even if there is no guarantee. In the very few cases were a Sbo script gives an error, I check Ponce's repo for tweaked buildscripts.
 
2 members found this post helpful.
Old 09-05-2019, 01:09 PM   #5
medictruck
LQ Newbie
 
Registered: Nov 2017
Location: Kathmandu, Nepal
Distribution: Slackware
Posts: 6

Original Poster
Rep: Reputation: Disabled
Thank folks for guiding. I have had some positive success in Slackware-Current (New to Current). I am having few difficulties in understanding the output of 'Mnemosyne - flashcard program' that I wanna understand.

I have installed Qt5 and Qt5-webkit from Alienbob's collections and python3-opengl from Slackbuilds. Here are my doubts in order -

1. I think sbopkg doesn't recognize Qt5 5-webkit as installed I presume - as it shows them still as 'New'?

2. As clear from the attachment screenshot of Mnemosyne queue in sbopkg, the 'python3-sip' package got build from SlackBuilds, did it take into account Qt5 packages as above?

3. Now, for the output(screenshot attached) of Mnemosyne (it built but didn't ran and threw few error outputs) that I ran from the terminal- So, I need guidance wrt this output

Code:
bash-5.0$ mnemosyne
Warning: Could not import OpenGL. Might cause a black screen on some Linux distributions. Try installing python3-opengl in that case.
Log body:
 An unexpected error has occurred.
Please forward the following info to the developers:

Traceback (innermost last):
  File "/usr/bin/mnemosyne", line 145, in <module>
    from PyQt5 import QtWebEngineWidgets  # Needs to happen first for some reason.
 RuntimeError: the sip module implements API v12.0 to v12.3 but the PyQt5.QtWebEngineWidgets module requires API v12.6

An unexpected error has occurred.
Please forward the following info to the developers:

Traceback (innermost last):
  File "/usr/bin/mnemosyne", line 145, in <module>
    from PyQt5 import QtWebEngineWidgets  # Needs to happen first for some reason.
 RuntimeError: the sip module implements API v12.0 to v12.3 but the PyQt5.QtWebEngineWidgets module requires API v12.6
An unexpected error has occurred.
Please forward the following info to the developers:

Traceback (innermost last):
  File "/usr/bin/mnemosyne", line 145, in <module>
    from PyQt5 import QtWebEngineWidgets  # Needs to happen first for some reason.
 RuntimeError: the sip module implements API v12.0 to v12.3 but the PyQt5.QtWebEngineWidgets module requires API v12.6
bash-5.0$


Quote:
Originally Posted by kgha View Post
When in need of a 3rd party package I always check AlienBOB's repo first. In your case, this will get you -current packages of Qt5 and Qt5-webkit. Next step is slackbuilds.org - in my experience most Sbo scripts works fine in -current, even if there is no guarantee. In the very few cases were a Sbo script gives an error, I check Ponce's repo for tweaked buildscripts.
Attached Thumbnails
Click image for larger version

Name:	Mnemosyne.png
Views:	19
Size:	60.7 KB
ID:	31298  

Last edited by medictruck; 09-05-2019 at 01:23 PM. Reason: Edit : Added info about opengl
 
Old 09-05-2019, 02:22 PM   #6
igadoter
Senior Member
 
Registered: Sep 2006
Location: wroclaw, poland
Distribution: many, primary Slackware
Posts: 1,286
Blog Entries: 1

Rep: Reputation: Disabled
You may lost compatibility during update. So you need your own sbo script - if you application will top to work you will have to rebuild it with your custom sbo script.
 
Old 09-06-2019, 02:28 AM   #7
kgha
Member
 
Registered: May 2018
Location: Sweden
Distribution: Slackware 64 -current multilib from AlienBob's LiveSlak MATE
Posts: 173

Rep: Reputation: 112Reputation: 112
Nor sure, but I wonder if you have conflicting sip versions installed. sip-4.19.18 is part of -current. If you built and installed python3-sip using the SBo script, this script builds sip-4.19.6 (if you downloaded the source file indicated on the SBo site). If so, you culd try uninstall the SBo package and, to be on the safe side, reinstall sip-4.19.18 and see if that helps.
 
Old 09-06-2019, 03:58 AM   #8
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,934

Rep: Reputation: Disabled
if OP installed python3-sip then he's pointing at the wrong repository: there's no python3-sip in the unofficial repository for current.

also if OP is mixing package versions between this repository and others he's in for a lot of pain: for example, the scripts here have been tested with a specific qt5 version so if you install a more recent one (5.13.x instead of 5.9.x) the things that use it as a dependency most probably won't work.
 
Old 09-08-2019, 09:42 AM   #9
spike86
Member
 
Registered: May 2004
Distribution: Arch
Posts: 56

Rep: Reputation: 12
Speaking from personal expirience, I think ponce is right, there probably is a mixing of versions/repos that need to be fixed.

I solved it in this way:
removed ALL sbo-installed packages
removed ALL external packages (sbotools, sbopkg, etc.. keeping slackpkg-plus)
removed ALL alienbob-based packages

keeped all multilib packages installed through slackpkg (they are usually harmless)

then I installed sbotools (they are my choosed sbo manager, mixing sbotools and sbopkg was definitely wrong) and changed SLACKWARE_VERSION= to current (remember to chang jobs count too, or the next step will take forever)
update/create the local repo

then using ONLY sbo, point to the package that you want (in this case Mnemosyne), sbotools actually checks automatically for dependencies, sbopkg doesn't so you'll have to do this by hand
to check if you are using the correct (unofficial-unsupported) repo, there are several MISSING packages that are reported in the requirements. That's CORRECT, they are in the base Slackware-current installation. If you find all packages, then you are in the wrong repo!

finally compile everything (yes, INCLUDING THE WHOLE QT5!) that's because qt5 from sbo and qt5 from alien are different versions, for instance. alienbob has a NEWER version that doesn't work with some programs present in sbo-current.

then blacklist sbo-compiled packages in the slackpkg-plus conf:
/etc/slackpkg/blacklist
Code:
[0-9]+_SBo
that's necessary to avoid involuntary upgrading of the packages.

it should work then
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Best way to keep Slackware 14.1 current upto date with the latest packages Quicken2k Slackware 10 11-10-2014 09:22 AM
isntalling suggested and Recommended packages with apt-get kushalkoolwal Debian 14 05-08-2006 01:48 PM
using apt to install recommended packages? MaTrIx709 Linux - Software 2 08-12-2005 01:04 AM
Is there a parameter for apt-get to install all recommended / suggested packages? Akhran Debian 5 08-08-2005 02:42 AM
Superkaramba - Recommended packages? HCLogo Linux - Software 2 05-05-2004 10:24 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration