-   Slackware (
-   -   Realtek RTL8187L Wireless config and a strange (

DecioSP 02-08-2010 01:44 PM

Realtek RTL8187L Wireless config and a strange
Well, at first I need to tell that after having big problems (audio, video, modem, network,...) with my venture into slack world at about 7 years ago, I thought that even with my insistence it would be hard to get used with it.
Around the middle of December last year I decided to try again and again I had face some problems (now with fdisk and GPT support in a 64 bit machine).
But now, at about a month after that, I need to say that having passed those initial problems with installation, not only I manage to learn a lot about linux in general (dependencies, rc. editing, permissions, groups...) as I am amazing to what Slackware became.
From 3D graphics acceleration in KDE (with an easy config for my video card, something I thought it would be impossible and that makes it by far better looking than any Windows Desktop fancy try), to great programs and suites integration like Amarok, OpenOffice, Ktorrent, THE firefox, and so many others all allied with the full control of the system (no automatic updates, no mysterious packages UNLESS I really allow it) not to tell g++, python and so on.
However, besides a raid 0 non readable partition, I am having a persistent problem with my wireless that always mix my pppoe connection when I try to config it via rc.inet1 (or rc.wireless ...).
To better explain my situation I have a computer with Asus P5k-e/Wifi-AP with came with an integrated wireless device (Realtek RTL8187L).
Also, the way I work out to connect to the internet was through (an ethernet) pppoe connection setup using pppoe-setup.
Right now it is working like a charm after pppoe-start and stop commands.
At about a month, when i was starting my first steps to config my machine, I tried to follow three times, and in two of those I manage to start my wireless, but in all it mixed up with my pppoe connection and since either pppoe-config as pppoe-setup didn't work after that (even after backup the files) I had to reinstall the whole system. (Yes, I know that probably there is an workaround easier via shell or file editing, but since every time I need to restart in the Windows, search for solution on internet, print those I find, restart, and try in slackware again, I decided that reinstalling was the fast solution for me at that time.)
Now, I am a bit more confident with my knowledge of the linux and decided to try to setup wireless again.
After an extensive search in the forum, I found out two major solutions: One pointing to alienwiki (with I really think is the best approach besides my previous experience) and other pointing to the proper realtek driver at
As i am yet trying to decide which method use, I download the driver and it came with an strange file ( that are called by wlan0up.
Below are both files:


SYSTEM=`uname -r|cut -d. -f1,2`
if [ $SYSTEM = 2.4 ]
cd ieee80211
insmod ieee80211_crypt-rsl.o
insmod crypto-rsl.o
insmod michael_mic-rsl.o
insmod aes-rsl.o
insmod ieee80211_crypt_wep-rsl.o
insmod ieee80211_crypt_tkip-rsl.o
insmod ieee80211_crypt_ccmp-rsl.o
insmod ieee80211-rsl.o
cd ../rtl8187
insmod r8187l.o

else #2.6 kernel

cd ieee80211/
#insmod ieee80211_crypt-rtl.ko
#insmod ieee80211_crypt_wep-rtl.ko
#insmod ieee80211_crypt_tkip-rtl.ko
#insmod ieee80211_crypt_ccmp-rtl.ko
#insmod ieee80211-rtl.ko

cd ../rtl8187/
insmod r8187l.ko

cd ../

cp /etc/acpi/events


ifconfig wlan0 up

#iwconfig wlan0 essid linksys_lzm
#ifconfig wlan0

#! /bin/sh

if [ "$1" = "RFON" ]; then
        dbus-send --system --type=method_call --dest=org.freedesktop.NetworkManager /org/freedesktop/NetworkManager org.freedesktop.NetworkManager.setWirelessEnabled boolean:true
        echo "Now Polling Method Turn  RF ON !" >> /etc/acpi/events/RadioPowerTest
        dbus-send --system --type=method_call --dest=org.freedesktop.NetworkManager /org/freedesktop/NetworkManager org.freedesktop.NetworkManager.setWirelessEnabled boolean:false
        echo "Now Polling Method Turn RF OFF !" >> /etc/acpi/events/RadioPowerTest

Since the only RadioPower I know is the which apparently hasn't anything to do with my wireless, I decided to ask here if there is any relation or if anyone knows what this RadioPower does.
Also, I really would like to try the config using rc.inet1, but I am afraid to lose my connection again, so if anyone could provide a good restoration method I think I will stick with alienwiki.

Drakeo 02-08-2010 01:51 PM

please read. this it is about saving power on laptops.

Drakeo 02-08-2010 02:30 PM

on a wireless the rc.1 is not needed. you can use it. you are using the pppoe point to point protocol over a ethernet. That means you sign in to a html gateway then the password is kept in your modem. So if you reset the modem you must re-sign in again. the rc.inet.conf can bring the walan device up. but when you did your initial install you set of the netconfig and gave it a host name this program does this for you.
it wrote to the rc.inet1 and also if the wlan0 was seen it wrote to the rc.inet2 .
this can be done any time by assuming root in a console and typing pkgtool then re-run slackware scripts. choose netconfig.

ok that get the hardware working. but if you are using wifi. We have to think ether card and radio transponder and receiver. and yes you can type all this in. rc.dinet1.config. but not many people have done that since slack 10.0.
10.2 came with wireless tools with kde. it worked great for me. today for ppoe I would just use wcid from the extra and connect by ppoe. the is if you are connecting to a router.

but I really doubt you are connecting ppoe if you are using wireless. it would be static or auto dhcpd. the router will be connected to your dsl modem that uses pppoe. that can be configured from a ether or wlan card with the use of the html gateway.
after the pppoe is set and you open the connection for more than one Managed open. then you need to connect to the router. which is static or auto dhcp. pppoe is password protocol.
once it is set in the dsl modems html cookies it is set. then we connect to the wlan side.
If your modem is a router with wifi then it can all be done wireless. But if you read the info that comes with the routers. It will read the preferred method of setting the pppoe is hard wire ethercard..

#IFNAME[4]="wlan0" <---- un-comment this is default which tells the
#IPADDR[4]="" rc.dinet2 to load the device and put it to work.
#USE_DHCP[4]="yes" <---- un-comment this and it will try to connect at boot
#DHCP_HOSTNAME[4]="icculus-wireless" the rest is self explained.
##WLAN_RATE[4]="54M auto"
##WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=96389dc66eaf7e6efd5b5523ae43c7925ff4df2f8b7099495192d44a774fda16"

DecioSP 02-08-2010 02:50 PM

Thanks for the prompt response and for the enlightening article.

DecioSP 02-08-2010 03:36 PM

Well let stop dreaming go back to earth :-)
Firstly, I don't have wicd installed and it appears that slackbuilds only has it to 12.1, will I expected any problem using it in a 13.0 version?
Secondly, shouldn't i see the device name when using lspci? (it appears that the device isn't proper initialized)

00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 02)
00:01.0 PCI bridge: Intel Corporation 82G33/G31/P35/P31 Express PCI Express Root Port (rev 02)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 02)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 02)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 92)
00:1f.0 ISA bridge: Intel Corporation 82801IR (ICH9R) LPC Interface Controller (rev 02)
00:1f.2 RAID bus controller: Intel Corporation 82801 SATA RAID Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation G80 [GeForce 8800 Ultra] (rev a2)
02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8056 PCI-E Gigabit Ethernet Controller (rev 12)
04:03.0 FireWire (IEEE 1394): Agere Systems FW322/323 (rev 70)

Also, it doesn't appears in the ifconfig, only in the ifconfig -a:

eth0      Link encap:Ethernet  HWaddr 00:1d:60:02:82:2c 
          inet6 addr: fe80::21d:60ff:fe02:822c/64 Scope:Link
          RX packets:9417715 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7978391 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:8862740819 (8.2 GiB)  TX bytes:2313371626 (2.1 GiB)

lo        Link encap:Local Loopback 
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:26963 errors:0 dropped:0 overruns:0 frame:0
          TX packets:26963 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1652740 (1.5 MiB)  TX bytes:1652740 (1.5 MiB)

ppp0      Link encap:Point-to-Point Protocol 
          inet addr:  P-t-P:  Mask:
          RX packets:9413393 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7974063 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:8787234308 (8.1 GiB)  TX bytes:2137812034 (1.9 GiB)

wlan0    Link encap:Ethernet  HWaddr 00:15:af:28:ac:da 
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wmaster0  Link encap:UNSPEC  HWaddr 00-15-AF-28-AC-DA-00-00-00-00-00-00-00-00-00-00 
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

The last 2 only appears in ifconfig -a
Regards the code, I don't have a rc.inet.conf in /etc/rc.d, just a rc.inet1.conf, which has the code as you wrote.
I confess that i am little confused, probably because my lack of experience, and so i need to ask, if i just un-comment those part and save there is any possibility that i lost my connection via pppoe?
If it happens re-running slackware scripts as you said will allow me to make the pppoe setup again without changing any other feature. (it wont mix in video drivers, xconfig, ...)?

mRgOBLIN 02-08-2010 05:25 PM

wicd package is in /extra now

64-bit is here

DecioSP 02-08-2010 09:59 PM

Well, unfortunately wicd didn't solve my problem.
As instructed I edited rc.inet1.conf to make that the file looked as if netconfig has never been run.
But not only it didn't work, as it also mix up all my connection.
The good thing is that this time i manage to get the connection back to normal by uninstalling wicd via pkgtool, removing the rc.wicd, re-running netconfig scripts and editing rc.inet.
Also, i think i figure what could be giving problems with the my configuration.
My computer access is via an adsl modem which is connected in my ethernet card (eth0) through an pppoe connection, in this connection, my ISP automatic provides me a DNS address, IP info,..., every time i connect.
The only thing i need to access (besides the obvious hardware) is an user name provided by ISP (in the format and a password.
It appears to me that every time i try to put wireless to work, it demand an DNS address which i didn't have before i made the pppoe-start.
To try a better explanation, when i put wicd to work, i didn't find a "server" option to put in DNS address (as I have when using pppoe-setup) and also it didn't enable any place to storage my user-pass (in order to try a direct connection), besides the pppoe.config.
When I tried to manual input pppoe-start, it connected but didn't ping anywhere.
After all of this, I think i could resume my needs into solving one (or maybe all) of the following problems:
1 - I need to "inform" the wireless device (wlan0) that my connection to the internet is by the ethernet card (eth0) through a pppoe with DNS provided by ISP every time i connect. (Probably via inet1.conf, but where? WLAN_CHANNEL?)
2 - This wireless device (wlan0) need to get this info (somehow) to provide internet access to the other computers in the network via wireless. (IPADD[x]="server" is valid? or just USE_DHCP[x]="yes" is sufficient?)
3 - This one I don't know if its possible, but a computer in this network is working under Windows and has an wireless card controlled by a software that only accept (at least) WPA encryption. I would like to allow this also to connect the internet using my computer, but to do this i need either to enable WPA encryption as work in some way to connect an *nix based and a windows based in the same network.
Excluding 3 that could be skipped and transformed in a future project, i think the first two problems is essential to solve all of this.
I know it is a lot of work, but if anyone could provide at least some guidelines that i could try i would be grateful.
To finish, as you probably have already noted, i don't know much about linux yet, so I need to ask you to be a little patience in case i don't immediately figures out how to work out with what are you suggesting.

DecioSP 02-09-2010 09:05 PM

Lets update it a bit.
Once more I went through the step by step in and I made some progress.
Now I get this:

:/etc/rc.d# /etc/rc.d/rc.inet1 wlan0_restart
info, wlan0: sending signal 1 to pid 6158             
info, wlan0: exiting                                 
/etc/rc.d/rc.inet1:  wlan0 information: 'Any ESSID'   
Error for wireless request "Set Nickname" (8B1C) :   
    SET failed on device wlan0 ; Operation not supported.
Polling for DHCP server on interface wlan0:             
err, wlan0: timed out                                   
warn, wlan0: using IPV4LL address


:/etc/rc.d# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0    IEEE 802.11bg  ESSID:"master"
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated
          Tx-Power=27 dBm
          Retry min limit:7  RTS thr:off  Fragment thr=2352 B
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0  Missed beacon:0

ppp0      no wireless extensions.


:/etc/rc.d# iwlist wlan0 scan
wlan0    No scan results

I Can't test if it is working as access point now, but I will do in the morning.
However, what could I do about those errors?

DecioSP 02-11-2010 01:29 PM


Drakeo 02-11-2010 02:11 PM

I am sorry I thought my first post made it clear what a pppoe is with adsl this goes way back to the old old program roaring penguin. if I missed it in your post I am sorry.
If you have a adsl connection you must have a dsl modem. now what is your router is it part of the modem or is it separate. the dsl modem works through a html gateway interface it keeps your login info on the dsl modem. so you need to configure your wifi router to login to the dsl modem and set it up that way.
If you have a dsl modem that is also a router and a wifi that is info needed.
if you want to connect automatically at boot with wifi than set up your wicd to use wlan0 to connect. not eth0

the dsl modem and your client that uses adsl pppoe to connect to the internet server. could care less what wifi router it is connected to. it looks for the dsl saved html page it reads it and connect to the clients server.
and in that html set up page is the option to open the connection.

Your goal from what I read is to boot up and use wifi card at boot and connect to your IP .

so set up your s connection with wicd and make life easy for you.

adsl pppoe is a staic conection that uses a password to connect.
wifi router connects to dsl modem dsl modem connects with adsl with a pppoe protocol. so use your wifi card to configure wifi router then in the wifi router there is option to connect adsl to your dsl modem.
power on power of
if your goal is different sorry.
Please move this thread to Network.

DecioSP 02-14-2010 02:55 PM


All times are GMT -5. The time now is 03:40 PM.