-   Slackware (
-   -   Realtek driver issues, solved, FYI (

JamesGT 02-11-2012 10:53 AM

Realtek driver issues, solved, FYI
Not sure how many people have this issue, or if it's been discussed, but with my new system (Asrock A75 Extreme6), it has a RealTek onboard nic. Slackware detects it as an R8169 and uses that driver, when it should use the R8168b driver.

My log showed constant "link up" messages in the logs, sometimes as often as every 5 or 10 seconds.

I found this info to remove the R8169 driver and install the R8168b driver.

Download r8168B driver:

tar vjxf r8168-8.023.00.tar.bz2

Remove r8169 driver:

rmmod r8169
Now install the downloaded r8168B driver:

cd r8168-8.023.00

load the r8168 driver:

modprobe r8168
Blacklist the r8169 driver to prevent it from loading again.

echo "blacklist r8169" >> /etc/modprobe.d/blacklist.conf
Now verify that the r8168B driver has been loaded and is in use now:

lsmod | grep r8168
I've had zero problems since following this. Just thought I'd pass it along for other AMD A8/Realtek NIC users.

H_TeXMeX_H 02-11-2012 12:21 PM

Thanks for the info.

JamesGT 10-17-2012 08:03 PM

Update for Slackware 14.
Recently I upgraded to Slackware 14, which still uses the R8169 driver for my NIC. Although better than before, it still have some issues so I reverted back to the R8168 driver. Updating is now easier if you need to use the R8168 driver.

You can go here...

Download the r8168-8.032.00.tar.bz2 driver, extract all the files then run and it will do all the work for you.

Restart your network, or reboot, and automagically the driver is installed.

All times are GMT -5. The time now is 06:40 AM.