-   Slackware (
-   -   realtek alc662 oss (

Ben Cobb 04-01-2008 10:01 AM

realtek alc662 oss
on an uptodate slackware 12.0 system with an onboard realtek alc662 rev1 sound card was having trouble with the sound.

So I uninstalled the alsa-lib and alsa-utils slackware packages and let the realtek install program reinstall them from the realtex audio package from their web site

this gives me sound (also a /dev/dsp) but when I reboot /dev/dsp is not recreated.

can get sound with alsa programs like kaffeine and get internet video/sound.

but xmms complains think it needs oss.

still have the alsa-oss slackware package installed. all three alsa programs are 1.0.15.

T3slider 04-01-2008 03:32 PM

That is definitely not an optimal way to upgrade ALSA. At this point I would recommend uninstalling whatever you installed (if it is even possible with the method of installation you used) and replacing the stock Slackware packages. Then, compile the new ALSA from source (or grab them from some place like and use the command `upgradepkg alsapackagename.tgz` as root (obviously replacing alsapackagename.tgz with the name of the updated package) and do the same for the other alsa packages (stock Slackware comes with alsa-lib-1.0.14a-i486-1, alsa-oss-1.0.14-i486-1, and alsa-utils-1.0.14-i486-1 -- you should compile/install the latest ALSA packages for each package). I am guessing that either the new ALSA packages you installed are not set up properly for a Slackware system or that they cannot use the older alsa-oss (or maybe you're using the updated 1.0.15 alsa-oss too? You said you 'still' have the Slackware package installed, but unless you're running -current instead of Slackware 12.0 you should have alsa-oss-1.0.14).

Good luck...

Ben Cobb 04-01-2008 04:23 PM

thanks for the reply - I started with alsa packages which i had upgraded to 1.0.15 and when setting up this machine found that /dev/dsp hadn't been created. that's why I tried to let realtek audio pack install the alsa stuff even though they provided the same 1.0.15 (but no als-oss)

generally don't like to install anything but a slackware package but thought I would try this. It came with the motherboard on a CD. this was a new machine with a blank hard drive (no os).

couldn't get internet to work either (verizon dsl) untill I ran a script from the same CD. (think this might be install 139 on a dozen machine).

T3slider 04-01-2008 04:31 PM

Ah, I understand now. Unfortunately I can't come up with much advice other than running `alsaconf` as root to try to detect your card, followed by `alsamixer` as your normal user (try muting and unmuting the sound and turn up the volume as high as it will go), followed by `alsactl store` as root every time you update alsamixer. Good luck -- if all else fails, Slackware 12.1 should be coming out within the next few weeks (that's pure guessing though) and it'll contain updated alsa packages and a newer kernel, so you may have better luck then.

Ben Cobb 04-01-2008 05:09 PM

thanks - I do that often - if something don't work wait for the upgrade
system is on my cousin's computer and with alsa he can do dvd's and hear internet sound (he has never heard of or will ever use xmms or audacity.)

glad all my other machines work.

seems like as soon as I finish an install it is time to upgrade again,
expect 12.1 will be able to use as an upgrade rather than clean install.
11 to 12 upgrading didn't work as had previous upgrades for me.

(keep a spare system on the hd)

All times are GMT -5. The time now is 01:00 PM.