-   Slackware (
-   -   Re: Dual booting Redhat 9 and Slack 9.1 (

MunCH 06-10-2004 08:40 PM

Re: Dual booting Redhat 9 and Slack 9.1
Hi all, well I have usually always dual booted with windows and a linux distro, but I decided to give XP the flick, and some how I have come unstuck. I usually had XP @ hda1, then a 200Mb /boot in hda2 then linux installed at hda3. However I put a 200Mb /boot sector @hda1
installed Redhat 9 on hda2 with grub, then I installed slack on hda3 without a boot loader, and I'm having a bit of trouble getting grub to boot slackware, everything I have tried so far hasnt worked, heres my grub.conf:

# grub.conf generated by anaconda
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/hda2
# initrd /initrd-version.img
title Red Hat Linux (2.4.20-8smp)
root (hd0,0)
kernel /vmlinuz-2.4.20-8smp ro root=LABEL=/ hdb=ide-scsi
initrd /initrd-2.4.20-8smp.img
title Red Hat Linux-up (2.4.20-8)
root (hd0,0)
kernel /vmlinuz-2.4.20-8 ro root=LABEL=/ hdb=ide-scsi
initrd /initrd-2.4.20-8.img
title Slackarse Linux 9.1 (2.4.22)
root (hd0,2)
kernel /vmlinuz root=/dev/hda3 hdb=ide-scsi


I have seen some posts with +chainloader and things like that, I wouls really like to get grub going before I recompile my kernels.

Thanks a bunch for your help


ringwraith 06-10-2004 09:02 PM

I don't use grub (lilo here), but the last line of the Slackware area (maybe it doesn't like being called Slackarse) kernel /vmlinuz.........
looks wrong to me since it is in /boot/vmlinuz, maybe try that edit and see.

MunCH 06-10-2004 09:34 PM

Thanks ringwraith, you saved my day again :newbie:

Cheers, I'll give it a shot


aikempshall 06-11-2004 07:02 AM

What error does GRUB return when you try to boot slackware.

Isn't it a bit dangerous sharing the boot partition between RH and Slackware. If I remember correctly doesn't an instalation of RH set up a symbolic link to it's kernel as vmlinuz thus overwriting your slack kernel.


MunCH 06-11-2004 05:40 PM

aikempshall, I didnt install a boot loader when I installed slackware, but anyway I get this error:

root (hd0,2)
file system type is ext2fs,
partition type 0x83
kernel /vmlinuz root=/boot/vmlinuz bdb= ide-scsi
Error 15: file not found

Press any key to continue.....



Andrew Benton 06-11-2004 06:01 PM

Like ringwraith said, that should be

title Slackarse Linux 9.1 (2.4.22)
root (hd0,2)
kernel /boot/vmlinuz root=/dev/hda3 hdb=ide-scsi

MunCH 06-11-2004 07:20 PM

Thanks Andrew, I did try that with no luck.



ringwraith 06-11-2004 11:36 PM

Munch, look more carefully at the lines. you changed the root= not the kernel location. Use exactly what Andy wrote.

aikempshall 06-12-2004 02:50 AM

When MUNCH wrote that <I installed slack on hda3 without a boot loader> my guess is that Slackware was installed in one partition (hda3) , boot and all, in which case my favoured writing of GRUB would be

title slackware
kernel (hd0,2)/boot/vmlinuz root=/dev/hda3 hdb=ide-scsi

as /root is on the third partition /dev/hda3
and the kernel is in the boot directory of the third partition

Also If I've got two distros on a machine I would want to have a swap partition.

Can Munch see the Slackware /boot/vmlinuz on /dev/hda3 from RH by using mount?


MunCH 06-12-2004 04:29 AM

aikempshall, I did try ringwraiths suggestion, though it didnt work to start with, now it does lol;)

though I omitted the hdb=ide-scsi because my dvd-r wasnt working, anyway it works now, thanks a lot guys, I'll paste the grub.cof file once I boot into redhat again incase anyone has a similar problem.



OK, not sure why this didnt work first time around:

title Slackware Linux 9.1 (2.4.22)
root (hd0,2)
kernel /boot/vmlinuz ro root=/dev/hda3

ringwraith 06-12-2004 08:55 AM

Glad it worked out Munch. From the outputs you posted above, it just looks like you mistyped the first time. Now if ony we can wean you away from RH, we will then own your soul ;-)

MunCH 06-13-2004 05:23 AM

Mwah ha ha ha:D , I seem to break my linux installations all to easily, I might just leave redhat on till I get RHEL WS, and do all my kernel compiling and experimental stuff on slack, havent mastered that puppy as yet, again thank you for your help.


All times are GMT -5. The time now is 05:32 PM.