LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 02-10-2005, 02:40 PM   #1
Ipolit
Member
 
Registered: Nov 2003
Location: Bulgaria
Distribution: Vector Linux, Morphix
Posts: 319

Rep: Reputation: 33
rc mouse and keyboard


Can you give me an advice
How could I disable the mouse and the keyboard in the console after the system is loaded? With an rc script, automatically
I will not use X.
thaks
 
Old 02-10-2005, 03:02 PM   #2
keefaz
LQ Guru
 
Registered: Mar 2004
Distribution: Slackware
Posts: 6,325

Rep: Reputation: 757Reputation: 757Reputation: 757Reputation: 757Reputation: 757Reputation: 757Reputation: 757
First you will need gpm package after install it, chmod +x /etc/rc.d/rc.gpm and
/etc/rc.d/rc.gpm start

If you have problem after that try :
/var/log/setup/setup.mouse
 
Old 02-10-2005, 03:06 PM   #3
Ipolit
Member
 
Registered: Nov 2003
Location: Bulgaria
Distribution: Vector Linux, Morphix
Posts: 319

Original Poster
Rep: Reputation: 33
I mean disable
I don't want'em to work
 
Old 02-10-2005, 03:12 PM   #4
keefaz
LQ Guru
 
Registered: Mar 2004
Distribution: Slackware
Posts: 6,325

Rep: Reputation: 757Reputation: 757Reputation: 757Reputation: 757Reputation: 757Reputation: 757Reputation: 757
Sorry my bad for reading wrong

Just chmod -x /etc/rc.d/rc.gpm should suffice,
maybe do a /etc/rc.d/rc.gpm stop before

But why do you want disable the keyboard ?
 
Old 02-10-2005, 03:25 PM   #5
Phathead
Member
 
Registered: Sep 2003
Distribution: Slackware 10.1, Slamd64 10.1, IpCop 1.4
Posts: 125

Rep: Reputation: 15
A few ideas:

Slackware will boot without a keyboard attached. Have you tried just unplugging the keyboard and mouse? It sounds like you don't need them at all, so why not unplug them?

If you have a USB keyboard and mouse, you can remove the kernel modules for them. I don't remember the names off hand, but if you do 'lsmod' you'll see what modules are running. You can either blacklist those modules in /etc/hotplug/blacklist or put some rmmod commands in your /etc/rc.d/rc.local. Blacklisting is more permanent because if you run rmmod, the modules will be re-inserted by unplugging and replugging the keyboard or mouse.

What is the goal of this? I'm assuming physical security is a problem and you'd prefer that no one be able to even try to log in. If so, make sure you edit your /etc/lilo.conf file to add a line that says restricted and another that says password="" Combined in the global section of lilo.conf, you will be prompted for a password when you run lilo. This password will restrict entering boot options at the lilo prompt to those who know the password. Check 'man lilo.conf' for details. Without this, your computer can be compromised by power cycling it and entering single user mode from the lilo prompt. Be sure to re-run lilo after you make changes.
 
Old 02-10-2005, 03:34 PM   #6
Ipolit
Member
 
Registered: Nov 2003
Location: Bulgaria
Distribution: Vector Linux, Morphix
Posts: 319

Original Poster
Rep: Reputation: 33
I don't want to recompile the kernel
How can I delete them from /proc?
 
Old 02-10-2005, 03:40 PM   #7
Phathead
Member
 
Registered: Sep 2003
Distribution: Slackware 10.1, Slamd64 10.1, IpCop 1.4
Posts: 125

Rep: Reputation: 15
Unless you've built a custom kernel that doesn't support loadable modules, you do not need to rebuild it. Blacklisting the modules does not require a rebuild. Also, changing the lilo configuration has nothing to do with rebuilding the kernel.

I don't know if deleting them from /proc will do anything for you. I'm pretty sure they'd either be recreated at bootup or it would destroy your system. You're welcome to try, but I don't know what will happen.
 
Old 02-10-2005, 04:30 PM   #8
Ipolit
Member
 
Registered: Nov 2003
Location: Bulgaria
Distribution: Vector Linux, Morphix
Posts: 319

Original Poster
Rep: Reputation: 33
I found in /lib/modules/2.4.22/kernel/drivers/input
keybdev and mousedev
put them in /etc/hotplug/blacklist
installed the original 2.4.22 but the keyboard and the mouse are working
 
Old 02-10-2005, 04:41 PM   #9
Phathead
Member
 
Registered: Sep 2003
Distribution: Slackware 10.1, Slamd64 10.1, IpCop 1.4
Posts: 125

Rep: Reputation: 15
The blacklist is only for devices controlled by hotplug (USB and Firewire mostly). If you have PS/2 keyboard and mouse, that route won't work.

Try rmmod on those two modules and see if that works. With PS/2, it should not be automatically re-enabled if you unplug and re-plug it. Just put the commands in your /etc/rc.d/rc.local. There will be no way to re-enable these modules without some kind of remote login like ssh or telnet.
 
Old 02-12-2005, 03:07 AM   #10
Ipolit
Member
 
Registered: Nov 2003
Location: Bulgaria
Distribution: Vector Linux, Morphix
Posts: 319

Original Poster
Rep: Reputation: 33
I don't think that it's possible to rmmod compiled into kernel
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
PS/2 Keyboard and Mouse king_kilr Linux - Hardware 1 11-22-2005 02:23 PM
No Keyboard and mouse Ahmed Slackware - Installation 7 09-22-2005 08:23 AM
Mouse and Keyboard mtecknology Linux - Hardware 1 06-22-2005 03:14 PM
no keyboard or mouse in X gyost Debian 19 09-22-2004 07:47 AM
USB mouse, keyboard, hid, console mouse problems jqcaducifer Linux - General 1 08-05-2003 09:43 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration