LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-12-2005, 08:49 AM   #1
sbirnie
LQ Newbie
 
Registered: Apr 2005
Distribution: Slackware
Posts: 1

Rep: Reputation: 0
Question rc.local not running?


I just recently installed Slackware 10.1 onto a machine. Unfortunatly my current box is RedHat (which Slackware will replace) so I'm a little off on how things are setup.

This is my current rc.local file:
Code:
#!/bin/sh
#
# /etc/rc.d/rc.local:  Local system initialization script.
#
# Put any local setup commands in here:
/etc/webmin/start >/dev/null 2>&1 </dev/null # Start Webmin
/usr/local/squid/sbin/squid
When I startup the box, neither webmin or squid has been started. Anyone know what might be going on? Where I can look for some info?
 
Old 04-12-2005, 09:11 AM   #2
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Is /etc/rc.d/rc.local executable?
 
Old 04-12-2005, 12:51 PM   #3
haze
LQ Newbie
 
Registered: Feb 2004
Posts: 16

Rep: Reputation: 0
chmod 755 /etc/rc.d/rc.local
 
Old 04-12-2005, 02:34 PM   #4
dkpw
Member
 
Registered: Sep 2003
Location: Scotland
Distribution: LinuxMint16 & Ubuntu 12.0.4 LTS
Posts: 218

Rep: Reputation: 30
Quote:
Originally posted by haze
chmod 755 /etc/rc.d/rc.local
Yep, that's the command to use! See this thread.

dkpw

Last edited by dkpw; 04-12-2005 at 02:37 PM.
 
Old 04-12-2005, 10:58 PM   #5
chedjuer
LQ Newbie
 
Registered: Jul 2004
Posts: 1

Rep: Reputation: 0
i am a newbie. i just install no-ip on suse 9.2. When i went to "/usr/local/bin" and tried to run "noip2" on the command line i got the error message: "bash: noip2: command not found". BTW, i loggin as root.
Do you guys know what happened to me????
thanks
 
Old 04-12-2005, 11:12 PM   #6
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
This is not a Suse forum but I guess we can help you anyway.
When you said you installed it, where did you did it? My noip2 executable is on /usr/local/sbin/
To find out where is the file use this command: find /usr -iname noip2
That should locate noip2 file for you and then you can cd to that directory and run it with ./noip2 or write the full path (if it's on /usr/local/sbin) like /usr/local/sbin/noip2
 
Old 04-13-2005, 01:18 AM   #7
trey85stang
Senior Member
 
Registered: Sep 2003
Posts: 1,091

Rep: Reputation: 41
Re: rc.local not running?

Quote:
Originally posted by sbirnie
I just recently installed Slackware 10.1 onto a machine. Unfortunatly my current box is RedHat (which Slackware will replace) so I'm a little off on how things are setup.

This is my current rc.local file:
Code:
#!/bin/sh
#
# /etc/rc.d/rc.local:  Local system initialization script.
#
# Put any local setup commands in here:
/etc/webmin/start >/dev/null 2>&1 </dev/null # Start Webmin
/usr/local/squid/sbin/squid
When I startup the box, neither webmin or squid has been started. Anyone know what might be going on? Where I can look for some info?
Did you install a webmin package.. or install from source?? if you installed a package, webmin can be enabled on startup by the following

chmod +x /etc/rc.d/rc.webmin

Same for squid if you installed a binairy package...

You can get the binairy packages from linuxpacakges.net
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Running X as local user Ephracis Linux - Software 1 11-05-2004 04:07 PM
help with running MRTG on local computer debloxie Linux - Newbie 1 10-05-2004 12:14 PM
rc.local not running at boot anthjaz Fedora 7 05-12-2004 01:40 PM
rc.local not running on boot??? Evilone Linux - Software 1 09-08-2003 01:01 PM
running program in local directory bob10a Linux - General 6 11-04-2002 06:48 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration