LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-19-2020, 03:04 PM   #1
bl0tt0
Member
 
Registered: Aug 2005
Location: The Glorious People's Republic of Austin
Posts: 160

Rep: Reputation: 26
rc.cgconfig fails with syntax error after PAM integration on -current


Hey all,

Just wanting to check whether this is a phenomenon unique to my system. I recently ran the update to -current that integrates PAM (via slackpkg upgrade-all and slackpkg install-new to catch the additional packages), and after running those commands, it seems that I can no longer initialize my cgroups via the rc.cgconfig script:

Code:
root@rackware:~# /etc/rc.d/rc.cgconfig start
Starting cgconfig service: error at line number 49 at daemons/lxc:syntax error
Error: failed to parse file /etc/cgconfig.conf
/usr/sbin/cgconfigparser; error loading /etc/cgconfig.conf: Have multiple paths for the same namespace
Failed to parse  /etc/cgconfig.conf
That 'multiple paths for the same namespace' error seems to be kind of nebulous, from the Googling I have already done (there are bug reports referencing comments at the tail end of a config file as a potential cause, for instance). For reference, this is the cgconfig.conf I am trying to load (based off of Chris Willing's guide to running unprivileged LXC containers):

Code:
group daemons/lxc { 
    perm {
        task {
            uid = root;
            gid = users;
        }
    admin {
          uid = root;
          gid = users;
      }
  }

  cpuset {
      cgroup.clone_children = 1;
      cpuset.mems = 0;
      cpuset.cpus = 0-3;
  }
  cpu {}
  cpuacct {}
  blkio {}
  memory { memory.use_hierarchy = 1; }
  devices {}
  freezer {}
  net_cls {}
  perf_event {}
  net_prio {}
}
As I mentioned, this was working prior to the last update, and I do see that the libcgroup package was bumped in order to integrate PAM. Has anyone else running cgroups via the cgrulesengd run into issues following the last update?

Thanks!
 
Old 05-19-2020, 03:20 PM   #2
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.2
Posts: 3,668

Rep: Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013
Anything useful in https://www.linuxquestions.org/quest...ge-4175631668/ ?
 
1 members found this post helpful.
Old 05-19-2020, 03:42 PM   #3
bl0tt0
Member
 
Registered: Aug 2005
Location: The Glorious People's Republic of Austin
Posts: 160

Original Poster
Rep: Reputation: 26
Quote:
Originally Posted by Richard Cranium View Post
Actually, it looks like libcgroup needed to be rebuilt with LANG=C set. Thanks, Richard Cranium!
 
Old 05-19-2020, 04:11 PM   #4
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.2
Posts: 3,668

Rep: Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013
Maybe, maybe not. If you recompile it yourself and it fixes your problem, email Mr. Volkerding with the details. You could have your name in the changelog!

FWIW, my real world name *is* in the changelog (well, not a recent changelog) for something like that.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to run rc.cgconfig roberto967 Slackware 15 08-19-2019 05:14 AM
cgroups in rc.S and in rc.cgconfig Lockywolf Slackware 10 06-13-2019 12:40 AM
[SOLVED] cgconfig failed sindh Linux - Newbie 1 10-27-2014 01:17 AM
/etc/pam.d/system-auth-ac vs. /etc/pam.d/password-auth-ac vs. /etc/pam.d/sshd christr Red Hat 2 08-01-2014 07:08 PM
C++ syntax error before :: token HELP, i cant find the syntax error :( qwijibow Programming 2 12-14-2004 06:09 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration