LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 10-27-2012, 10:36 AM   #1
Chelyuk
LQ Newbie
 
Registered: Sep 2012
Posts: 15

Rep: Reputation: Disabled
rc.alsa doesn't run on startup


I have a problem, that alsa doesn't apply it's config on sturtup. I thought there was a problem with alsa, but if I run /etc/rc.d/rc.alsa manualy it works. So why it doesn't work automaticaly?
Code:
root@samsung:/etc/rc.d# ls -l | grep alsa
-rwxr-xr-x 1 root root  2771 сент. 11 01:11 rc.alsa
 
Old 10-27-2012, 11:08 AM   #2
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2 on Lenovo Thinkpad W520
Posts: 7,701

Rep: Reputation: 2618Reputation: 2618Reputation: 2618Reputation: 2618Reputation: 2618Reputation: 2618Reputation: 2618Reputation: 2618Reputation: 2618Reputation: 2618Reputation: 2618
Looks weird... Did you edit /etc/rc.d/rc.M in any way?
 
Old 10-27-2012, 12:12 PM   #3
Chelyuk
LQ Newbie
 
Registered: Sep 2012
Posts: 15

Original Poster
Rep: Reputation: Disabled
No, I didn't edit /etc/rc.d/rc.M.
I'll try to describe something more about my problem. All started when I noticed that, microphone in skype doesn't work. Then I've understood that microphone doesn't work in whole system(I can't record my voice). In alsamixer I saw that "digital" and "capture" channels were on zero level. I have increased the levels, exit from alsamixer and made "alsactl store". But when I restart X-session or reboot, "digital" and "capture" were on zero level again. If I make "alsactl restore" it applies my changes but just until the restart X-session or reboot. Then I've seen that /etc/rc.d/rc.alsa should do the "alsactl restore" by itself. I reboot the system and make "/etc/rc.d/rc.alsa restart "digital" and "capture" channels increased as I saved in alsa.
But I don't understand why it doesn't happening on startup? rc.alsa is executable and it should runs, inside:
Code:
...
# A function to load the ALSA mixer settings:
load_alsa_mixer() {
  if [ -r /var/lib/alsa/asound.state ]; then
    echo "Loading ALSA mixer settings:  /usr/sbin/alsactl restore"
    /usr/sbin/alsactl restore
  else
    # It's possible a user might not want to set a default sound state.
    # In that case, do this:  touch /var/lib/alsa/no.asound.state
    if [ ! -r /var/lib/alsa/no.asound.state ]; then
      echo "Setting default ALSA mixer settings."
      # set default mixer volumes for ALSA
      # Taken from the alsaconfig script.
      amixer -s -q <<EOF
...
/var/lib/alsa/asound.state - is present and saving after "alsactl store"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Script run at startup doesn't work under Ubuntu 10.04 LTS DSchuler Linux - Newbie 6 05-03-2011 07:42 PM
I run Fedora 9 and I boot from USB, how I run at startup Firewall and antivirus? gginis Linux - Software 3 06-08-2008 03:19 AM
Apache on startup...doesn't startup! Madley Linux - Server 5 11-24-2006 02:22 PM
ALSA Startup error, MPlayer startup error, Sid andymadigan Debian 4 08-03-2004 04:15 PM
startup script to set up iptables rules doesn't run alexfittyfives Debian 2 06-01-2004 07:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration