-   Slackware (
-   -   Razor-qt (

GasPipe 12-19-2011 04:55 AM

I was reading phoronix this morning and noticed this:
Razor-Qt: A New Qt-Based Desktop Environment

This DE looks very interesting and I was wondering if any of you guys have tested it?
Looks like it has very few dependencies.

Here's a link to the homepage if someone is interested.

ponce 12-19-2011 05:39 AM

for fun, I tried to assemble a quick slackbuild

you can test it yourself, if you want (it needs openbox) ;)

P.S. I built it here on slackware64-current with multilib and alienbob's qt-4.7.4, but who knows, could build also elsewhere :)

Alien Bob 12-19-2011 07:12 AM

Funny, both Robby Workman and myself also created SlackBuild scripts for this after reading an article about Razor-Qt on LWN :-)

Robby's script is pending approval on , and I already created packages for it which I might upload. Openbox is not required by the way. Razor needs a Window manager, and apart from OpenBox, you could also use Fvwm2 or KDE's own kwin (I tried successfully with KDE 4.5.5 and Robby reported failure with the kwin in my KDE 4.7.4).

Funny also that both Ponce and I created an xinitrc.razorqt and added it to the package in the same way :-) Robby's version does some custom stuff with regard to XDG which I did not quite follow while I did a quick scan of his script.


ponce 12-19-2011 07:18 AM


Originally Posted by Alien Bob (Post 4553567)
Funny also that both Ponce and I created an xinitrc.razorqt and added it to the package in the same way :-)

lol, guess who I learned from? :D

btw, I followed dev's advices about openbox ;)

brianL 12-19-2011 07:28 AM

Proves the old saying: great minds think alike. :)

GasPipe 12-19-2011 08:42 AM

To be honest, I was thinking myself that Ponce would be interested and could do the buildscripts but this fast!?
And Eric too!

I'm happy that there are others who think this might be a good DE but unfortunately I don't have time to test it yet. Perhaps later this week.
I would also like to hear opinions about it if someone has the time to test it.
Anyway thanks Ponce, Eric and Robby!

GazL 12-19-2011 10:44 AM

One thing I noticed is the right click context menu tends to lag when opening. It feels nowhere near as responsive as the native openbox menu. Still, it's early days yet and the project has plenty of time to mature. In the long run I think it'll stand or fall on the quality of its plugins and whether they make the mistake of allowing it to feature-creep into bloatland like many of the other 'light' environments have.

It won't be tempting me away from my dwm+dmenu setup anytime soon, but I don't hate it and it's going to be one to keep an eye on as it matures. I wish the razor-qt devs well.

MTK358 12-19-2011 11:14 AM

I installed the AUR package and I'm using it right now, and it seems really nice (except for the fact that a few glitches and some of the settings are confusing to figure out, but that's expected with such new software).

brianL 12-19-2011 11:28 AM

Just got ponce's build running (using kwin, will try openbox later), on Slackware64 13.37. Not checked it out thoroughly, but it seems OK. Thanks.

brianL 12-19-2011 12:03 PM

Found something I'll have to sort out, keyboard layout's changed: it's swapped my @ and " over. Still the right one in System Settings.

brianL 12-19-2011 04:42 PM

I've got the correct keyboard layout (gb) in KDE's System Settings, in /etc/X11/xorg.conf.d/90-keyboard-layout.conf, so everything is OK in KDE4.6.5. But when I log into razorqt(kwin or openbox), I get the results mentioned in the above post, and can't find out how to change it, or why it's changed. Anybody any ideas?

bobzilla 12-20-2011 02:37 AM

1 Attachment(s)
As soon as I saw this I remembered I recently stumbled upon a small Qt based file manager called qtfm. It doesn't provide desktop icons, but it's low on dependencies (basically, requires only Qt4). You can get the build script from SBo.

May be of use to someone. ;)

Btw, I already wrote on the local Slack forum about Raptor-Qt and gave them the link to this topic. :)

P.S. Screenshot shows qtfm running on XFCE. I think you'll have to set your icon theme (and gtk style) in gtkrc-2.0 for QGtkStyle to recognize it under XFCE. Otherwise it would default to GNOME icon theme (as seen on the pic).

brianL 12-20-2011 09:27 AM

Solved my little problem by guesswork. Slacker's intuition. :) Ran razor-x11info, and got the right keyboard layout. Magic. :)

ponce 12-21-2011 07:47 AM

I've tried to prepare for slackware what the razorqt devs call a "full featured desktop", so I wrote the missing slackbuilds for qlipper, qtermwidget, qterminal, juffed, qxkb, qastools (contain qasmixer), ptbatterysystemtray, screengrab, qps and andromeda (you can see them in branches here).

I've avoided:
- nomacs, as it depends on qt >= 4.7.2, opencv and LibRaw (and BTW it segfaults).
- audio/video players, as they depend a lot on personal tastes ;)

I've pushed this stuff on my github repository for current (I've used Robby's razorqt buildscript, with the xdg magic), so if you use it with sbopkg, you can already run this queue yourself. :)


Some of this stuff look pretty young (plus there are only a few translations), but seems there are no stopping problems using it.

If you try these and confirm they're working fine, I'll submit the new scripts to :)

brianL 12-21-2011 08:29 AM

On 13.37, I created a queuefile (razorextras.sqf) and tried this:

For temporary usage

sbopkg -V SBo-git/current -r
, thinking that would mean I wouldn't have to alter my sbopkg.conf, but sbopkg still only acknowledges the 13.37 repo.

All times are GMT -5. The time now is 04:40 AM.