-   Slackware (
-   -   Random thoughts on browser choices/Firefox. (

jon lee 10-05-2013 01:45 PM

Random thoughts on browser choices/Firefox.
I was having some minor dbus issues between clementine and firefox. This prompted me to attempt to compile Firefox without dbus.
I found the mozilla esr17.0.9 source in slackbuilds. I made it through that with some fighting with some apparent memory problems on the final linking.

It works OK/Good, but it is branded nightly. I decided I wanted a real firefox brand and started searching for different source. Immediately I noticed that starting with version 18 and higher, two more modules are included in IPC (interprocess communication), 'unixsocket' and 'netd'. Not knowing what these are and how they effect security, I wonder if they should be included in the build (simple enough to strip them from the makefile)?

I also found that it's easy to eliminate some extraneous build options in configure:

./configure --prefix=/usr --disable-dbus --disable-gconf --disable-gnomevfs --enable-gstreamer
I know the above works. I would eventually like to test some other options. Which of these would be useful (or mess things up)?

./configure --prefix=/usr --disable-dbus --disable-gconf --disable-gnomevfs --disable-dbm --enable-gstreamer --enable-address-sanitizer --enable-llvm-hacks --enable-faststripe --disable-logging --enable-strip --enable-install-strip
I decided to try and compile v24 to see if it could be done and also gstreamer is supposed to work to give h.264/html5 support in this version.

1 gig of memory (and 1 gig of swap) isn't enough to compile v24. I finally got a straight answer out of ld, after fighting with it the same as v17.

I would usually get this:


collect2: error: ld terminated with signal 9 [Killed]
make[3]: *** [] Error 1
make[3]: Leaving directory `/home/slackjack/mozilla-release/toolkit/library'
make[2]: *** [libs_tier_platform] Error 2
make[2]: Leaving directory `/home/slackjack/mozilla-release'
make[1]: *** [tier_platform] Error 2
make[1]: Leaving directory `/home/slackjack/mozilla-release'
make: *** [default] Error 2

Or it would complain about some_file.o being truncated. I had this happening with v17 as well (had to finish compile in a straight terminal with no windows manager running). This isn't enough for v24.

It finally coughed up the real reason:


../../dist/lib/libjs_static.a: could not read symbols: Memory exhausted
collect2: error: ld returned 1 exit status
make[3]: *** [] Error 1
make[3]: Leaving directory `/home/slackjack/mozilla-release/toolkit/library'
make[2]: *** [libs_tier_platform] Error 2
make[2]: Leaving directory `/home/slackjack/mozilla-release'
make[1]: *** [tier_platform] Error 2

There was also a plain syntax error in the javascript code (rawSource when it was supposed to be raw_source).. rawSource not defined, raw_source warning defined in header but not used). That didn't give me much confidence. Made it through that and the stripping of the .def files.
Anyway, I can't make it through the final linking on v24 with 1 gig of mem... and barely made it through v17 (with the same issues).

This means I'm apparently stuck with v17. Is there a better browser choice out there? I was looking at icecat which explains the branding issue.
Or perhaps Midori browser?

Does anyone prefer one of these over Firefox? Any potential security issues with one or another?

Keith Hedger 10-06-2013 08:05 AM


...Xulrunner's build uses large amount of memory. On some systems, the RAM/Swap combination needs 6 GB available.
The Xulrunner buld is basically the same as firefox.

Have a look at BLFS if you are building from source as it has a lot of useful build/dependency info.

YellowApple 10-06-2013 03:09 PM


Originally Posted by jon lee (Post 5040603)
1 gig of mem

Upgrade your RAM and/or start adding swap; Firefox is notorious for exhausting RAM during compilation.

That said, Chromium works pretty well on Slackware. Might be worth a shot if you haven't already considered/tried it.

jon lee 10-06-2013 07:16 PM

Thanks for the links. I didn't think to look at LFS.
I made it through v17 again a second time. This time all the way through without any problems at all.
I'm tempted to try v24 with the separate libxul and see if that makes a difference.
It's about a 10-12 hour compile for me, so I have to build up motivation.

About Chromium... parts are built into firefox already.. under IPC - components. In fact it was through a strace that I tried to eliminate Chromium to begin with (Can't. Too many dependencies.)

aus9 10-06-2013 07:28 PM

I am blunter

Instead of paying more money to buy more RAM, pls consider going to a distro that is more related to x386
and see if they have web browsers that might suit your needs

I suspect some on that list are more intensive for RAM than I would prefer but thats your decision. But Slackware is not a hit which appears to be 486 and higher

While I am at it, I might as well advise you to look for smaller graphical engines
depending on your needs, LXDE springs to mind
but there a ton of DEs smaller than LXDE

good luck

ahh this might be easier to use, If interested

ttk 10-06-2013 10:40 PM

Have you tried firefox v16.0.2? It's been the most stable for me, of all the versions before and since. It's the first (and only) to prove more stable than v3.6, staying up for 45 days (give or take).

All times are GMT -5. The time now is 08:34 PM.