-   Slackware (
-   -   random system crash problem (

silkenphoenixx 10-06-2006 04:09 PM

random system crash problem
I have a terrible problem!

I just downloaded and installed slamd64 11.0 (I used to use regular slackware 10.2).
At random intervals the system just crashes! I really don't understand it! Symptoms are every now and again it just stops responding completely (even the music stopped playing - it just happened all at once) and I can't seem to identify a common denominator of what causes it.

I think I've narrowed down the suspects to two:
Bad memory - I doubt this one because not once did slack10.2 crash on the same system but to be sure I'm going to run memtest86 on the machine all night as soon as I post this...
Bad install disk - When I tried to install the first time I got a weird error when the setup app closed and it went back to the black screen and just kept saying "Segmentation Fault" over and over again. Once again this may be bad memory but it also may be a bad download (the md5's were fine, but it still may be problematic)

These are the only two possibilities that I can think of. Could there be anything else? I've never tried slamd64 before, but I doubt that it's as unstable as that. I can hardly keep the system up for 2 hours!

Has anyone else perhaps had a similar problem? Does anyone have some suggestions as to what a solution could be? (Re download / install / new memory or whatever is the case)

I'll report back in about a day with the results of my memtest.

Thanks in advance for the help

silkenphoenixx 10-07-2006 02:44 AM

Update: ran memtest86 all night and it's all clear, so I guess it's not that. I may just have to re-download and install...

Wim Sturkenboom 10-07-2006 03:45 AM

I have the same issue (non-responding) with Slackware 10.2 (32bit) on a Biostar CRU51-M9 with 1GB and Sata HD.

It completely freezes and after roughly 20 seconds it comes back to live again. I can not even switch to another terminal to run top to check what's going on. I have not done further analysis.

So you're not alone.

PS I run runlevel 3, so it's not an X issue.

petterah 10-07-2006 05:33 AM

Hi, perheps some module is causing all the pain? You could blacklist modules that hotplug runs if they don't work as they should :)


number22 10-08-2006 01:30 AM

turn on the high memory in kernel; and try out the smp kernel even you only one core;

Recompile your nic modules;

Check out your PSU; make sure you have enough juice for your computer.

Reinsert your memory modules

silkenphoenixx 10-09-2006 01:19 AM

Er... It could be a module... but... How?

I have never attempted fiddling with modules before, and as I said, previously under 32bit slackware 10.2 I NEVER had a system crash or anything similar. I've never tried waiting for it more than about 10 seconds, though, so I don't know if it comes right.

Because I never had any problems previously I'm pretty sure it's not the hardware (300w psu, intel 640cpu geforce6200, seagate160gb sata and 2 samsumg dvd writers, hardly enough to tax the psu I think)

The smp might be useful, because it doesn't seem to be using the hyper threading (ksysguard reports only one cpu, whereas when I ran fc5 it registered 2)

How would one go about blacklisting hotplug's modules? Or messing around with kernel modules? Is there and easy way, or should I switch to ubuntu? :-)

Another problem that I forgot to mention is that while I was installing slamd64 for the first time, I had a stage when the blue-screen of the installer program changed suddenly into a black screen with confused install-screen like text and "Segmentation Fault" interspersed. I reset and tried again and it seemed to work, that's why I inititally suspected a bad install disc. Thoughts?

Thanks for the help so far

All times are GMT -5. The time now is 01:43 AM.