-   Slackware (
-   -   RAM usage on Slackware 12.0 (

trashbird1240 09-05-2007 08:34 AM

RAM usage on Slackware 12.0
Howdy Forum,

I'll describe my observation and then I simply want to know

*if I should be concerned
*if anyone else has noticed this
*where can I begin to look to trace down the problem, if it is one

Relevant info: Slackware 12.0, with kernel, KDE 3.5.7 and Enlightenment DR17 from Slacke17 on both machines in Question. The big difference between these two machines is at home I have 1GB of RAM and at work I have 512MB.

Now, on to the "observation:"
At home I've been watching Abelson and Sussman's SICP lectures on Xine, downloading them using Bittorrent, which was Ktorrent under KDE and now Opera's bittorrent client. Also, I'm a habitual Emacs user; a typical session includes using Emacs, a browser (Konqueror or Firefox) and perhaps gv or xpdf, as well as a music player (Amarok, Emphasis or Audacious).

As I keep monitors running, I noticed I was using a lot of memory --- up to 99% of the available memory, with no swapping on both machines. I figured this was due to either (a) a large buffer in Emacs, or (b) the videos I was watching. I've adjusted a lot of things though, and none of it has an effect on the amount of memory usage.

I figured "Ah, I'm mostly just using Emacs, and not a lot of KDE applications, so I should use a 'light' window manager --- that ought to help." It's had no effect.

I'll note that this is a recent thing; before two weeks ago I'd say the average on either machine was around 130 MB.

I'll add that I've experienced NO performance problems, except when I activated "bling" in E17. I have also had a weird problem with the computer hanging up, but I don't think that is related.

Thanks for any discussion,

Gethyn 09-05-2007 08:56 AM

Are you sure this wasn't happening before? Just about every Linux computer I've ever used grabs most of the available memory and uses it to buffer things. This is by design, as programs etc that are loaded into RAM are much quicker to access than direct access from the hard drive.

Since you mentioned it, what was the problem with the system hanging up? Can you describe the symptoms?

hitest 09-05-2007 09:57 AM

I've found that my slack box is using a lot less RAM and the CPU usage is lower since I switched to using the JFS and I'm also using XFce 4.4.1.
What start-up services do you have running? I have only what I need running at boot-up.

trashbird1240 09-05-2007 10:14 AM

@hitest: I'm running KDM, sshd, a few others --- currently running enlightenment so there should be few if any KDE services running or shared libraries. I turned off mysqld because I didn't need it. I'm running reiserfs on all Linux partitions.

Here's the output of top:

top - 11:08:23 up  2:24,  3 users,  load average: 0.34, 0.22, 0.14
Tasks:  72 total,  2 running,  70 sleeping,  0 stopped,  0 zombie
Cpu(s):  2.4%us,  0.0%sy,  0.0%ni, 97.6%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:    507156k total,  497468k used,    9688k free,    66752k buffers
Swap:  997912k total,    2604k used,  995308k free,  160396k cached

 3041 root      15  0  155m  22m 7552 S  0.0  4.5  1:42.67 X                 
 3743 joel      15  0  150m  88m  14m S  0.0 17.8  1:28.75 audacious         
 3421 joel      15  0 58372  47m 6240 S  1.6  9.6  1:12.04 enlightenment     
 3757 joel      15  0 44584  35m 8852 S  0.0  7.1  0:37.30 emacs             
 5172 joel      15  0  173m  45m  17m S  0.0  9.2  0:19.43 firefox-bin       
  931 root      16  -4  2176  928  456 S  0.0  0.2  0:01.71 udevd             
    1 root      15  0  764  292  248 S  0.0  0.1  0:01.48 init             
 2936 haldaemo  18  0  2112  900  780 S  0.0  0.2  0:01.06 hald-addon-keyb   
    4 root      10  -5    0    0    0 S  0.0  0.0  0:00.60 events/0         
 2928 haldaemo  18  0  5188 3596 2324 S  0.0  0.7  0:00.37 hald             
 3023 root      15  0  1884  472  396 S  0.0  0.1  0:00.28 gpm               
 2935 haldaemo  15  0  2108  896  780 S  0.0  0.2  0:00.20 hald-addon-keyb   
  143 root      10  -5    0    0    0 S  0.0  0.0  0:00.15 kswapd0           
  142 root      16  0    0    0    0 S  0.0  0.0  0:00.14 pdflush           
  141 root      15  0    0    0    0 S  0.0  0.0  0:00.13 pdflush           
 3029 joel      15  0  4088 2556 1612 S  0.0  0.5  0:00.13 zsh               
 5191 joel      16  0  4088 2556 1608 S  0.0  0.5  0:00.13 zsh

@Gethyn: I'm not sure that this wasn't happening before, and I only switched to Slackware 12.0 on this box right before this started happening. The lock-up is detailed here.

As I said, I'm pretty sure this is no big deal; I've had no performance problems. However, it's still weird. If it's not weird, educate me ;)


perry 09-05-2007 10:46 AM

My machine was operating at 512 MB and then got upgraded to 1.5 GB. And I noticed a BIG difference in performance. With the 512 MB configuration my 1 GB swap was usually in constant motion and a 1/2 of my processor's time must have been spent dealing with swapping issues. After the memory upgrade not only is the swap partition never touched but I find I'm using less memory.

That's my story and I'm sticking to it!

- Perry

dracolich 09-05-2007 04:26 PM

It looks like the biggest memory-consuming apps are audacious, enlightenment, emacs and firefox. You said you tried a lighter window manager because you don't use many kde apps. Which wm did you try? And if you use a kde app from a lighter wm it's still going to load the required kde libs and any other overhead. I'm not familiar with enlightenment so I don't know how it behaves in different wms.

One thing you can try is to get a base memory reading from top. Boot into runlevel3 (multiuser commandline) so that no X or graphical login managers are running. As soon as you login run top and make a note of the memory usage. Now you have something to compare to after starting your wm and other apps. I would also get a number immediately after the wm is loaded, before starting any additional apps.

Maybe I overlooked it, but did you compare the home and work computers.

hitest 09-05-2007 10:36 PM

Fire Fox is very much a memory hog, if left running for hours it will eat up RAM. That along with the three other applications you're running probably explains why your unit is using almost all of the system RAM and going into swap. Have you thought about using Opera? It is very light and fast, full-featured. That may help you if you want to run all of those applications.
XFce is a very nice wm.

duryodhan 09-06-2007 02:30 AM

I have 1GB ram, out of which only around 14MB-50MB is ever free.
But cat /proc/meminfo tells me that

Cached: 625924 kB
SwapCached: 516 kB
Active: 318020 kB
SwapTotal: 2008116 kB
SwapFree: 2007548 kB

meaning basically that my applications are only using around 300MB, the rest is all cached. My HDD swap is never used. Thinking over it , it is correct... what do I achieve by keeping some RAM free?? it should always be used up fully , just that when I need it it should be easily available (which it the whole point of caching the memory).

So yeah, using up all memory isn't the problem

Maybe you could do cat /proc/meminfo and tell the output.

trashbird1240 09-06-2007 09:01 AM

Howdy Fellas,

@dracolich, I'm using Enlightenment (E17). I'm aware of the issue
with the shared KDE libs, so I'm avoiding KDE applications. That was
one of my ideas anyway, so it's all working out well. I exported my
Konqueror bookmarks, etc. I've also thought about using FVWM, but
I've had a few configuration problems and I'm at work, so you know...

Good suggestion about runlevel 3: I already did look at memory
consumption while logged in to a VT in runlevel 4, and with no WM
running, it's definitely lower, but still not as low as it was before.

@hitest: Yes I have more than considered using Opera, I've used it at
home and really enjoyed it. The built-in bittorrent client saved me
from firing up KTorrent. Firefox has a couple advantages, a big one
being MozEx, which allows me to grab mailto: links and edit things
like this posting in Emacs. If there's something similar for Opera,
I'll definitely look into it. I've also tried XFce, and it's cool,
but it crashed on me unexpectedly several times. The "pre not even
pre alpha don't use this if you don't want serious problems" E17 has
performed better. This is one of the biggest challenges of using free
(as in ice cream) software: there are lots of choices and they are
available right away.

@duryodhan -- I recalled a conversation last night my friend who works
at ITA software. He said he has a Linux workstation with 8 GB of RAM,
and it's always all taken up.

Thanks for the discussion --- I don't think this is a serious problem
and I'm going to stop worrying about it. Like I said, I have had no
performance problems. I'm still performing to my full capacity ;)


hitest 09-06-2007 07:31 PM

Hey Joel,

One thing I noticed when I switched from an ext3 file system to a JFS is that my CPU load went down quite a bit. I like the JFS, it is more efficient for me than ext3.

trashbird1240 09-07-2007 10:19 AM

Just to update you, I logged out of Enlightenment, then logged back in yesterday evening and the ram usage was way low and stayed low. INteresting...

By JFS, do you mean a particular "journaled file system" or the general category, that would include reiserfs? I think the /home is ext3, but the / is reiserfs at home. Both /home and / are reiserfs at work.


hitest 09-08-2007 09:54 AM


Originally Posted by trashbird1240 (Post 2884509)
Just to update you, I logged out of Enlightenment, then logged back in yesterday evening and the ram usage was way low and stayed low. INteresting...

By JFS, do you mean a particular "journaled file system" or the general category, that would include reiserfs? I think the /home is ext3, but the / is reiserfs at home. Both /home and / are reiserfs at work.


I mean the JFS offered by Slackware 12 as an option when you install Slackware 12. I prefer JFS over Reiser.
Good to hear your RAM usage is lower now:-)

All times are GMT -5. The time now is 05:52 PM.