LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-07-2011, 08:12 PM   #1
acummings
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 615

Rep: Reputation: 50
Ralink RT2500 wireless on 13.37 32 bit


I need how to get it to work with wpa2 or wpa (wpa_supplicant is installed). Thank you.

It's a Linksys pci wireless g hardware

Code:
root@SR1053:/home/al# lspci | grep 2500
00:08.0 Network controller: Ralink corp. RT2500 802.11g (rev 01)
Code:
root@SR1053:/home/al# lsmod | grep rt2
rt2500pci              12676  0 
rt2x00pci               3954  1 rt2500pci
rt2x00lib              25762  2 rt2500pci,rt2x00pci
mac80211              181473  2 rt2x00pci,rt2x00lib
cfg80211              122542  2 rt2x00lib,mac80211
eeprom_93cx6            1004  1 rt2500pci
I got connected using wicd, but to do so, I had to log onto my 2wire 2701b (a late att dsl gateway) and remove security.

I tried every security level on the router ie wpa2, wpa, wep and I matched each of those level inside wicd but wicd kept reporting "password bad"

With the router set on wpa2-psk a Windows 7 laptop wireless connect went right on quickly and worked excellently.

Does rt2500 support wpa2? How to get this RT2500 working with wpa2 or wpa?

I saw wireless.conf in /etc/rc.d (but haven't yet edited since unsure what to do). Thank you.

--
Alan.
 
Old 09-07-2011, 09:44 PM   #2
acummings
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 615

Original Poster
Rep: Reputation: 50
Hi. I'll share what further that I've got so far:

The "Configuring Your Network" link at

http://www.linuxquestions.org/questi...3/#post4109377

Also, many howto/helps located in

/usr/share/wpa_supplicant/*

--
Alan
 
Old 09-08-2011, 01:47 AM   #3
acummings
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 615

Original Poster
Rep: Reputation: 50
I've edited configs and I'm unable to locate where the next comes from.

Code:
root@SR1053:/home/al# /etc/rc.d/rc.inet1 wlan0_start
/etc/rc.d/rc.inet1:  wlan0 information: 'RT2500'
Error for wireless request "Set Nickname" (8B1C) :
    SET failed on device wlan0 ; Operation not supported.
 
Old 09-08-2011, 10:32 AM   #4
acummings
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 615

Original Poster
Rep: Reputation: 50
Has anyone had success with using wpa with Linksys pci wireless g (ralink rt2500)?

I don't know if the next is still applicable. I'll report back when I've had yet more time to try both this and more others if this doesn't do it.

http://rt2x00.serialmonkey.com/wiki/...n_rt2500_Howto

Code:
   Using WPA on rt2500

WPA isn't directly supported by the Linux Wireless Tools API, so you need to use |iwpriv| to enable functionality directly on the card:

# ifconfig eth-wifi up
# iwconfig eth-wifi channel 5
# iwconfig eth-wifi essid youressidname
# iwpriv eth-wifi set AuthMode=WPAPSK
# iwpriv eth-wifi set EncrypType=TKIP
# iwpriv eth-wifi set WPAPSK="wireless password"
# ifconfig eth-wifi 10.0.0.2
--
Alan
 
Old 09-10-2011, 03:01 AM   #5
acummings
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 615

Original Poster
Rep: Reputation: 50
Now I might compile a .39 kernel for this box (due to the May 19 news at the next url). Or (I saw refs to ralink rt2500 hardware as being "obsolete") so maybe I get me a later pci card wireless hardware?

Any experiences, thoughts on what the easiest route may be for me to get wireless up on this box? Ideas, suggestions, anyone?

http://linuxwireless.org/News/Archive

Quote:
May 19, 2011

Kernel 2.6.39 has been released with following important wireless changes:
<snip>
* rt2x00: fix hw crypto for WPA TKIP (Michael MIC failures)
http://www.linux.com/archive/feature/132701

Informative but just a tad bit dated by now.

--
Alan
 
Old 09-11-2011, 03:09 AM   #6
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
That hardware works fine under Linux and should work with WPA (I think I've used my card with the same chipset with WPA). Why don't you just use Wicd?
 
Old 09-14-2011, 03:47 AM   #7
acummings
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 615

Original Poster
Rep: Reputation: 50
Quote:
Why don't you just use Wicd
I did. But I always got the report of password bad per my 1st post:

http://www.linuxquestions.org/questi...7/#post4464405
 
Old 09-14-2011, 11:52 PM   #8
acummings
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 615

Original Poster
Rep: Reputation: 50
Thanks! I guess the wicd started working during bootup after a while.

It started working upon bootup!!

But (were I to disconnect) to attempt connect using the wicd applet it will not connect as it reports "password is bad"

Anyways, it's working with wpa2-psk. It connects upon bootup and I just leave it connected.

Also during bootup, I still get the next error that I've not yet found where this error is coming from

Quote:
root@SR1053:/home/al# /etc/rc.d/rc.inet1 wlan0_start
/etc/rc.d/rc.inet1: wlan0 information: 'RT2500'
Error for wireless request "Set Nickname" (8B1C) :
SET failed on device wlan0 ; Operation not supported.
Any ideas on and/or where to look?

--
Alan.
 
Old 12-25-2013, 04:30 PM   #9
nl1at
LQ Newbie
 
Registered: Mar 2004
Location: Uitgeest Netherlands
Posts: 26

Rep: Reputation: 15
Thumbs up Solved

Know this is while ago but ran into the same thing on slack13.
The SET NICK stuff comes from the rc.wireless script line 189 Which says "This is a bit hacktish"
If you comment out until it says "Regular stuff" the error massage is gone.
And it has no effect on your config.
Hope this helps some guys
 
Old 12-26-2013, 06:00 AM   #10
solarfields
Senior Member
 
Registered: Feb 2006
Location: slackalaxy
Distribution: Slackware, CRUX
Posts: 1,248

Rep: Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840
my old laptop had Ralink 2500... in my experience it worked better with the windows driver and ndiswrapper. oh, the irony! anyways, in case you want to give it a try, here's what i did on Slackware 14.0:

Install ndiswrapper-kernel and ndiswrapper-utils from SBo. The kernel source, should be present. Then, let’s check the hardware:
lspci | grep RT
lsmod | grep rt2500
iwconfig


The driver in use is rt2500pci. Blacklist it by creating a file /etc/modprobe.d/rt2500pci.conf (this may be different in 13.37), containing:

blacklist rt2500pci

More instructions are found in /etc/modprobe.d/README. Now navigate to the folder that contains the windows driver rt2500.inf and…

ndiswrapper -i rt2500.inf # install the driver
rmmod rt2500pci # unload the default driver
modprobe ndiswrapper # load ndiswrapper

Add the last line from above to /etc/rc.d/rc.local, so ndiswrapper is loaded automatically on boot.

Last edited by solarfields; 12-26-2013 at 06:02 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 10 - Wireless issue with RaLink RT2500 and DHCP silviap Fedora 7 03-17-2009 08:57 AM
Installing wireless network card Ralink RT2500 runnerpaul Linux - Newbie 1 03-16-2006 06:37 PM
wireless; ralink; rt2500; SuSE 9.2; Help jimbrook Linux - Wireless Networking 5 02-15-2006 02:01 PM
Cannot connect to Internet using Ralink rt2500 wireless NIC dsuratman Linux - Wireless Networking 2 09-04-2005 06:32 AM
Wireless Configuration Files; ralink rt2500 jimbrook SUSE / openSUSE 9 06-06-2005 03:07 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration