-   Slackware (
-   -   raid partition has no superblock (

Furlinastis 11-04-2007 06:45 PM

raid partition has no superblock
When I try to assemble a raid array in mirrored mode it fails giving me this:

mdadm --assemble /dev/md1 /dev/sda2 /dev/sdb2
mdadm: no recogniseable superblock on /dev/sda2
mdadm: /dev/sda2 has no superblock - assembly aborted

I have this problem only with mirrored and not striped. I even recreated some partitions as striped and now they work. What's odd is that if I boot the slackware CD and issue the build command they mount perfectly. I can see the contents of the partition. In other words, without the build command mirrored partitions don't mount.

I think I fixed that issue by using --create, but I'm not sure and it's not booting anyway.

Though when I boot my install it gave my a kernel panic error before, but now it interrupts the boot process and prompts for the root password and suggests doing fsck. Though I've tried what it suggests, fsck.ext3 -v -y /dev/md1 and fsck.ext3 -b 8193 and it still won't boot.

When I do: fsck.ext3 -b 32768 /dev/sda3 or md2, it goes through a routine where it fixes a bunch on inodes and directories, but it still won't boot.

I have tried reinstalling slackware and reformatting/reinstalling the file system using setup and still it gives me the same errors. I really doubt it's a hardware fault as my windows partition works fine. How can I manually write a superblock(using fsck or mdadm?) to the hard drive? Or is there something else I can do?

Furlinastis 11-10-2007 10:59 PM

Here's EXACTLY what it says when it interrupts the boot process:


Checking root file system:
fsck 1.39 (29-May-2006)
/dev/md2: The filesystem size (according to the superblock) is 2502123 blocks
The physical size of the device is 2502096 blocks
Either the superblock or the partition table is likely to be corrupt!

(i.e., without -a or -p options)

***An error occured during the root filesystem check*****
***You will now be given a chance to log into the ****
***system in single-user mode to fix the problem. ***
***'e2fsck -v -y <partition>' might help. ****

Once you exit the single-user shell, the system will reboot.

Type control-d to proceed with normal startup,
(or give root password for system maintenance):
If I press ctrl D then the system reboots.

If I do mdadm --examine /dev/<dev> the output looks normal.

Maybe this has something to do with it. When I created the partitions, I created them on /dev/sda and /dev/sdb but since I have a PCIe x1 sata controller, when I boot the system sda and sdb become sdc and sdd. While the hard drives on the sata controller take up sda and sdb. However, when I remove the sata controller I get the same results.

I really don't want to reformat and it didn't do me a lot of good before anyway. I've tried rewriting the partition table with fdisk and doing different things with fsck but I don't know if I did the fsck correctly. I did fsck.ext3 -fcv /dev/<dev> as well as what it said above.

The only thing I can think of is writing zeros to both hard drives with dd then reformatting again. But then I would have to kill my working windows partitions and back up all the crap that's on there and I don't really want to do that.

OH OH... It just popped into my mind. How did this all start? Well, chkdsk happened. Thank you M$ :) For whatever reason windows wanted me to do chkdsk and rather than using common sense and stop, I went along with the carpet bombing command that is chkdsk which hosed my boot sector forcing me to reinstall lilo. What I don't get is how is knackered the superblock so that even when rewriting it with linux commands doesn't help.

All times are GMT -5. The time now is 12:42 PM.