LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-04-2018, 03:47 PM   #16
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 current / Linux Mint / Debian / Void Linux
Posts: 8,114

Original Poster
Rep: Reputation: 1667Reputation: 1667Reputation: 1667Reputation: 1667Reputation: 1667Reputation: 1667Reputation: 1667Reputation: 1667Reputation: 1667Reputation: 1667Reputation: 1667

Quote:
Originally Posted by kingbeowulf View Post
BW-userx,

I am still not clear on your video source. DVD? Bluray? A rip from ffmpeg /mencoder or similar? AVI (wma, wmv from MS Windws?) and MKV are containers so its anybody's guess what's inside. the gst plugins do no include the actual codec - just a uniform interface - so you will need to add them.
Looks like you need from SBo:

libmp4v2 (mpeg4ip?) mpeg4 streams
libmp2 - for dvds
faac (the "other" aac codec)
lame/mpg123 - for mp3
xvidcore - for Divx/3vix
x265?

Does rage look for ffmpeg or vlc and use that? vlc is listed as a dep for "emotion_generic_players" so it my not be picking it up. Mplayer is included in Slackware: does it play the video/audio?

if you do a 'ldd usr/bin/rage' does it list any libs missing? also for gst-*?
movies are mp4 avi mkv all off the net.

e_bus is a depends for rage, and when I was messing terminology source it had a message that e_bus being added to some other E package, so getting that depens "e_bus" along is imposable now at least I have not found it in my searching.

it's strage, e .22 it has its addons terminology, ephoto, rage, extras. It is like rage should not be giving grief, I have every codec it needs installed, E put the e_bus and whatever else into a package and it is like they did not update there rage to look in that package for the depends. If that is also what is causing it to not completely work. as well as its icons in the file manager. its a slackbuild for E so I think who ever did it did not customize it to Slack . I used sbotools to install it. not I am thinking I should go look at the slackbuild to see what it is doing.

mplayer plays, xine plays, mpv plays and all of the default install of video players play.

rage no play. rage bad, bad rage bad.

Last edited by BW-userx; 06-04-2018 at 03:51 PM.
 
Old 06-07-2018, 12:37 PM   #17
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 current / Linux Mint / Debian / Void Linux
Posts: 8,114

Original Poster
Rep: Reputation: 1667Reputation: 1667Reputation: 1667Reputation: 1667Reputation: 1667Reputation: 1667Reputation: 1667Reputation: 1667Reputation: 1667Reputation: 1667Reputation: 1667
Quote:
Originally Posted by kingbeowulf View Post
BW-userx,

I am still not clear on your video source. DVD? Bluray? A rip from ffmpeg /mencoder or similar? AVI (wma, wmv from MS Windws?) and MKV are containers so its anybody's guess what's inside. the gst plugins do no include the actual codec - just a uniform interface - so you will need to add them.
Looks like you need from SBo:

libmp4v2 (mpeg4ip?) mpeg4 streams
libmp2 - for dvds
faac (the "other" aac codec)
lame/mpg123 - for mp3
xvidcore - for Divx/3vix
x265?

Does rage look for ffmpeg or vlc and use that? vlc is listed as a dep for "emotion_generic_players" so it my not be picking it up. Mplayer is included in Slackware: does it play the video/audio?

if you do a 'ldd usr/bin/rage' does it list any libs missing? also for gst-*?
I'm not sure about what current is doing with the codec's but rage is working fine, so far, as I just did a slackbuild on it, and installed it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] [Q]Kubuntu 14.04 Amarok Player and Video player not playing music and video sameer.n.soni Linux - Newbie 6 06-20-2014 01:46 PM
Help me get 2 ATI Rage XL Video Cards Going xmrkite Linux - Hardware 2 05-25-2009 11:37 AM
How do you use video in on ATI rage fury pro (128) to record from a video cam? ka9qlq Linux - Hardware 0 01-06-2005 07:48 PM
ATI 3D Rage Pro Video Card kystandardbred Linux - Hardware 4 02-14-2003 04:22 PM
ATI Rage Fury Pro - TV (S-Video) Out MasterC Linux - Hardware 3 06-30-2002 12:29 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 05:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration