LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-12-2005, 09:42 PM   #31
Erratio
LQ Newbie
 
Registered: Jul 2005
Location: MA, USA
Distribution: Custom from source
Posts: 9

Rep: Reputation: 0

Did you apply all three patches from a fresh install? If so then try doing the same with a 2.6.11 kernel and see if the problem persists.
 
Old 07-14-2005, 11:00 AM   #32
v1_ad
LQ Newbie
 
Registered: Jul 2005
Location: israel
Distribution: slackware 10.1
Posts: 13

Rep: Reputation: 0
Fine,
but DRI still doesn't work ...
 
Old 07-14-2005, 07:22 PM   #33
Erratio
LQ Newbie
 
Registered: Jul 2005
Location: MA, USA
Distribution: Custom from source
Posts: 9

Rep: Reputation: 0
DRI works fine for me, make sure that you didn't disable it as per the instructions in the other link I sent, and disable the DRI driver that's included with the Linux kernel.
 
Old 07-15-2005, 07:27 AM   #34
v1_ad
LQ Newbie
 
Registered: Jul 2005
Location: israel
Distribution: slackware 10.1
Posts: 13

Rep: Reputation: 0
You mean Option "no_dri" "yes" ,I don't use
and DRI disabled in my kernel

and I am still have to use 2.6.11.12
how sad...
 
Old 07-15-2005, 02:09 PM   #35
Atmchicago
Member
 
Registered: Apr 2003
Location: Baltimore
Distribution: Fedora
Posts: 220

Rep: Reputation: 32
Which is the DRI driver included in the Linux kernel? And how is it disabled? Is it the option called "Radeon" in the list of video cards?
 
Old 07-15-2005, 03:22 PM   #36
Erratio
LQ Newbie
 
Registered: Jul 2005
Location: MA, USA
Distribution: Custom from source
Posts: 9

Rep: Reputation: 0
The DRI option in the kernel is the "Direct Rendering Manager" under Device Drivers/Character Devices. I personally have it to be built as a module, but it's not loaded...you don't want it or any of the dependent modules loaded or compiled in since you're using a 3rd-party DRI module. I think the "Radeon" driver/module only works with certain cards but I don't know much about it at all since I know it doesn't work with mine. To use the drivers provided by ATI you want to use the "fglrx" driver and module.
 
Old 07-15-2005, 05:48 PM   #37
v1_ad
LQ Newbie
 
Registered: Jul 2005
Location: israel
Distribution: slackware 10.1
Posts: 13

Rep: Reputation: 0
Nether Direct Rendering Manager (XFree86 4.1.0 and higher DRI support)
and modules included in it selected (compiled) in kernel

I found another solition
I've installed NVIDIA
Now I have another problem with ati
It is how to remove control panel


...
 
Old 02-13-2006, 02:12 PM   #38
exvor
Senior Member
 
Registered: Jul 2004
Location: Phoenix, Arizona
Distribution: Gentoo, LFS, Debian,Ubuntu
Posts: 1,537

Rep: Reputation: 87
There is a post on the ATI knolgebase that addresses this issue. Unfountly it does not reslove this issue with the PCI express version of the x600 card.

I have an open ticket with ati and hopeing they work with me to find a resolution to the issue.

however i haveent attempted to load it on a 2.4 kernel or without drm ill have to check that.


Ill keep you updated on if i can get it to work .
 
Old 02-13-2006, 06:14 PM   #39
Atmchicago
Member
 
Registered: Apr 2003
Location: Baltimore
Distribution: Fedora
Posts: 220

Rep: Reputation: 32
To remove the control panel you have to remove the package you used to install the ATI drivers. If you didn't use a package, then I think the installer has an --uninstall option of some sort from the command line.
It definitely seems like nvidia is eating ati's lunch over linux support right now.
 
Old 02-24-2006, 10:53 AM   #40
exvor
Senior Member
 
Registered: Jul 2004
Location: Phoenix, Arizona
Distribution: Gentoo, LFS, Debian,Ubuntu
Posts: 1,537

Rep: Reputation: 87
Ok update.

I think i have narrowed it down to kernel options selected when building a kernel. The fedora core 4 kernel non recompiled will load the lastest ati drivers without crashing x. Actually its very stable. DRI however is disabled because i cannot find a way to disable it with this kernel. AKA i cannot recompile the kernel on Fedora (this is why i hate RH and Fedora)another distro is slackware 10.2. Without recompileing the kernel i can get ati driver to work properly no freeze in X. Afer i mess with it it Freezes even with dri off. So its some misterious kernel option that screws things up. I have a feeling its something to do with the apictimer because that gets all wacky on fedora unless i disable it with the noapictimer option on boot. Note: After downloading sources and recompileing a kernel with no DRI in Fedora 4 64bit i get same freeze. This is a total system crash but the mouse still moves oddly enough.

ATI the kernel dev's and Xorg all refuse to accept this as a problem.


my beef with the kernel dev's

lately they seam not to be intrested in fixing issues.
the apictimer issue has been around for almost 2 years and yet no kernel released resloves the issue. the only fix i can find is just to disable apictimer witch causes issues with PCMCIA and a host of other things.

the freeze issue here has been around for over a year now and yet Its posted over and over and over again and no solution.

if im missing something please let us know or if anyone has a solid resolution that resloves both ATI and open source radeon freeze please post.


thanks

Last edited by exvor; 02-24-2006 at 11:06 AM.
 
Old 02-24-2006, 12:01 PM   #41
lestoil
Member
 
Registered: Apr 2004
Location: new york
Distribution: win2k,ubuntu,sw13,arch,centos5.3
Posts: 815

Rep: Reputation: 31
From a debian reference if you have lappy or lcd screen try
Option MonitorLayout "LVDS,AUTO"
in /etc/X11/xorg.conf to avert the black screen after setting up the ati card.
I guess pci-e cards dont need agp module and the kernel needs the pci-e support built-in. Good thing we can use vesa driver until things can be worked out. There must be kernel config files available in install notes for lappys with working ati pci-e video cards. What an adventure linux can be! Sheech!

Last edited by lestoil; 02-24-2006 at 12:03 PM.
 
Old 07-03-2007, 06:14 PM   #42
exvor
Senior Member
 
Registered: Jul 2004
Location: Phoenix, Arizona
Distribution: Gentoo, LFS, Debian,Ubuntu
Posts: 1,537

Rep: Reputation: 87
I just found this again after trying to find a kernel bug number and I actually wanted to update anyone on this issue if they ever are trying to find help on it.


This problem occurs because of a incompatibility with the ati frame buffer driver and the X driver.

Remove the ati frame buffer driver and it resolves the freezing issue.

now back to my search to see if this problem was actually resolved in the recent kernel or not :P.

I am suspecting no as its a problem that occurs between diffrent projects.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Radeon X600 and Quake 3 NX-01 Slackware 2 11-15-2005 05:46 PM
help with radeon x600 rooster33 SUSE / openSUSE 10 11-02-2005 12:53 PM
Can't use a ATI MOBILITY RADEON X600 under mandrake 10 hpwit Linux - Hardware 0 10-13-2005 06:24 AM
Radeon X600, unknown chip? feeble2 Linux - Hardware 1 08-12-2005 07:20 PM
driver for ATI mobility radeon X600 mat_uk111 Linux - Newbie 7 07-22-2005 02:43 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration