LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-15-2010, 07:49 AM   #1
Josh000
Member
 
Registered: Aug 2009
Distribution: Slackware 13 64bit
Posts: 534

Rep: Reputation: 35
Radeon KMS and console question


Hello, I am sorry if this seems like a stipud question, but I cannot find the answer anywhere.

I am trying to compile kernel 2.6.33.2 and use the radeon KMS options. I last did this a few months ago following the instructions in the "Radeon KMS works!" thread.

I took my old .config and used make oldconfig, then made sure the appropriate sections were set with make menuconfig.

I remember that framebuffers should be disabled, so I did this.

When booting however, it states that no appropriate video modes can be found, and to choose from the options or scan for additional(which don't provide any further) with the highest being 80x60.

If framebuffer is disabled, how can I still have a high resolution console?

Last edited by Josh000; 04-15-2010 at 08:14 AM.
 
Old 04-15-2010, 08:35 AM   #2
the3dfxdude
Member
 
Registered: May 2007
Posts: 566

Rep: Reputation: 245Reputation: 245Reputation: 245
You need to build-in or modprobe radeon (w/kms) and fbcon. Make sure that radeonfb is blacklisted or not built.
 
Old 04-15-2010, 08:37 AM   #3
Josh000
Member
 
Registered: Aug 2009
Distribution: Slackware 13 64bit
Posts: 534

Original Poster
Rep: Reputation: 35
I did build in radeon (Rather than making it a module), and I am sure radeonfb is not builtin.

What do you mean by fbcon? Should I enable vesa fb or anything like that?

Last edited by Josh000; 04-15-2010 at 08:39 AM.
 
Old 04-15-2010, 09:16 AM   #4
dolphin77
Member
 
Registered: May 2009
Posts: 202

Rep: Reputation: 58
vladimir@darkstar:~$ cat /etc/modprobe.d/radeon.conf
options radeon modeset=1
 
Old 04-15-2010, 09:17 AM   #5
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
CONFIG_FRAMEBUFFER_CONSOLE should be 'm' or 'y'. If you build it as a module, make sure it's loaded *before* the radeon DRM module.

From your description, though, the fact that you get that video mode question makes me think you might be booting with a vga= option.

Adam
 
Old 04-15-2010, 02:20 PM   #6
Josh000
Member
 
Registered: Aug 2009
Distribution: Slackware 13 64bit
Posts: 534

Original Poster
Rep: Reputation: 35
Well, I have it working now which is pretty awesome.

CONFIG_FRAMEBUFFER_CONSOLE is indeed set to y, I am unsure what option it maps to in menuconfig. Nevermind I guess....

I did have one problem when trying to play quake, it causes firefox to crash with the error: XF86DGANoDirectVideoMode

Hae I left something out of the kernel? Quake never used to crash, it just used to be unplayably slow as I didn't have 3D acceleration working.

I did indeed have a vga= option in lilo.conf which I removed, and I notice a message that talked about waiting for firmware. Everything boots up fine eventually but it seems to do nothing for a while waiting for firmware?
 
Old 04-15-2010, 02:32 PM   #7
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
Can you post the output of 'dmesg'? You may need to just grab the firmware from: http://people.freedesktop.org/~agd5f/radeon_ucode/

Adam
 
Old 04-15-2010, 02:46 PM   #8
Josh000
Member
 
Registered: Aug 2009
Distribution: Slackware 13 64bit
Posts: 534

Original Poster
Rep: Reputation: 35
Hi Adam,

Thanks for your help. My dmesg output is attached. It seems that because it could not find the firmware acceleration was disabled? Would this cause the DGA error?

Also it looks like the firmware it wants is RV635_pfp.bin, which I don't see on the site you linked to?
Attached Files
File Type: txt dmesg.txt (30.1 KB, 10 views)

Last edited by Josh000; 04-15-2010 at 03:05 PM.
 
Old 04-15-2010, 03:10 PM   #9
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
No, the DGA error is something different.

First, let's deal with that... In your ~/.q3a/baseq3/q3config.cfg file change in_dgamouse from 1 to 0

DGA was deprecated long long ago. It seems to only impact some older games but, thankfully, dga mouse support can be disabled for all/most of them.

As for the firmware... Are you using an initrd by chance?

Adam
 
Old 04-15-2010, 03:24 PM   #10
Josh000
Member
 
Registered: Aug 2009
Distribution: Slackware 13 64bit
Posts: 534

Original Poster
Rep: Reputation: 35
I don't have a .q3a directory, just a .quakelive director. I've found the directory with config files and I'm look for where I can disable DGA.

Nope, not using an initrd.
 
Old 04-15-2010, 03:30 PM   #11
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
I'm not familiar with quakelive and I'm not able to test it at the moment, so we may have to revisit that once we get acceleration working.

Are you compiling radeon directly into the kernel or are you using it as a kernel module? If you're using it as a kernel module, see if /lib/firmware/radeon/RV635_pfp.bin exists. If it doesn't, check to see if that file exists inside the kernel source directory... Something like: /usr/src/linux-2.6.33.2/firmware/radeon/RV635_pfp.bin. If it exists there, copy it to /lib/firmware/radeon and reboot.

I have to say that I find this very odd. I never had this problem when I updated my kernel.

Adam
 
Old 04-15-2010, 03:49 PM   #12
Josh000
Member
 
Registered: Aug 2009
Distribution: Slackware 13 64bit
Posts: 534

Original Poster
Rep: Reputation: 35
OK, for QL in case other people want to know:

The file ~/.quakelive/quakelive/home/baseq3/qzconfig.cfg and the option is seta in_dgamouse "0"

I am compiling radeon directly into the kernel, and the firmware files exist exactly with the path you gave.

I will copy it and reboot..since I am not using radeon as a module, why would I still need to copy it though?
 
Old 04-15-2010, 04:00 PM   #13
Josh000
Member
 
Registered: Aug 2009
Distribution: Slackware 13 64bit
Posts: 534

Original Poster
Rep: Reputation: 35
OK, I rebooted after copying the firmware....it still seems to hang for a bit after it states it is requesting it and I still don't have acceeration. glxinfo |grep -i direct outputs nothing.
 
Old 04-15-2010, 04:08 PM   #14
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
Please show your /var/log/Xorg.0.log file and just the output of 'dmesg | grep drm'

Adam
 
Old 04-15-2010, 04:17 PM   #15
Josh000
Member
 
Registered: Aug 2009
Distribution: Slackware 13 64bit
Posts: 534

Original Poster
Rep: Reputation: 35
OK, files attached.
Attached Files
File Type: txt Xorg.txt (25.7 KB, 11 views)
File Type: txt dmesg.txt (1.4 KB, 7 views)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Radeon kms works! dolphin77 Slackware 147 01-05-2012 05:32 AM
Linux KMS Intel 865G: Hacking KMS to use vesa... or disable hardware acceleration eantoranz Linux - Hardware 1 08-01-2009 12:58 PM
KMS with radeon gives garbled screen with x onlyolli Linux - Software 0 06-29-2009 04:14 PM
LXer: TTM, Radeon KMS Support Goes Into Linux 2.6.31 LXer Syndicated Linux News 0 06-17-2009 06:11 PM
Radeon 7000 & console framebuffer plusminus Linux - Hardware 3 03-20-2004 03:36 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 06:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration