LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Radeon KMS and console question (https://www.linuxquestions.org/questions/slackware-14/radeon-kms-and-console-question-802170/)

Josh000 04-15-2010 07:49 AM

Radeon KMS and console question
 
Hello, I am sorry if this seems like a stipud question, but I cannot find the answer anywhere.

I am trying to compile kernel 2.6.33.2 and use the radeon KMS options. I last did this a few months ago following the instructions in the "Radeon KMS works!" thread.

I took my old .config and used make oldconfig, then made sure the appropriate sections were set with make menuconfig.

I remember that framebuffers should be disabled, so I did this.

When booting however, it states that no appropriate video modes can be found, and to choose from the options or scan for additional(which don't provide any further) with the highest being 80x60.

If framebuffer is disabled, how can I still have a high resolution console?

the3dfxdude 04-15-2010 08:35 AM

You need to build-in or modprobe radeon (w/kms) and fbcon. Make sure that radeonfb is blacklisted or not built.

Josh000 04-15-2010 08:37 AM

I did build in radeon (Rather than making it a module), and I am sure radeonfb is not builtin.

What do you mean by fbcon? Should I enable vesa fb or anything like that?

dolphin77 04-15-2010 09:16 AM

vladimir@darkstar:~$ cat /etc/modprobe.d/radeon.conf
options radeon modeset=1

adamk75 04-15-2010 09:17 AM

CONFIG_FRAMEBUFFER_CONSOLE should be 'm' or 'y'. If you build it as a module, make sure it's loaded *before* the radeon DRM module.

From your description, though, the fact that you get that video mode question makes me think you might be booting with a vga= option.

Adam

Josh000 04-15-2010 02:20 PM

Well, I have it working now which is pretty awesome.

CONFIG_FRAMEBUFFER_CONSOLE is indeed set to y, I am unsure what option it maps to in menuconfig. Nevermind I guess....

I did have one problem when trying to play quake, it causes firefox to crash with the error: XF86DGANoDirectVideoMode

Hae I left something out of the kernel? Quake never used to crash, it just used to be unplayably slow as I didn't have 3D acceleration working.

I did indeed have a vga= option in lilo.conf which I removed, and I notice a message that talked about waiting for firmware. Everything boots up fine eventually but it seems to do nothing for a while waiting for firmware?

adamk75 04-15-2010 02:32 PM

Can you post the output of 'dmesg'? You may need to just grab the firmware from: http://people.freedesktop.org/~agd5f/radeon_ucode/

Adam

Josh000 04-15-2010 02:46 PM

1 Attachment(s)
Hi Adam,

Thanks for your help. My dmesg output is attached. It seems that because it could not find the firmware acceleration was disabled? Would this cause the DGA error?

Also it looks like the firmware it wants is RV635_pfp.bin, which I don't see on the site you linked to?

adamk75 04-15-2010 03:10 PM

No, the DGA error is something different.

First, let's deal with that... In your ~/.q3a/baseq3/q3config.cfg file change in_dgamouse from 1 to 0

DGA was deprecated long long ago. It seems to only impact some older games but, thankfully, dga mouse support can be disabled for all/most of them.

As for the firmware... Are you using an initrd by chance?

Adam

Josh000 04-15-2010 03:24 PM

I don't have a .q3a directory, just a .quakelive director. I've found the directory with config files and I'm look for where I can disable DGA.

Nope, not using an initrd.

adamk75 04-15-2010 03:30 PM

I'm not familiar with quakelive and I'm not able to test it at the moment, so we may have to revisit that once we get acceleration working.

Are you compiling radeon directly into the kernel or are you using it as a kernel module? If you're using it as a kernel module, see if /lib/firmware/radeon/RV635_pfp.bin exists. If it doesn't, check to see if that file exists inside the kernel source directory... Something like: /usr/src/linux-2.6.33.2/firmware/radeon/RV635_pfp.bin. If it exists there, copy it to /lib/firmware/radeon and reboot.

I have to say that I find this very odd. I never had this problem when I updated my kernel.

Adam

Josh000 04-15-2010 03:49 PM

OK, for QL in case other people want to know:

The file ~/.quakelive/quakelive/home/baseq3/qzconfig.cfg and the option is seta in_dgamouse "0"

I am compiling radeon directly into the kernel, and the firmware files exist exactly with the path you gave.

I will copy it and reboot..since I am not using radeon as a module, why would I still need to copy it though?

Josh000 04-15-2010 04:00 PM

OK, I rebooted after copying the firmware....it still seems to hang for a bit after it states it is requesting it and I still don't have acceeration. glxinfo |grep -i direct outputs nothing.

adamk75 04-15-2010 04:08 PM

Please show your /var/log/Xorg.0.log file and just the output of 'dmesg | grep drm'

Adam

Josh000 04-15-2010 04:17 PM

2 Attachment(s)
OK, files attached.


All times are GMT -5. The time now is 10:16 AM.