-   Slackware (
-   -   Quota Limit reached (

Jeebizz 08-07-2007 03:46 PM

Quota Limit reached
Well, I just got a new printer, an HP OfficeJet J5780 All-in-one. Its nice, CUPS actually sees this printer, and I was able to set it up relatively easily, and test printed a page. I then went back and changed a few settings for the DPI output, and decided to try another test print, and was met with a quota error page...


Quota limit reached.

However I don't have any other jobs pending. I guess I missed something, but can't quite figure out what. How do I change the quota limit? :scratch:

tobyl 08-07-2007 04:21 PM

looks like you have got to get on the command line with lpadmin


Jeebizz 08-07-2007 04:30 PM

Thanks, I will have to play with lpadmin then.

Jeebizz 08-07-2007 06:00 PM

Well, it seems that it didn't quite work out. I decided to just completely turn off all quotas, so I issued the following command.

root@slacker:/home/slackuser# lpadmin -p HP_OfficeJetJ5780 -o job-k-limit=0 -o job-page-limit=0

But I am still getting a quota error. I didn't get any errors from the command, since I did specify the right printer name. What gives? :scratch:

This is what printers.conf looks like.

# Printer configuration file for CUPS v1.2.11
# Written by cupsd on 2007-08-08 18:21
<Printer HP_OfficeJetJ5780>
DeviceURI usb://HP/Officejet%20J5700%20series?serial=CN73HC40D404TB
State Idle
StateTime 1186605290
Accepting Yes
Shared Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
AllowUser slackuser
OpPolicy default
ErrorPolicy abort-job

tobyl 08-08-2007 01:39 PM

is there an error log in /var/log/cups?

sorry Jeebizz I'm not knowledgeable on HP printers

you might get some useful info here:
(I suppose you do have the Slackware hplip installed and if so, I think there is an rc file in /etc/rc.d for hplip)


edit: actually it seems only slackware >11.0 has hplip, before it was hpijs
you may wish to investigate if this makes a difference to you...

Jeebizz 08-08-2007 03:26 PM

Sorry, I failed to specify my version. I am running Slackware 12, and I made sure to enable hplip, since hplip was available in this version. I have looked at the hplip site at sourceforge, and it seems that hplip is the recommended default for deskjet, not hpjis. It seems that hpjis has been superseded by hplip. Anyways, this is the error log.

I [09/Aug/2007:15:26:13 -0500] Saving job cache file "/var/cache/cups/job.cache"...
I [09/Aug/2007:15:26:17 -0500] Listening to (IPv4)
I [09/Aug/2007:15:26:17 -0500] Listening to /var/run/cups/cups.sock (Domain)
I [09/Aug/2007:15:26:17 -0500] Loaded configuration file "/etc/cups/cupsd.conf"
I [09/Aug/2007:15:26:17 -0500] Using default TempDir of /var/spool/cups/tmp...
I [09/Aug/2007:15:26:17 -0500] Cleaning out old temporary files in "/var/spool/cups/tmp"...
I [09/Aug/2007:15:26:17 -0500] Configured for up to 100 clients.
I [09/Aug/2007:15:26:17 -0500] Allowing up to 100 client connections per host.
I [09/Aug/2007:15:26:17 -0500] Using policy "default" as the default!
I [09/Aug/2007:15:26:17 -0500] Full reload is required.
I [09/Aug/2007:15:26:17 -0500] Loaded MIME database from '/etc/cups': 34 types, 38 filters...
I [09/Aug/2007:15:26:17 -0500] Loading job cache file "/var/cache/cups/job.cache"...
I [09/Aug/2007:15:26:17 -0500] Full reload complete.
I [09/Aug/2007:15:26:17 -0500] Listening to on fd 0...
I [09/Aug/2007:15:26:17 -0500] Listening to /var/run/cups/cups.sock on fd 2...
I [09/Aug/2007:15:26:45 -0500] commptr=""
I [09/Aug/2007:15:26:45 -0500] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=22718)
I [09/Aug/2007:15:26:52 -0500] commptr="?op=print-test-page"
I [09/Aug/2007:15:26:52 -0500] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=22719)
I [09/Aug/2007:15:26:53 -0500] Denying user "guest" access to printer "HP_OfficeJetJ5780"...

tobyl 08-09-2007 11:08 AM

I don't see a problem there, I think the 'guest' account is for samba.
I'm running out of ideas.
I read in the hplip site (Technical Documentation > Man Pages) that there are a number of command-line tools, eg
hp-setup, hp-toolbox, hp-check, hp-info etc (I think you will find them in /usr/share/hplip)
Documentation for their use is on the site.
I would be tempted to remove the printer and start again (probably removing the files in /var/spool/cups at the same time). These tools may help you get the correct set-up.


intergrator 08-11-2007 03:45 PM

I tried this trick and it worked
I had the same problem with my HP 1018 printer with a CUPS warning of out of quota.

I unplugged it from you linux box and plugged the printer into my Wintindo laptop.
Did a print test and of course it worked, but then I plugged it back into the linux
box and it started printing again. I think the issues is with the flame ram in the
printer and not the linux box. There must be a file that get dump in windows.

Just thought I would pass it along. Hope it helps someone.

Jeebizz 08-11-2007 08:28 PM

It might be some option under the printer itself then. Anyways, I just got another computer, and I moved the printer to that computer. It acts like a printer server, and after I set it up, I still get a quota limit error, see this link: Hrmm..

Jeebizz 08-17-2007 03:38 PM

Well I'm still at a loss here. I tried unplugging the printer completely just to clear it's memory, and still nothing. Plugged it in my XP notebook, seems to have worked temporarily. I don't want to have to plug it into my xp notebook every few times just to get it to work again. There has to be a better solution.

guzzi 08-17-2007 07:44 PM

Quota limit reached
I ran into this with the new CUPS.

To overcome, as root, I opened a browser and entered http://localhost:631/printers

This brought up the CUPs admin screen.

After clicking the tab for printer, the is a place to set allowed users. Enter the user name that is causing the quota limit problem, and that should take care of it.

Jeebizz 08-17-2007 08:53 PM

I already did that. Also, this is not on my local host, but on another computer I specifically setup as a print server. I made sure to add my user name. Nothing. I'm rather disappointed in the CUPS docs. No real help there, plus no real way of configuring it through the cups web interface.

Jeebizz 09-27-2007 07:49 PM

Its been a while, and I wish to get back to this issue again. I have been scouring google and still no answer to this issue. Adding and removing doesn't change the quota status, so there is clearly a CUPS issue, but I tried all I can think of but still nothing. Anybody got any other suggestions?

letrafe 06-27-2008 09:01 PM

try this
I rember that this problem have
turned on when I have added a new user to printers privilege. So I have added this line " AllowUser myusername" in printers.conf and when I reboot (leaving the printer turned on) the problem was fixed

Jeebizz 06-27-2008 10:24 PM

Never thought of that, I will have to try that. This issue was so annoying because I still never resolved it so I decided to leave it for a while. I hope that your suggestion will finally work for me.

All times are GMT -5. The time now is 07:44 PM.