-   Slackware (
-   -   Question on Ati driver (

animeresistance 09-07-2011 07:22 PM

Question on Ati driver
Hi people ! :D

I got some questions about Ati drivers (more specific 9.3, i know it is too old), and the radeon firmware that comes with kernel

I have an AMDRS690 chipset (Radeon Xpress 1200 series) and it works well (slow effects but it is ok, i think), and i want to run a 3D simulator (webots) and it is too slow, so i ran the command: $ glxinfo |grep OpenGL to see what driver i'm using, for my surprise there's an Xorg R300 project.

$ glxinfo |grep OpenGL
OpenGL vendor string: X.Org R300 Project
OpenGL renderer string: Gallium 0.4 on RS690
OpenGL version string: 2.1 Mesa 7.9.2
OpenGL shading language version string: 1.20
OpenGL extensions:

So i searched with locate command to if there was a radeon driver, and it is a radeonhd driver under (/firmware). So i want to run a 3D simulator (webots) and it runs incredibly slow.

Does somebody knows how to enable 3D acceleration with radeonhd?
Or i will have to install the 9.3 drivers?
Any ideas?

adamk75 09-07-2011 07:28 PM

First, you can't use the radeonhd Xorg driver. That's for r500, r600, and r700 GPUs (x1600 through the HD4950, roughly). It's also only a 2D driver.

Second, you can't use catalyst/fglrx 9.3 on any modern distribution. If you do want to use that version of the proprietary driver, you will have to install a linux distribution from over two years ago.

Third, 3D acceleration for all the open source drivers (for radeon GPUs) is provided by Mesa. In the case of r300-r500 GPUs, the most capable version is the gallium3d driver that you are clearly using. If you are having issues with this particular driver, you should open up a bug report with the developers at


I take back my first sentence. You could use the radeonhd driver, I believe, since I think your RS690 qualifies. But, the rest of the point one still holds. radeonhd only provides 2D acceleration. radeonhd is also abandoned and unsupported. It does not support KMS, which would break 3D acceleration with the gallium3d driver (which requires KMS), making your performance even worse.

animeresistance 09-08-2011 05:23 AM

Thanksfor replying
Hi again ...

Thnaks for the info :D i will follow your advice ...

Well i updated to a newer version of mesa, but the performance is the same :( bad 3D performance. Maybe because i am making a big mistake. I also tried to make a xorg.conf, but slackware doesn't seem to see it (or maybe it is the same performance with or without a xorg.conf file?).

Anyway, i was wondering about the existance of xorg.conf.d ... so i googled it (does it is spelled right?), and i think i found that xorg.conf.d manages the modules of the original xorg.conf ... wonder if i can put the serverdisplay module in there ... hmm ..

Yep, i'll do it tomorrow .. now i'm sleepy.

animeresistance 09-11-2011 11:16 PM

Well, i think i got it.

This ol' bones is running 3D decent, but to do thins i updated mesa, radeon driver (xf86-video-ati) and added my device in the /xorg.conf.d directory....

Hope someday or somehow AMD give more support to the ol' bones drivers like RS690 ...

Maybe i should marry to nvidia's cards from now on ... :P

All times are GMT -5. The time now is 07:53 PM.