-   Slackware (
-   -   Question for the Network Gurus. (

cwizardone 12-17-2012 11:21 AM

Question for the Network Gurus.
This is an offshoot from two different threads, which will be attached below.

Background: My Internet connection is not always the best, but gets the job done. Every now and then I can connect, it appears, to the 'Net, but I can't go anyway. Zip, nada. I can get to the router, but that is as far as it goes.
So, many months ago, now, just for chuckles, when this happened, I fired up Tor and, lo and behold, I could get out. I've been doing this ever since whenever I can't get out via a "regular" connection.

So, the first question is, how can this happen? How can Tor tunnel out when a "regular" connection cannot be made?

I've had a similar experience with Konqueror, BUT when other browsers can get out via a "regular" connection, Konqueror cannot. However, you can configure Konqueror to use Tor or configure the KDE proxy system settings to use Tor, fire up Tor, and Konqueror will come to life.

So, that is the second question, how can konqueror get out via Tor, but cannot get out using the "regular" connect (when the "regular" connection is working properly)?

Here are the pieces from the other threads that triggered this question:


Thanks for the suggestion, but I've already tried that and it didn't make a difference. Konqueror will work now and then, but for the most part it is worthless as a browser. The same pages that pop right up with Opera or Firefox will not load at all with Konqueror.
OTOH, believe or not, inside of windows Xp and KDE for windows, Konqueror works
just fine.

Is the Internet connection dependent upon the drivers (modules)?
Or, can the modules, and, I guess, the quality thereof, affect the strength
and/or quality of the Internet connection?
I've been comparing the connections when in ms-winblows vs Slackware64.
It isn't scientific by any means, but I've been visiting the same sites, using the same software, i.e., browser, reading the same posts or playing the same videos, etc., etc., etc., all on the same box, i.e, the hardware is the same.
Unfortunately, in Slackware64 the connection appears to be inferior. By that I mean you can be, e.g., reading posts on a board such as this one and when you want to go back to the index page or "turn the page" the connections appears to have stalled or disappeared and you have to wait several seconds for it to come back to life, if it comes back at all. Sometimes it reappears after hitting the 'refresh' button. Doesn't matter if I'm using networkmanager or wicd, the results are the same.
In ms-winblows this not a problem. The signal is there and you can move to the next page immediately.
Is there a fix for this?

tronayne 12-17-2012 12:03 PM

You're saying you can get to the router -- does that mean that you have an actual router connected to a modem with a cable or do you have one of those combination modem-router things all in one box? Are you using wireless (your referenced post seems to indicate that you are) or do you have a cable connected from your system to the router? If it's wireless, how far apart (and through what, like walls, basements, attics, aluminum-backed insulation, out in the garage, whatever)? Got the thing on a metal file cabinet?

When you can't get to the Internet with a browser (any of them), can you open a terminal window and ping, say, If you do, say

ping -c 5
PING ( 56(84) bytes of data.
64 bytes from ( icmp_req=1 ttl=51 time=742 ms
64 bytes from ( icmp_req=2 ttl=51 time=993 ms
64 bytes from ( icmp_req=3 ttl=51 time=925 ms
64 bytes from ( icmp_req=4 ttl=51 time=990 ms
64 bytes from ( icmp_req=5 ttl=51 time=1096 ms

--- ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 6622ms
rtt min/avg/max/mdev = 742.827/950.089/1096.910/117.208 ms

you ought to get something real similar to the above (the above is a satellite connection which is a little slower than cable, DSL or fiber optic, well a lot slower than fiber optic, with a couple of round trips 22,500 mile up and down).

If you don't get the above or you can't ping anything, do you have DNS server addresses in /etc/resolv.conf or in the router setup? Don't rely on a modem or a router for DNS, they tend to lose their minds after a period of time: you should try one or the other (in the modem, in the router setup) or something like this in /etc/resolv.conf:

cat /etc/resolv.conf
search com

Those two addresses are Google's open DNS servers and you are free to use them. You don't need more than two DNS server addresses. Those are the addresses you might try (they're available roughly 100% -- ping them and see what you get in the way of time).

There are some other things you can do but it would be helpful to know what you have in the way of hardware first.

cwizardone 12-17-2012 06:20 PM


bash-4.2$ ping -c 5
PING ( 56(84) bytes of data.
64 bytes from ( icmp_req=1 ttl=52 time=71.1 ms
64 bytes from ( icmp_req=2 ttl=52 time=17.2 ms
64 bytes from ( icmp_req=3 ttl=52 time=24.0 ms
64 bytes from ( icmp_req=4 ttl=52 time=16.9 ms
64 bytes from ( icmp_req=5 ttl=52 time=21.4 ms

--- ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4005ms
rtt min/avg/max/mdev = 16.911/30.159/71.111/20.651 ms
It is a router, converted with the dd-wrt software to act as a repeater. It is sitting on top of the computer case (tower).
While I would like to do whatever is necessary to make the signal stable, which it is not, at this point I'm really more interested in how Tor can tunnel out to the 'Net when I can't make a "normal" connect. Just curious as to how that works. :)
Many Thanks.

cwizardone 12-19-2012 12:46 PM

It has to be the Linux drivers/modules.
I've been roaming around the Internet most of the morning in Xp and haven't had a problem. I booted over to Linux and the troubles, as usual, started.
One second the connection seems OK, then in the blink of an eye, it just plain disappears, like it decided to take a coffee break. Sometimes it comes back in 10 or 20 seconds. Sometimes it takes 2 or 3 minutes. Sometimes it never comes back, just goes for a walk never to be seen again.
Yet, again, this is not a problem in ms-windoze.
Don't know what to say....

acummings 12-19-2012 11:03 PM

Doing the next **worked wonders** for my formerly terrible internet on 13.37 (I first learned of it from Robby Workman here on the Slackware forum). But I've not a clue if it's what you need to do, blacklist ipv6.


al@P5Q:~$ cat /etc/modprobe.d/ipv6.conf
blacklist ipv6


cwizardone 12-20-2012 05:40 PM


Originally Posted by acummings (Post 4853404)
Doing the next **worked wonders** for my formerly terrible internet on 13.37 (I first learned of it from Robby Workman here on the Slackware forum). But I've not a clue if it's what you need to do, blacklist ipv6.


al@P5Q:~$ cat /etc/modprobe.d/ipv6.conf
blacklist ipv6


Thank you! :hattip:
That definitely seems to have helped.
I say, "seems" as the way things go around here it could just be the phase of the moon. :)
There is a major airport so far to the west of here you wouldn't know it existed as the majority of the time, the vast majority of the time, they use their north/south runways. Today they are using their east/west runways so I'm sensing a disturbance in the Force. :)
Thanks, again, and Merry Christmas!

acummings 12-20-2012 10:22 PM

I was perusing and just came across the next network related thread which does some troubleshooting on the DNS -- and, for the time being, has disabled ipv6.

Evidently both the ipv4 and the ipv6 kernel modules (drivers) are loaded and active by default.

(if this ipv4 -- ipv6 has anything to do with your issues) then you perhaps nailed it when you had stated "it's the drivers".

I do not know why Windows XP works.

So, I can't help but wonder: is Linux ahead of Windows in implementing ipv6? Or is it instead that Windows uses greater auto detection and auto turns off ipv6 when needed so as to not overly stall the network (internet)?

On Slackware, I've not been using ipv6 whatsoever ever since or even since before 13.37 was released.

And, AFAIK, there's currently only a limited amount of ipv6 in actual use on the internet -- but that, as time passes, ipv6 is eventually may take the place of ipv4.


cwizardone 12-21-2012 06:58 AM

Did some reading on ipv4 and ipv6 last night and you are correct.

I found this interesting, but guess it is a good thing if one stumbles upon a ipv6 listed site,


NOTE: Blacklisting a module does NOT prevent a module from being loaded if it is needed by a system service, regardless of the fact that it has been blacklisted. Besides, it does NOT prevent the module from being modprobe'd by root. You may want to disable IPv6 by aliasing net-pf-10 to off. Please refer to the section below for instructions. You may have read tutorials that teach you to append a line to "/etc/modprobe.d/blacklist", but in fact it is NOT RECOMMENDED to do so. It is more appropriate to write manual configurations to a separated file (i.e. local configuration file) whenever possible, so that the configuration files distributed by the system keep their original content. The following instructions create the file "/etc/modprobe.d/blacklist.local" by mimicking what is done by the Ubuntu installer (i.e. Debian installer) when "ipv6.blacklist=yes" is added to the kernel parameters during installation:
The entire article can be found at,

Basically, in SlackSpeak, he is saying to create the ipv6.conf as you suggested.

Thanks, again, Alan!

cwizardone 12-22-2012 04:03 PM


Originally Posted by acummings (Post 4854099)
...I do not know why Windows XP works.

So, I can't help but wonder: is Linux ahead of Windows in implementing ipv6? Or is it instead that Windows uses greater auto detection and auto turns off ipv6 when needed so as to not overly stall the network (internet)?...

Turns out that earlier versions of Xp, up through Xp service Pack 2, did not have support for ipv6.
Xp service pack 3 does have ipv6 support and that is the version I have installed in another partition. As said above, it worked, where Linux would not.

After blacklisting ipv6 in Linux the Internet connection has greatly improved, but, after turning off* ipv6 in Xp-sp3, that connection has dramatically improved. It is so much faster than connecting through Linux (all the same hardware) it is enough to make one consider switching to Xp and get it over with. Sometimes it seems we are chasing a 12 year old operating system and have yet to catch up.

Turning off ipv6 in win7 is not recommended.

*("netsh int ipv6 uninstall" in a dos box, without the quote marks, and then reboot.)

acummings 12-22-2012 10:52 PM

DNS lookups do seem to be a bit slow in Linux (does Win XP do more caching or etc. than Linux).

Some web pages have very many DNS lookups just for one web page because the web master chose to source so much from other outside servers/sites (especially so with ads). In some web browsers, near the bottom of the browser, you can watch or see all of the various urls (and each unique url has its own DNS lookup).

I had dnsmasq on Slackware and it rather noticibly sped up the internet. But I haven't gotten around to installing dnsmasq on the Slackware box I'm using now.

Since I do use the nameservers from my ISP (at&t DSL internet), I'm reliant on how fast or slow they are.

A year or two ago I had Squid on my former Slackware box. **Very very powerful.** Don't even bother to do name lookups on ads if you don't want to; instead, just have Squid substitute a place holder graphic right where the ad otherwise would be.

I was also caching DNS when I had Squid. I don't recall now if I had Squid or Dnsmasq do the caching. But I think I was using Dnsmasq in conjunction with Squid. It was by far the fastest (www web browsing) internet that I ever had.

Squid installed as a transparent proxy (if my memory serves me correctly). Did ad detection and did not do a name lookup for an ad but loaded my own placeholder graphic loaded right from my hard drive instead.

The proxy is like a man in the middle. So, with proxy, you have the power to deliver any web page to your browser ***totally as or however you desire*** (it's called dynamically on the fly rewriting the html).

Web masters probably do not like Squid.

Yes that www web browsing experience was a fast one. Saved a bunch of bandwidth too ie less name lookups and no ads loaded into web browser from a server across the internet.

Squid and dnsmasq have their own learning curve though.

Yep the icon probably detectws/shows I'm on my Win 7 lap -- not my favorite box. Slackware is still my favorite.


acummings 12-23-2012 01:22 AM

I just recalled yet another experience I had in Slackware having to do with the speed versus slowness of web pages loading while www web browsing.

It had to do with the firewall (iptables) configuration.

The internet (www web browsing) worked well whenever I used a firewall that was generated by Alien Bob's firewall generator (a search the forum should turn up the generator's www url).

Then I tried firehol via (and then I had a huge, slow www browsing problem)

I like the power of config with firehol. I had the config set for "trusted" ( but not .254 which is my router) and also for a "not trusted" (anything from the other or internet side of my internet gateway Just one NIC with a lan cable to the router.

With that setup, I could allow things on my trusted local lan that I didn't or wouldn't trust if coming from or going to the internet.

I sometimes ran smb (Samba) on my lan. I liked the freedom that setup gave me for just running whenever I wanted to my local lan only server services, Samba being one of them.

These same local lan servers/services were left out or excluded from the "non trusted" part of the firehol config.

It worked nicely except for the very slow/stuck/intermittent/frustrating www browsing. I didn't yet ever figure it out to get the www browse fixed. So I went back to using Alien's firewall generator and my www browsing works fine again.

What little bit I know about iptables though it does appear to be very very powerful. Perhaps powerful enough if set too secure that there would be sacrificed speed of www browsing (that's a guess on my part). Some misconfiguration likely was my problem on firehol.


tronayne 12-23-2012 10:15 AM

There is a little trick you can use to go around DNS (well, actually, not even get there to start with). If you add addresses and names to /etc/hosts of sites you frequently use, you won't even look at DNS.

Get the site address with ping, add it with the site name and maybe one or two aliases to /etc/hosts and you're good to go. The resolver looks there first.

Hope this helps some.

All times are GMT -5. The time now is 09:56 AM.