LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


View Poll Results: Do you use ndiswrapper?
yes 3 27.27%
no 8 72.73%
Voters: 11. You may not vote on this poll

Reply
  Search this Thread
Old 10-29-2004, 06:02 PM   #1
Axi0n
LQ Newbie
 
Registered: Oct 2004
Location: California USA
Distribution: Slackware 10
Posts: 11

Rep: Reputation: 0
Question about ndiswrapper


when I boot up my computer I have to
-modprobe ndiswrapper
-iwconfig wlan0 essid "MSHOME"
-iwconfig wlan0 key restricted <my key>
-ifconfig wlan0 192.168.2.25
-route add default gw 192.168.2.1


I have to add that EVERY time I boot up my pc ... its a bit annoying... any file I can edit to add those commands in so I can just boot into linux and not have to do all that??? I know I am lazy .... just looking for the easiest route.. plus gf dosent know crap about linux and she wants to check her mail in the morning while I am asleep so heh Thanks in advance
 
Old 10-30-2004, 06:07 AM   #2
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
You can put those commands in /etc/rc.d/rc.local file.
 
Old 10-30-2004, 03:20 PM   #3
kersten78
Member
 
Registered: Nov 2003
Location: Minneapolis, MN
Distribution: Slackware, Debian, Gentoo, openSuSE
Posts: 357

Rep: Reputation: 30
Exactly as gbonvehi said.
I'd just like to add one thing that I had to do. For some reason when I added the script to rc.local, none of the iwconfig settings would remain set. I was calling a script almost identical to what you have. For some reason, the commands would be executed to quickly and the iwconfig commands would run before the ndiswrapper module finished loading. Hence, nothing was set in iwconfig. I added a line "sleep 6" after "modprobe ndiswrapper" and it works every time now. Although the boot process takes 6 seconds longer now.
Hope this helps.
 
Old 10-30-2004, 05:00 PM   #4
Axi0n
LQ Newbie
 
Registered: Oct 2004
Location: California USA
Distribution: Slackware 10
Posts: 11

Original Poster
Rep: Reputation: 0
Thank you so much kersten78 works perfect now... I get to be lazy thanks againg guys...
 
Old 10-30-2004, 11:21 PM   #5
killerbob
Member
 
Registered: Oct 2004
Location: Ottawa, ON
Distribution: Slackware
Posts: 662

Rep: Reputation: 30
You may want to change your SSID to something other than MSHOME, as it makes it pretty obvious that you're using a Microsoft wireless AP.... that's the default setting on their hardware.

If you can, also set the AP so that it doesn't broadcast the SSID. You simply can't get 100% security on a wireless AP, but if you're interested in protecting your network, 75% is better than 25%.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ndiswrapper question stress Linux - Wireless Networking 5 11-28-2005 11:07 AM
ndiswrapper question karan101 Linux - Laptop and Netbook 10 09-17-2005 04:46 PM
NdisWrapper Question justintime32 Mandriva 2 04-01-2005 01:33 PM
NdisWrapper Question justintime32 Mandriva 5 02-23-2005 11:28 AM
ndiswrapper Question efanning Linux - Wireless Networking 7 02-02-2005 02:18 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration