LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-24-2020, 04:06 PM   #61
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 5,481

Rep: Reputation: Disabled

it's not enough: as an alternative to paste in this forum you can also use some services like https://pastebin.com or https://termbin.com for that (and post here the resulting links)

Last edited by ponce; 06-24-2020 at 04:07 PM.
 
Old 06-24-2020, 04:13 PM   #62
TheNutCase
Member
 
Registered: May 2016
Location: Columbia, South Carolina14
Distribution: Slackware 14.2
Posts: 334

Original Poster
Rep: Reputation: Disabled
On second thought, I think I may have found something (error-wise, that is):
Code:
[  7%] Generating ui_compressor_gui.h
cd /tmp/SBo/MuseScore-3.4.2/build.release/effects && /usr/lib64/qt5/bin/uic -o /tmp/SBo/MuseScore-3.4.2/build.release/effects/ui_compressor_gui.h /tmp/SBo/MuseScore-3.4.2/effects/compressor/compressor_gui.ui
/usr/lib64/qt5/bin/uic: error while loading shared libraries: libpcre2-16.so.0: cannot open shared object file: No such file or directory
effects/CMakeFiles/effects.dir/build.make:61: recipe for target 'effects/ui_compressor_gui.h' failed
make[3]: *** [effects/ui_compressor_gui.h] Error 127
make[3]: Leaving directory '/tmp/SBo/MuseScore-3.4.2/build.release'
CMakeFiles/Makefile2:877: recipe for target 'effects/CMakeFiles/effects.dir/all' failed
make[2]: *** [effects/CMakeFiles/effects.dir/all] Error 2
make[2]: *** Waiting for unfinished jobs....
[  7%] Building CXX object telemetry/CMakeFiles/telemetry.dir/qrc_telemetry_resources.cpp.o
cd /tmp/SBo/MuseScore-3.4.2/build.release/telemetry && /usr/bin/c++   -DQT_CONCURRENT_LIB -DQT_CORE_LIB -DQT_GUI_LIB -DQT_HELP_LIB -DQT_NETWORK_LIB -DQT_NO_DEBUG -DQT_OPENGL_LIB -DQT_POSITIONING_LIB -DQT_PRINTSUPPORT_LIB -DQT_QML_LIB -DQT_QUICKCONTROLS2_LIB -DQT_QUICKTEMPLATES2_LIB -DQT_QUICKWIDGETS_LIB -DQT_QUICK_LIB -DQT_SQL_LIB -DQT_SVG_LIB -DQT_TESTLIB_LIB -DQT_WEBCHANNEL_LIB -DQT_WEBENGINECORE_LIB -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINE_LIB -DQT_WIDGETS_LIB -DQT_XMLPATTERNS_LIB -DQT_XML_LIB -DTELEMETRY_DISABLED -I/tmp/SBo/MuseScore-3.4.2/build.release/telemetry -I/tmp/SBo/MuseScore-3.4.2/telemetry -isystem /usr/include/qt5 -isystem /usr/include/qt5/QtCore -isystem /usr/lib64/qt5/./mkspecs/linux-g++ -I/usr/include/qt5/QtGui -isystem /usr/include/qt5/QtNetwork -I/usr/include/qt5/QtTest -I/usr/include/qt5/QtQml -I/usr/include/qt5/QtQuick -I/usr/include/qt5/QtQuickControls2 -I/usr/include/qt5/QtQuickTemplates2 -I/usr/include/qt5/QtQuickWidgets -I/usr/include/qt5/QtWidgets -I/usr/include/qt5/QtXml -I/usr/include/qt5/QtXmlPatterns -I/usr/include/qt5/QtSvg -I/usr/include/qt5/QtSql -I/usr/include/qt5/QtPrintSupport -I/usr/include/qt5/QtConcurrent -I/usr/include/qt5/QtOpenGL -I/usr/include/qt5/QtHelp -I/usr/include/qt5/QtWebEngine -I/usr/include/qt5/QtWebEngineCore -I/usr/include/qt5/QtWebChannel -I/usr/include/qt5/QtPositioning -I/usr/include/qt5/QtWebEngineWidgets -I/tmp/SBo/MuseScore-3.4.2 -I/tmp/SBo/MuseScore-3.4.2/build.release -I/usr/include/freetype2 -I/tmp/SBo/MuseScore-3.4.2/thirdparty -I/tmp/SBo/MuseScore-3.4.2/mscore -I/tmp/SBo/MuseScore-3.4.2/global  -O2 -fPIC  -std=gnu++11 -fPIC -O2 -DNDEBUG -DQT_NO_DEBUG -DQT_NO_DEBUG_OUTPUT   -fPIC -std=gnu++11 -o CMakeFiles/telemetry.dir/qrc_telemetry_resources.cpp.o -c /tmp/SBo/MuseScore-3.4.2/build.release/telemetry/qrc_telemetry_resources.cpp
[  7%] Building CXX object telemetry/CMakeFiles/telemetry.dir/telemetry_automoc.cpp.o
cd /tmp/SBo/MuseScore-3.4.2/build.release/telemetry && /usr/bin/c++   -DQT_CONCURRENT_LIB -DQT_CORE_LIB -DQT_GUI_LIB -DQT_HELP_LIB -DQT_NETWORK_LIB -DQT_NO_DEBUG -DQT_OPENGL_LIB -DQT_POSITIONING_LIB -DQT_PRINTSUPPORT_LIB -DQT_QML_LIB -DQT_QUICKCONTROLS2_LIB -DQT_QUICKTEMPLATES2_LIB -DQT_QUICKWIDGETS_LIB -DQT_QUICK_LIB -DQT_SQL_LIB -DQT_SVG_LIB -DQT_TESTLIB_LIB -DQT_WEBCHANNEL_LIB -DQT_WEBENGINECORE_LIB -DQT_WEBENGINEWIDGETS_LIB -DQT_WEBENGINE_LIB -DQT_WIDGETS_LIB -DQT_XMLPATTERNS_LIB -DQT_XML_LIB -DTELEMETRY_DISABLED -I/tmp/SBo/MuseScore-3.4.2/build.release/telemetry -I/tmp/SBo/MuseScore-3.4.2/telemetry -isystem /usr/include/qt5 -isystem /usr/include/qt5/QtCore -isystem /usr/lib64/qt5/./mkspecs/linux-g++ -I/usr/include/qt5/QtGui -isystem /usr/include/qt5/QtNetwork -I/usr/include/qt5/QtTest -I/usr/include/qt5/QtQml -I/usr/include/qt5/QtQuick -I/usr/include/qt5/QtQuickControls2 -I/usr/include/qt5/QtQuickTemplates2 -I/usr/include/qt5/QtQuickWidgets -I/usr/include/qt5/QtWidgets -I/usr/include/qt5/QtXml -I/usr/include/qt5/QtXmlPatterns -I/usr/include/qt5/QtSvg -I/usr/include/qt5/QtSql -I/usr/include/qt5/QtPrintSupport -I/usr/include/qt5/QtConcurrent -I/usr/include/qt5/QtOpenGL -I/usr/include/qt5/QtHelp -I/usr/include/qt5/QtWebEngine -I/usr/include/qt5/QtWebEngineCore -I/usr/include/qt5/QtWebChannel -I/usr/include/qt5/QtPositioning -I/usr/include/qt5/QtWebEngineWidgets -I/tmp/SBo/MuseScore-3.4.2 -I/tmp/SBo/MuseScore-3.4.2/build.release -I/usr/include/freetype2 -I/tmp/SBo/MuseScore-3.4.2/thirdparty -I/tmp/SBo/MuseScore-3.4.2/mscore -I/tmp/SBo/MuseScore-3.4.2/global  -O2 -fPIC  -std=gnu++11 -fPIC -O2 -DNDEBUG -DQT_NO_DEBUG -DQT_NO_DEBUG_OUTPUT   -fPIC -std=gnu++11 -o CMakeFiles/telemetry.dir/telemetry_automoc.cpp.o -c /tmp/SBo/MuseScore-3.4.2/build.release/telemetry/telemetry_automoc.cpp
[  7%] Linking CXX static library libtelemetry.a
cd /tmp/SBo/MuseScore-3.4.2/build.release/telemetry && /usr/bin/cmake -P CMakeFiles/telemetry.dir/cmake_clean_target.cmake
cd /tmp/SBo/MuseScore-3.4.2/build.release/telemetry && /usr/bin/cmake -E cmake_link_script CMakeFiles/telemetry.dir/link.txt --verbose=1
/usr/bin/ar qc libtelemetry.a  CMakeFiles/telemetry.dir/actioneventobserver.cpp.o CMakeFiles/telemetry.dir/telemetrysetup.cpp.o CMakeFiles/telemetry.dir/widgets/telemetrypermissiondialog.cpp.o CMakeFiles/telemetry.dir/models/telemetrypermissionmodel.cpp.o CMakeFiles/telemetry.dir/services/telemetryservice.cpp.o CMakeFiles/telemetry.dir/qrc_telemetry_resources.cpp.o CMakeFiles/telemetry.dir/telemetry_automoc.cpp.o
/usr/bin/ranlib libtelemetry.a
make[3]: Leaving directory '/tmp/SBo/MuseScore-3.4.2/build.release'
[  7%] Built target telemetry
make[2]: Leaving directory '/tmp/SBo/MuseScore-3.4.2/build.release'
Makefile:149: recipe for target 'all' failed
make[1]: *** [all] Error 2
make[1]: Leaving directory '/tmp/SBo/MuseScore-3.4.2/build.release'
Makefile:52: recipe for target 'release' failed
make: *** [release] Error 2
 
Old 06-24-2020, 04:28 PM   #63
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 5,481

Rep: Reputation: Disabled
it seems that you found an interesting thing: the version of qt5 I built here linked against pcre2, and that is not listed between the optional dependencies on SBo...

I'll try to build you another one on a clean and up-to-date installation linked only to the mandatory dependencies so that you can test that, but it will be ready only in a few hours.

Last edited by ponce; 06-24-2020 at 04:30 PM.
 
Old 06-24-2020, 05:18 PM   #64
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 5,481

Rep: Reputation: Disabled
Quote:
Originally Posted by ponce View Post
I'll try to build you another one on a clean and up-to-date installation linked only to the mandatory dependencies so that you can test that, but it will be ready only in a few hours.
well, it took a bit less than predicted: try removepkg the qt5 package you have installed, install this and try again building MuseScore.
 
Old 06-24-2020, 05:23 PM   #65
USUARIONUEVO
Senior Member
 
Registered: Apr 2015
Posts: 1,426

Rep: Reputation: 447Reputation: 447Reputation: 447Reputation: 447Reputation: 447
to prevent pcre2 problems, the qt5 configure script have an option to ommit system pcre2 and use qt version.

Quote:
-pcre ................ Select used libpcre2 [system/qt]
I have my qt5 package from sbo linked to pcre2 (SBo) , and i fail to build musescore , with similar errors.


I go download pone package and test



EDIT: with last qt5 ponce package i can build now musescore , its time to debug if culprit is pcre2 system (from SBo), and need force to qt included version. When system no have , qt5 build internal version , then probably forced to build internal version is the best solution.


EDIT2: Im not in home , and no have strong machine here (work) , tomorrow i can do some extra test to see if found some culprit , for now the OP can use the last ponce qt5 package posted , cause i test and builds musescore perfectly.

Last edited by USUARIONUEVO; 06-24-2020 at 05:58 PM.
 
Old 06-24-2020, 07:42 PM   #66
TheNutCase
Member
 
Registered: May 2016
Location: Columbia, South Carolina14
Distribution: Slackware 14.2
Posts: 334

Original Poster
Rep: Reputation: Disabled
It compiled with no problem, and then seemed to install without any problem - but when I went to run it, it took me through the introduction okay, but then the program quit after that. Oh, the main screen is displayed for a sptit second,then dissapars. Is MuseScore a 32-bit program (I have a 64-bit operating system)?

Last edited by TheNutCase; 06-24-2020 at 07:48 PM.
 
Old 06-24-2020, 08:09 PM   #67
TheNutCase
Member
 
Registered: May 2016
Location: Columbia, South Carolina14
Distribution: Slackware 14.2
Posts: 334

Original Poster
Rep: Reputation: Disabled
I just tried runnung mscore (in terminal mode, and got the following output:
Code:
bash-4.3$ mscore
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-doctor'
[20097:20119:0624/210631.431263:FATAL:nss_util.cc(655)] NSS_VersionCheck("3.26") failed. NSS >= 3.26 is required. Please upgrade to the latest NSS, and if you still get this error, contact your distribution maintainer.
Trace/breakpoint trap
 
Old 06-24-2020, 08:49 PM   #68
USUARIONUEVO
Senior Member
 
Registered: Apr 2015
Posts: 1,426

Rep: Reputation: 447Reputation: 447Reputation: 447Reputation: 447Reputation: 447
Quote:
Originally Posted by TheNutCase View Post
I just tried runnung mscore (in terminal mode, and got the following output:
Code:
bash-4.3$ mscore
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-doctor'
[20097:20119:0624/210631.431263:FATAL:nss_util.cc(655)] NSS_VersionCheck("3.26") failed. NSS >= 3.26 is required. Please upgrade to the latest NSS, and if you still get this error, contact your distribution maintainer.
Trace/breakpoint trap
mozilla-nss is 3.40.1 here.

you upgrade your system to get the patches ?
 
Old 06-24-2020, 09:17 PM   #69
TheNutCase
Member
 
Registered: May 2016
Location: Columbia, South Carolina14
Distribution: Slackware 14.2
Posts: 334

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by USUARIONUEVO View Post
mozilla-nss is 3.40.1 here.

you upgrade your system to get the patches ?
No, how do I go about it (short of wiping my hard drive and starting over "from scratch")?
 
Old 06-25-2020, 12:28 AM   #70
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 7,151

Rep: Reputation: 4820Reputation: 4820Reputation: 4820Reputation: 4820Reputation: 4820Reputation: 4820Reputation: 4820Reputation: 4820Reputation: 4820Reputation: 4820Reputation: 4820
slackpkg is the easiest way to upgrade your system. There's instructions on getting it set up and using it here. Make sure you select a 14.2 mirror and not a current mirror.

The alternative is going to your favorite mirror and downloading all the packages in the patches/ directory and then running upgradepkg on them.
 
Old 06-25-2020, 12:47 AM   #71
kgha
Member
 
Registered: May 2018
Location: Sweden
Distribution: Slackware 64 -current multilib from AlienBob's LiveSlak MATE
Posts: 315

Rep: Reputation: 231Reputation: 231Reputation: 231
I strongly recommend you to read the slackpkg instructions (bassmadrigal's link in previous post) and take action so that your system is fully upgraded. mozilla-nss, for instance, was upgraded from 3.23 to 3.31 in September 2017 (and is now 3.40). I don't know how old your install is but if your last upgrade was three years ago or thereabouts, there are a plethora of patches (including vital security patches) that you have missed and you may run into a lot of issues in the future unless you do something about it.
 
1 members found this post helpful.
Old 06-25-2020, 09:15 AM   #72
drumz
Member
 
Registered: Apr 2005
Location: Scottsdale, AZ, USA
Distribution: Slackware
Posts: 245

Rep: Reputation: 91
You can follow security updates here:

http://www.slackware.com/changelog/s...php?cpu=x86_64

Or subscribe to the newsletter to get email notifications:
http://www.slackware.com/lists/

which is archived here:
http://www.slackware.com/security/

As already mentioned, after you know there are upgraded packages to install, you can either manually download them (or sync from a mirror) and run "upgradepkg" or you can use slackpkg to do the downloading and upgrading for you.
 
Old 06-25-2020, 11:49 AM   #73
USUARIONUEVO
Senior Member
 
Registered: Apr 2015
Posts: 1,426

Rep: Reputation: 447Reputation: 447Reputation: 447Reputation: 447Reputation: 447
Hi , i make some tests in my system , i build qt5 WITH WEBENGINE , install qt5-webkit , and Musescore builds fine here

My qt5 package is linked to pcre2 system library , and no problems here.


Then problem is in OP system , he need start to upgrade base slackware packages. (slackpkg update/upgrade-all)



EDIT: I talk too fast ...musescore segmentation fault at start , gdb says nothing ..i continue investigating.
EDIT2: I try now compiling qt5 with bundle version of pcre ... "-qt-pcre"

Last edited by USUARIONUEVO; 06-25-2020 at 12:28 PM.
 
Old 06-25-2020, 04:14 PM   #74
TheNutCase
Member
 
Registered: May 2016
Location: Columbia, South Carolina14
Distribution: Slackware 14.2
Posts: 334

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by bassmadrigal View Post
slackpkg is the easiest way to upgrade your system. There's instructions on getting it set up and using it here. Make sure you select a 14.2 mirror and not a current mirror.

The alternative is going to your favorite mirror and downloading all the packages in the patches/ directory and then running upgradepkg on them.
I just did the upgrade as you suggested, then ran mscore - and got the following output:
Code:
bash-4.3# mscore
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
[29439:29439:0625/170954.181151:ERROR:zygote_host_impl_linux.cc(89)] Running as root without --no-sandbox is not supported. See https://crbug.com/638180.
[heap]  0
[heap]  1
[heap]  2
[heap]  3
[heap]  4
[heap]  5
[heap]  6
[heap]  7
[heap]  8
[heap]  9
[heap]  10
[heap]  11
[heap]  12
[heap]  13
[heap]  14
[heap]  15
 
Old 06-25-2020, 04:21 PM   #75
BrunoLafleur
Member
 
Registered: Apr 2020
Location: France
Distribution: Slackware
Posts: 73

Rep: Reputation: Disabled
"bash-4.3# mscore
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
[29439:29439:0625/170954.181151:ERROR:zygote_host_impl_linux.cc(89)] Running as root without --no-sandbox is not supported. See https://crbug.com/638180."

Do you lauch it as root ?

Why do you do that ?

You should launch it as a normal user in a graphical environment. Else it won't work obviously.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Trouble building Musescore on Slackware 64 Captain Pinkeye Slackware 7 06-30-2014 12:41 PM
[SOLVED] Musescore won't install on Intel 64 bit CPU PC, help please alex polvorilla Linux - Software 3 12-30-2012 02:46 PM
LXer: MuseScore, LilyPond, and Chordii: Projects on the Move LXer Syndicated Linux News 0 03-29-2011 05:40 AM
Classical organ sound fonts for MuseScore Tom Nichol Linux - Software 0 06-18-2009 02:30 PM
MusEScore 0.1pre2 compilation issues stev160 Linux - Software 0 07-15-2004 09:59 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration