-   Slackware (
-   -   Question about Catalyst 12.8 (

animeresistance 10-05-2012 11:25 AM

Question about Catalyst 12.8
Hi all.

Sorry for disturbing you. I have a question, i own a laptop with AMD Radeon HD 7670 (honestly, i'm a newbie with this AMD Radeon stuff), and i followed the instructions that are on this thread ()

But those were for Catalyst 12.6 in slackware current. and i used them to install Catalyst 12.8 in Slackware 14, graphic interface works good, but, when i use the glxgears or fgl_glxgears command in the command line, it says:


Using GLX_SGIX_pbuffer
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  136 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  12
  Current serial number in output stream:  12

And when i try to use the AMD Catalyst Control center a message appears, and it says:
"There was a problem initializing Catalyst Contro center Linux Edition. It could be caused by the following.

No AMD graphics driver is installed, or the AMD driver is not functioning properly.
Please install the AMD driver appropiate for you AMD hardware, or configure using aticonfig".

My main question is ... What i need to do to see if the driver is installed and working properly? or this messages displayed are telling me that there is no AMD driver? or i should uninstall the Catalyst 12.8 and install it again ?

Any help is greatly appreciate it ...

ReaperX7 10-05-2012 12:25 PM

Did you blacklist the default "radeon" and "ati" driver modules from loading?

414N 10-05-2012 01:11 PM


Originally Posted by ReaperX7 (Post 4798206)
Did you blacklist the default "radeon" and "ati" driver modules from loading?

The only driver to blacklist would be the kernel one (radeon), as ati is the X "driver" and needs not to be blacklisted.
Have you run aticonfig --initial after installing the fglrx driver? Is fglrx appearing in lsmod output?
Make sure that your /etc/X11/xorg.conf file exists and loads the fglrx driver.

TobiSGD 10-05-2012 01:15 PM

The radeon module is automatically blacklisted by the installer. I would rather think that there were either errors during the install, leading to an incomplete install, or, like 414N already suggested, that the OP forgot to run aticonfig --initial.

animeresistance 10-05-2012 05:18 PM


Thanks for the reply ...

I blacklisted ati and readeon ...

I ran the aticonfig --initial

I think i should erase the ati from the blacklist ... lemme do it and i will tell you if it was success or fail ...

adamk75 10-05-2012 07:25 PM

I'm pretty sure your /var/log/Xorg.0.log file will tell you what's wrong.


animeresistance 10-05-2012 08:20 PM

Thank you for all your replies.

I really appreciate your help. . And it is fixed.

Somehow i messed and missed something, so i did
- a fresh install,
- unzipped the driver,
- chmod +x driver,
- ./driver
- aticonfig --initial
- vi /etc/modprobe.d/blacklist.conf and added the radeon driver (blacklist radeon)
- reboot
- lsmod (to make sure flgrx module is there)
- vi /etc/X11/xorg.conf to make sure X will use the flgrx driver
- startx
- and in command line introduce fgl_glxgears to see if it runs ...

All went well ... i thought that i haven't missed nothing ,,, but anyway, now it works.

Thank you to all of you =)

All times are GMT -5. The time now is 04:02 AM.