LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-05-2019, 11:32 AM   #1
Johncc330
Member
 
Registered: Mar 2007
Posts: 49

Rep: Reputation: 16
Qt5.11.3 Slackware64-current package: Strange colors


A couple of days ago, I installed Qt5 (5.11.3), using Alien Bob's Slackware packages. After I compiled and installed LibreCAD (which needed Qt5), I found that the GUI shows strange color. I also ran qt5ct, which suffered the same coloring issue. As I really don't have much experience with Qt, I have no idea where the problem could originate. Venturing a guess, could this be a font rendering problem?

I've added a screenshot of qt5ct as it appears here.

I tried to change to a light theme instead of the dark one I prefer, which made the pinkish color change to green), and tried several other variations, none of which created monochrome letters.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2019-01-04_19-57-01.png
Views:	79
Size:	36.7 KB
ID:	29405  
 
Old 02-03-2019, 06:28 PM   #2
KewlCat
LQ Newbie
 
Registered: Aug 2015
Distribution: Slackware
Posts: 17

Rep: Reputation: Disabled
It looks like a bad "sub-pixel rendering" issue.
Do you have anything to configure Freetype ?
 
Old 02-03-2019, 06:32 PM   #3
Skaendo
Member
 
Registered: Dec 2014
Location: West Texas, USA
Distribution: Slackware64-14.2
Posts: 909

Rep: Reputation: Disabled
Try the GTK style instead of fusion. You might need the qt5-styleplugins package to get it.
 
Old 02-03-2019, 08:46 PM   #4
Johncc330
Member
 
Registered: Mar 2007
Posts: 49

Original Poster
Rep: Reputation: 16
There are only two style options: Fusion and Windows. No Gtk there... Strange.
 
Old 02-03-2019, 09:09 PM   #5
Johncc330
Member
 
Registered: Mar 2007
Posts: 49

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by KewlCat View Post
It looks like a bad "sub-pixel rendering" issue.
Do you have anything to configure Freetype ?
Mmmm... Is freetype configurable? I never modified freetype, and qt5ct doesn't seem to have any option. It's working normally under Gtk.
 
Old 02-03-2019, 09:10 PM   #6
Skaendo
Member
 
Registered: Dec 2014
Location: West Texas, USA
Distribution: Slackware64-14.2
Posts: 909

Rep: Reputation: Disabled
Quote:
Originally Posted by Johncc330 View Post
There are only two style options: Fusion and Windows. No Gtk there... Strange.
The GTK style comes in the qt5-styleplugins package. It's available on SBo.
 
  


Reply

Tags
qt5, slackware64 current


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] No package 'x11' found No package 'xext' found No package 'xdamage' found No package 'xfixes' found No package 'x11-xcb' found Jigsaw Linux From Scratch 12 04-25-2019 07:33 AM
[SOLVED] qt4 alienbob qt5 coexist and SBo package build issue with smplayer? bamunds Slackware 7 03-22-2018 02:52 PM
[SOLVED] Building qt5 on slackwarearm-current stormtracknole Slackware - ARM 9 03-06-2018 07:14 PM
[SOLVED] current: lazarus/qt5 SIGSEGV when program exit baldzhang Slackware 2 02-02-2018 09:17 AM
Updating from Slackware64-current to Slackware64 13. glore2002 Slackware 4 08-28-2009 06:50 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration