LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-04-2010, 09:22 AM   #1
SlackN00b
Member
 
Registered: Dec 2003
Distribution: Slackware 9.1
Posts: 44

Rep: Reputation: 15
qt4 and plasma ruby bindings


Hello all I've slackware 13.1 and anytime I try the following commands in
irb:

Code:
require 'rubygems'
require 'Qt4'
or

Code:
require 'rubygems'
require 'plasma_applet'
i receive the following error:

LoadError: no such file to load -- Qt4
LoadError: no such file to load -- plasma_applet

now I'm wondering what packages or gems I need to make it work??
Thanks
 
Old 06-05-2010, 05:58 PM   #2
bonaire
Member
 
Registered: Jun 2008
Location: Bonn/Germany
Distribution: Slackware-13.37
Posts: 94

Rep: Reputation: 19
Don't know, what is wrong with your installation. Tjat is working for me. Full installation of slackware 13.1

Code:
#!/usr/bin/env ruby
require "Qt4"
require "plasma_applet"
Both commands return true.
 
Old 06-07-2010, 02:32 AM   #3
SlackN00b
Member
 
Registered: Dec 2003
Distribution: Slackware 9.1
Posts: 44

Original Poster
Rep: Reputation: 15
Thanks a lot I think I've messed with the ruby installation then...
 
Old 06-07-2010, 07:19 AM   #4
vbatts
Member
 
Registered: Jun 2005
Location: Raleigh, NC, USA
Distribution: slackware
Posts: 84

Rep: Reputation: 58
Quote:
Originally Posted by SlackN00b View Post
Thanks a lot I think I've messed with the ruby installation then...
you can also search around to ensure you have your library name correct, with something like
Code:
$> find /usr/lib64/ruby/| grep -iE '(qt|kde)'
then give it a whirl
Code:
$> irb
irb(main):001:0> require 'Qt4'
=> true
irb(main):002:0> require 'KDE/plasma'
=> true
irb(main):003:0> require 'KDE/korundum4'
=> true
take care,
vb
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Any issues installing Ruby Gems and Ruby on Rails in Slackware? Lufbery Slackware 8 02-09-2011 07:22 PM
kde4 on karmic: plasma-desktop doesn't start by itself after removing plasma-netbook eantoranz Linux - Software 8 10-10-2009 09:57 AM
Ruby SDL/ Ruby OpenGL tutorials/reference? LinuxNoob75 Programming 0 12-30-2007 12:47 PM
LXer: Qyoto C#/Mono Bindings for Qt4, New QtRuby release and PHP Bindings Coming Soon LXer Syndicated Linux News 0 07-03-2007 09:01 PM
Compiling qt4 apps for non-qt4 linux, win, mac birdseye Programming 4 10-31-2005 04:45 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration