-   Slackware (
-   -   Qt3 package from extra not found (

Daedra 09-01-2009 03:53 PM

Qt3 package from extra not found
This is not much of a problem right now, but I installed the QT3 package from /extra mostly for kernel compiling but when I do make xconfig I am getting this error

make xconfig
* Unable to find the QT3 installation. Please make sure that
* the QT3 development package is correctly installed and
* either install pkg-config or set the QTDIR environment
* variable to the correct location.
make[1]: *** No rule to make target `scripts/kconfig/.tmp_qtcheck', needed by `scripts/kconfig/qconf.o'. Stop.

How do I correct this so qt3 is recognized?


easuter 09-01-2009 04:20 PM

Try adjusting the QTDIR environment variable when you run the makefile, something like this:


QTDIR=/path/to/qt3 make xconfig
I don't know what the qt3 installation directory is for Slackware 13, but you can probably find it by opening the qt3 package installation log in /var/log/packages.

Daedra 09-01-2009 04:36 PM

that got it. Thanks :)

xamaco 09-24-2009 03:24 PM

Thanks as well, it did it for me too...

I've just installed Slackware 13.0.

I had to install Scribus for a newspaper. Slackware 13.0 proposes only Scribus 1.3.5 which is not backward compatible with the older 1.3.3 family and is still flagged as unstable. Scribus 1.3.3 uses Qt 3 and 1.3.5 Qt 4.
As Daedra, I installed qt3 from the extra and could not compile Scribus : qt3 not found. The difference is I used the Scribus SlackBuild from, repository 12.2.
After typing 'export QTDIR=/opt/kde3/lib/qt3' and then 'scribus.Slackbuild', it worked like a charm and I now have a functional Scribus

I'm brand new to Slackware, after several years of Suse and Ubuntu (and other distros I tested and rejected). I'll post later something about my impressions with Slackware. Right now I still have to install more stuff to be really fully operational and eventually ditch Ubuntu (which works very well but is a bit boring : I love to tweak).

ppr:kut 09-25-2009 01:15 AM

It works fine here, so my guess is you installed qt3 and then tried building scribus right afterwards? In that case the profile.d scripts for qt3 weren't executed yet and therefore QTDIR wasn't set. It should work fine after the next login, or by sourcing the profile.d script (or by setting the variable by hand as you did)

xamaco 09-25-2009 12:15 PM

No, it worked fine as soon as I did the QTDIR=...
I had the problem all alone after installing Qt3. After I did a search in this forum and got the answer I needed.

All times are GMT -5. The time now is 09:33 PM.