-   Slackware (
-   -   Python Errors - Ipodder (

snowman156 12-09-2004 08:01 PM

Python Errors - Ipodder
I'm having an issue with a python program that I am trying to run on Slackware 10.0 and cannot seem to find a solution for. I'm trying to run Ipodder for Linux and although it is rumored to work on Conectiva, I can't get it to work on Slack, FC3, or Mandrake 10.1. The only package I could find is the .rpm so (in Slack) I first did:

rpm2tgz ipodder-1.1.2-1cl.noarch.rpm

installpkg ipodder-1.1.2-1cl.noarch.tgz

It seemed to install, but everytime I try to run the executable, I get this:

Traceback (most recent call last):
File "", line 1, in ?
import wx
ImportError: No module named wx

Thinking I was missing some python library, I installed the following:


After I did that, I ran ipodder again and get this:

Traceback (most recent call last):
File "", line 1, in ?
import wx
File "/usr/lib/python2.3/site-packages/wx-2.5.3-gtk2-unicode/wx/", line 42, in ?
from wx._core import *
File "/usr/lib/python2.3/site-packages/wx-2.5.3-gtk2-unicode/wx/", line 4, in ?
import _core_
ImportError: cannot open shared object file: No such file or directory

Can anybody point me in the right direction here as far as where to look for a solution? My googling has resulted in very little relating to either Ipodder or my particular error mesg. Thanks in advance

gbonvehi 12-09-2004 08:41 PM

Try installing wxBase (you can get it from

Edit: I took a look at (wx's homepage) and I saw there's 2.5.3 version which it seems that Ipodder is looking for, try getting that version, the one you installed and it's on linuxpackages is 2.4.2.

snowman156 12-09-2004 09:37 PM

I tried the wxbase but got the same error. I uninstalled the wxpython-2.5.3 and installed the wxpython-2.4.2 with the corresponding wxbase and still get the same error.

gbonvehi 12-09-2004 10:47 PM

Try matching both packages (or compile them) to 2.5.3. Take a closer look at Ipodder requirements too.

All times are GMT -5. The time now is 03:52 PM.