-   Slackware (
-   -   PXE installation problem - can only select A series packages for installation (

Nylex 05-03-2008 02:33 PM

PXE installation problem - can only select A series packages for installation
Hi, I have set up a server for DHCP, NFS and TFTP per Eric Hameleers' instructions (, though with some minor changes - mainly these are just the IP addresses used. I've also mounted the DVD ISO image on /mirror/slackware/slackware-12.1, instead of copying all the files there. For some reason, I have problems booting from the DVD hence not installing that way.

Most things seem to work ok: I can boot via PXE and run the Slackware setup program. When I get to the "Package series selection" screen, I can only select the A series. None of the other series are even listed, though they are all present in /mirror/slackware/slackware-12.1/slackware.

I haven't a clue what the problem could be, so any help would be appreciated.


Alien Bob 05-03-2008 03:04 PM

Depends on what you typed when the installer asks for the IP address of the NFS server that holds the package tree, and more importantly, the path to the packages. Your path needs to end on ".../slackware" which is the directory that contains the a, ap,..., y subdirectories.


Nylex 05-03-2008 03:53 PM

Sorted. Thanks Eric!

Nylex 08-16-2010 03:29 PM

This is an old thread, I know, but I'm having the same problem with 13.1. My NFS server is running on 13.0 and I have the line


in /etc/exports. When trying to install 13.1 via NFS, when asked "What is the Slackware source directory?", I answer "/mirror/slackware/slackware-13.1/slackware". The NFS mount result dialog tells me that mounting did not work, but if I check /var/log/messages on my server machine, I see

authenticated mount request from for /mirror/slackware/slackware-13.1/slackware (/mirror/slackware)

which doesn't seem like an error to me.

What's going on here?


Nylex 08-19-2010 02:15 PM

I still don't know what the problem is with NFS, but setting up Apache for an HTTP installation seems to be working ok, so never mind :).

All times are GMT -5. The time now is 07:32 AM.