LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-27-2020, 12:41 AM   #1
arfon
Member
 
Registered: Apr 2004
Location: Texas
Distribution: Slackware
Posts: 182

Rep: Reputation: Disabled
Pulseaudio only showing "dummy output" device.


I just did a 14.2 update (with slackpkg) and after the update, audio quit working. I checked the mixer and only "dummy output" and "dummy input" devices were there.


I logged in as root and ran pavucontrol and it had the normal audio devices...

After some investigating, apparently the update removed my user from all groups except "users". I added my user back to:

Code:
usermod -a -G lp,wheel,floppy,dialout,audio,video,cdrom,plugdev,power,netdev,scanner joeuser
and pulseaudio was fine after that.

Last edited by arfon; 01-31-2020 at 02:08 AM.
 
Old 01-27-2020, 03:41 AM   #2
Tonus
Member
 
Registered: Jan 2007
Location: Paris, France
Distribution: Slackware-current
Posts: 636
Blog Entries: 3

Rep: Reputation: 163Reputation: 163
Pulseaudio only showing "dummy output" device.

Can't believe that is an upgrade issue. I'd bet for a keyboard accident... If you hadn't update for a long time, did you checked the changelog?

Anyway, would you mind marking the thread as solved?

Last edited by Tonus; 01-27-2020 at 03:43 AM.
 
Old 01-31-2020, 02:06 AM   #3
arfon
Member
 
Registered: Apr 2004
Location: Texas
Distribution: Slackware
Posts: 182

Original Poster
Rep: Reputation: Disabled
Well, it's a server with an audio notification (ran as joeuser). No one was logged on before, during or after upgrade and the discovery of the loss of audio.


Here's a copy of the history:

Code:
  132  /etc/rc.d/rc.ntpd start
  133  date
  134  date   #Audio was working here for joeuser
  135  pkgtool update
  136  slackpkg update
  137  slackpkg upgrade-all
  138  slackpkg upgrade-all
  139  slackpkg install-new
  140  reboot
  141  reboot
  142  ls /etc/rc.d/  #Audio quit working for joeuser, started investigating.
  143  chmod 755 /etc/rc.d/rc.pulseaudio
The only thing that changed from when the audio worked to when it quit was a system upgrade.

Last edited by arfon; 01-31-2020 at 02:09 AM.
 
Old 02-13-2020, 05:27 PM   #4
Tonus
Member
 
Registered: Jan 2007
Location: Paris, France
Distribution: Slackware-current
Posts: 636
Blog Entries: 3

Rep: Reputation: 163Reputation: 163
Quote:
Originally Posted by arfon View Post
The only thing that changed from when the audio worked to when it quit was a system upgrade.
Usual problem would be lack of attention to new config files... Would check what packages were upgraded and which one would have had .new config file.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Slackware-current kde audio settings - only "PulseAudio Sound Server" device seen in "Device preference" tab alekow Slackware 2 01-20-2020 05:17 PM
pulseaudio no sound only Dummy Output Bob D Linux - Hardware 1 11-26-2018 06:43 AM
Audio not working on Debian, only "card" is dummy output. cemcmd Linux - Software 15 12-13-2016 03:12 PM
Only sound device found is "Dummy Output" and Radeon issues bulletfreak Slackware 42 08-19-2016 01:47 PM
audio output device changes to 'dummy output' Joshwaaa Linux - Software 1 04-02-2010 11:03 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration