LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-25-2016, 06:53 AM   #1
pchristy
Member
 
Registered: Oct 2012
Location: UK
Distribution: Slackware
Posts: 312

Rep: Reputation: Disabled
Pulseaudio default volume.....


Help, please, before I go deaf!

Since the most recent upgrade, which installed pulseaudio, I am unable to control the default (power-on) audio level. It always goes to 100%, resulting in a deafening login jingle!!!

Previously, I would use alsamixer as root to set initial volumes. Although that still goes through the motions, the volumes reset to 100% on reboot. Kmix does the same. Although I can set sensible levels, they get lost on rebooting!

How do you set default levels with pulseaudio?

--
Pete
 
Old 01-25-2016, 07:29 AM   #2
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: Newport News, VA
Distribution: Slackware
Posts: 5,053

Rep: Reputation: 2860Reputation: 2860Reputation: 2860Reputation: 2860Reputation: 2860Reputation: 2860Reputation: 2860Reputation: 2860Reputation: 2860Reputation: 2860Reputation: 2860
See this and set flat-volumes = no in /etc/pulse/daemon.conf
 
Old 01-25-2016, 08:16 AM   #3
pchristy
Member
 
Registered: Oct 2012
Location: UK
Distribution: Slackware
Posts: 312

Original Poster
Rep: Reputation: Disabled
Thanks for the pointer! That didn't work on its own, but it did point me to the cause of the problem!

I needed to go into System Settings / Application and System Notifications / Manage Notifications from the KDE kickoff button, and then select the player settings tab. Setting that to 50-60% got things working as desired!

It appears that under pulseaudio - even if you've set flat-volumes=no and set alsamixer - having the kde player settings at 100% will over-ride whatever default settings you *think* you have made! This is the opposite behaviour to non-pulseaudio systems!

Grrr!

But thanks for pointing me towards the wiki which gave me the hint!

--
Pete
 
Old 01-26-2016, 09:40 AM   #4
gordydawg
Member
 
Registered: Sep 2013
Distribution: slackware
Posts: 40

Rep: Reputation: Disabled
Quote:
Originally Posted by pchristy View Post
Thanks for the pointer! That didn't work on its own, but it did point me to the cause of the problem!

I needed to go into System Settings / Application and System Notifications / Manage Notifications from the KDE kickoff button, and then select the player settings tab. Setting that to 50-60% got things working as desired!

It appears that under pulseaudio - even if you've set flat-volumes=no and set alsamixer - having the kde player settings at 100% will over-ride whatever default settings you *think* you have made! This is the opposite behaviour to non-pulseaudio systems!

Grrr!

But thanks for pointing me towards the wiki which gave me the hint!

--
Pete
Thank you for posting this for Slackware-current users running KDE. This had been driving me crazy over the last few days. A future update to SlackDocs on setting up Alsa/Pulse audio should mention this little, but very important tip
 
Old 01-26-2016, 10:08 AM   #5
GazL
Senior Member
 
Registered: May 2008
Posts: 4,683
Blog Entries: 12

Rep: Reputation: 2180Reputation: 2180Reputation: 2180Reputation: 2180Reputation: 2180Reputation: 2180Reputation: 2180Reputation: 2180Reputation: 2180Reputation: 2180Reputation: 2180
By the sounds of it, the symptoms suggest that kde notifications is setting the volume of the sink rather than its sink-input, otherwise "flat-volumes:no" ought to protect against that (to the best of my understanding of the topic).


BTW, if you configure pulse to use an alsa pcm dmix device for output, you end up with a setup supporting concurrent multi-user output with each user having an independent sink volume control. You can then use 'alsamixer -c 0' to set the hardware controls which will effectively work as a cap on maximum volume. You retain all the sound routing features of pulse, but you will lose the pulseaudio 'ports' functionality that is used to manage the device hardware settings and you will have to resort to changing card settings the traditional way with 'alsamixer -c 0'. I actually find I prefer it that way, as I'd rather not have pulse second-guessing what hardware settings I want enabled on my primary soundcard.

If anyone is interested let me know and I'll post how I have my system configured.
 
Old 01-26-2016, 10:33 AM   #6
pchristy
Member
 
Registered: Oct 2012
Location: UK
Distribution: Slackware
Posts: 312

Original Poster
Rep: Reputation: Disabled
I must confess to not being at all familiar with pulseaudio. I've never needed it previously, but it looks as if it is going to become unavoidable, so I'd better know at least the basics!

As far as I can make out, setting flat-volumes=no should allow various applications to set their volumes independently *relative* to a master setting. The problem with KDE is that the player that sets the volume of the notifications, if left at its default setting of 100, over-rides any settings made by alsamixer / kmix, and ramps the master volume up to 100%.

I have never previously had to touch this setting. I've always set alsamixer (as root) to provide a sensible level, and that was that. Now, under pulseaudio, that "sensible setting" gets over-ridden by the (non-root!) volume setting for KDE's notifications. And as that has been raised, and all the other apps set their levels relative to that master, everything is now far too loud.

It isn't an issue once you have found it and know how to adjust it, but its a non-obvious adjustment! As gordydawg says, it can drive you crazy!!!

Is my summary of what is happening here correct?

Over to the experts!

--
Pete
 
1 members found this post helpful.
Old 01-27-2016, 06:12 PM   #7
Gordie
Member
 
Registered: Aug 2007
Distribution: Slackware
Posts: 350

Rep: Reputation: 95
I use XFCE. About every second time I boot up I can actually hear Skype log on no problem with my speakers. YouTube is unbearably loud at these times
The other times I boot up I need the headphones to hear anything (Skype, YouTube, anything).
I set flat-volumes = no in /etc/pulse/daemon.conf and this made no difference
 
Old 01-28-2016, 03:29 AM   #8
pchristy
Member
 
Registered: Oct 2012
Location: UK
Distribution: Slackware
Posts: 312

Original Poster
Rep: Reputation: Disabled
Gordie, I only use XFCE occasionally, so I can't offer any hard advice, but presumably - like KDE - it has some way of setting the volume of system notifications. If you can find that, it might assist with finding a solution to your issues. It could also be Skype itself, of course! Anything that messes with the basic level settings can cause the issue.

I'm still finding levels in some applications to be erratic - notably youtube - but this could be just a question of adjusting each one once. Once set, it should then be ok going forward.

At least, I hope so!

P.S. I notice there is something called pamixer installed with pulse audio. Although not a graphic mixer like alsamixer, it does seem to have some effect on pulseaudio. Typing "pamixer" at a command prompt will list its functions. Maybe setting its level with a script during logon may help?

--
Pete

Last edited by pchristy; 01-28-2016 at 03:34 AM.
 
Old 01-28-2016, 06:31 AM   #9
Gordie
Member
 
Registered: Aug 2007
Distribution: Slackware
Posts: 350

Rep: Reputation: 95
I don't use audio notifications or sound events if I can help it. Silence is golden. Here is what is working for me since I stumbled upon it yesterday afternoon:

PulseAudio plugin set for the absurd level of 153 volume)
/usr/sbin/alsactl store used manually only as needed (/etc/rc.d/rc.local)
/usr/sbin/alsactl restore used as an entry (/etc/rc.d/rc.local_shutdown)

Last edited by Gordie; 01-28-2016 at 11:09 AM.
 
Old 01-28-2016, 06:40 AM   #10
pchristy
Member
 
Registered: Oct 2012
Location: UK
Distribution: Slackware
Posts: 312

Original Poster
Rep: Reputation: Disabled
Hi Gordie,

Interesting. I used to use alsamixer and alsactl to set my default levels, but found that pulseaudio over-rode these. Even if you don't use sound events or notifications, it is possible that there is a "default" setting for these somewhere in the boot process. In my case it was in the KDE initialisation - a setting I'd never had to use previously.

Have you tried using pamixer in either rc.local or in bashrc or similar? It looks as if it might be designed for that purpose. Haven't tried it myself yet, but its on my "todo" list!

--
Pete
 
  


Reply

Tags
pulseaudio, volume control


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] PulseAudio and volume buttons cgorac Slackware 6 01-19-2016 03:03 PM
[SOLVED] Pulseaudio and storing volume between reboots af7567 Slackware 10 01-18-2016 06:33 AM
PulseAudio Volume Control Question... rnturn Linux - Software 3 11-18-2014 01:21 PM
Difference between Fedora and Ubuntu (pulseaudio) volume controls ordealbyfire83 Linux - Software 1 05-16-2011 08:15 PM
LXer: EarCandy is a Smart PulseAudio Volume Manager LXer Syndicated Linux News 0 05-22-2009 09:30 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration