LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-08-2018, 05:17 AM   #1
ArcBrut
LQ Newbie
 
Registered: Jul 2018
Distribution: Slackware -current
Posts: 10

Rep: Reputation: Disabled
Pulse audio consumes 100% of one core.


After upgrading pulseaudio to latest Pat pulseaudio-12.0-x86_64-2.txz, process gsettings-helper consume 100% of one CPU core and grow up to 6GiB. If I kill this process, then pulseaudio process grow to 5-6GiB and comsume 100% of one core.
Does anyone have a similar experience?
 
Old 07-08-2018, 06:10 AM   #2
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 3,825

Rep: Reputation: 1101Reputation: 1101Reputation: 1101Reputation: 1101Reputation: 1101Reputation: 1101Reputation: 1101Reputation: 1101Reputation: 1101
nope, works fine here
 
Old 07-08-2018, 06:27 AM   #3
chrisretusn
Member
 
Registered: Dec 2005
Location: Philippines
Distribution: Slackware
Posts: 787

Rep: Reputation: 284Reputation: 284Reputation: 284
You don't mention what version of Slackware you are using. I see no issues here with Slackware64-current.
 
Old 07-08-2018, 09:19 AM   #4
ArcBrut
LQ Newbie
 
Registered: Jul 2018
Distribution: Slackware -current
Posts: 10

Original Poster
Rep: Reputation: Disabled
Slackware64-current. I have external DAC on USB(DigiHud USB audio driver). It looks like GConf works well, but GSettings, used in new pulseaudio-12.0-x86_64-2.txz package,causes this problem. I must kill gsettings-helper, than pulseaudio and start pulseaudio manualy. Then everything works well.
 
Old 07-14-2018, 02:17 PM   #5
ArcBrut
LQ Newbie
 
Registered: Jul 2018
Distribution: Slackware -current
Posts: 10

Original Poster
Rep: Reputation: Disabled
I noticed in syslog this lines(after reboot):
[pulseaudio] server-lookup.c: Unable to contact D-Bus: org.freedesktop.DBus.Error.NotSupported: Unable to autolaunch a dbus-daemon without a $DISPLAY for X11
[pulseaudio] main.c: Unable to contact D-Bus: org.freedesktop.DBus.Error.NotSupported: Unable to autolaunch a dbus-daemon without a $DISPLAY for X11
[pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.ServiceUnknown: The name org.bluez was not provided by any .service files

I do not know if this is related to my problem. Maybe yes. For a single user logged in desktop system DISPLAY will probably always be :0 . I do not know why $DISPLAY is not set in my system.
 
Old 07-14-2018, 03:18 PM   #6
Okie
Member
 
Registered: Mar 2002
Location: Oklahoma
Posts: 998

Rep: Reputation: 49
i have had pulseaudio hang like that and start consuming cpu @100% like that when an app crashed from trying different settings to see what works and what dont work, i dont know if that little bit of info helps or not but i thought i would throw that out there so you might have something to look for, i tried making pulseaudio play nice with various apps and it dont want to keep the settings i given it and keeps going from analog to hdmi which was an annoyance, so i finally abandoned pulseaudio and removed it from my system and switched to a pure alsa system, dont do this unless you know what you are doing because it will cause some breakage until other packages are rebuilt to satisfy the system change

i think pulseaudio has a mind of its own, it was invented by some guy named Lennart Poettering who works for redhat that invented systemD which is far worse

Last edited by Okie; 07-14-2018 at 03:19 PM.
 
Old 07-15-2018, 11:35 AM   #7
alex14641
Member
 
Registered: Feb 2016
Distribution: Slackware64_14.1, Slackware64_14.2, Slackware64_current
Posts: 105

Rep: Reputation: Disabled
Quote:
Originally Posted by ArcBrut View Post
After upgrading pulseaudio to latest Pat pulseaudio-12.0-x86_64-2.txz, process gsettings-helper consume 100% of one CPU core and grow up to 6GiB. If I kill this process, then pulseaudio process grow to 5-6GiB and comsume 100% of one core.
Does anyone have a similar experience?
Have you tried the latest current, which has pulseaudio 12.1?
 
Old 07-15-2018, 02:50 PM   #8
ArcBrut
LQ Newbie
 
Registered: Jul 2018
Distribution: Slackware -current
Posts: 10

Original Poster
Rep: Reputation: Disabled
Yes, today I installed pulseaudio 12.1 and everything works well. A quick look at the pulseaudio 12.1 changelog... no, I will not be vulgar. Thank you all for your advice and help.
 
1 members found this post helpful.
Old 07-16-2018, 06:36 PM   #9
USUARIONUEVO
Member
 
Registered: Apr 2015
Posts: 889

Rep: Reputation: 275Reputation: 275Reputation: 275
see that

https://lists.freedesktop.org/archiv...ly/030280.html
 
1 members found this post helpful.
Old 07-29-2018, 03:34 PM   #10
ArcBrut
LQ Newbie
 
Registered: Jul 2018
Distribution: Slackware -current
Posts: 10

Original Poster
Rep: Reputation: Disabled
Problem persists. If I set default pulseaudio output to external USB DAC, gsettings-helper.so consume 100% of one CPU core and grow up to 6GiB. If I set internal analog audio as defaul output, all works well. Not only after restart, but also when changing output in PAVU control.
 
Old 07-29-2018, 04:16 PM   #11
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: Slackware
Posts: 8,282

Rep: Reputation: 3362Reputation: 3362Reputation: 3362Reputation: 3362Reputation: 3362Reputation: 3362Reputation: 3362Reputation: 3362Reputation: 3362Reputation: 3362Reputation: 3362
I'm using a USB DAC, and I don't have this issue.
 
Old 07-30-2018, 07:16 AM   #12
ArcBrut
LQ Newbie
 
Registered: Jul 2018
Distribution: Slackware -current
Posts: 10

Original Poster
Rep: Reputation: Disabled
Dugan, are you using Plasma 5.13 ? I think that there is some connection between Plasma 5.13 series, pulseaudio 12.x and gsettings what causes this issue. I have to try xfce or liveSlack with latest Plasma from Alien Bob, to rule out a bug in my installation.
 
Old 07-30-2018, 10:11 AM   #13
ArcBrut
LQ Newbie
 
Registered: Jul 2018
Distribution: Slackware -current
Posts: 10

Original Poster
Rep: Reputation: Disabled
Last liveslack-current-plasma5(2018-07-29) booted from usb works without this issue. I deleted all KDE, QT, pulseaudio configuration and cache files from /home. Issue gone. I will continue to test
 
Old 08-04-2018, 04:54 AM   #14
ArcBrut
LQ Newbie
 
Registered: Jul 2018
Distribution: Slackware -current
Posts: 10

Original Poster
Rep: Reputation: Disabled
Everything works after deleting files. Issue gone. I refer to the thread as solved.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Pulse Audio purple52 Linux - Newbie 1 05-15-2014 09:16 PM
Unknown process consumes 100% CPU forever - Linux server chrisanto_2000 Linux - Security 11 03-23-2012 04:48 AM
pulse audio sulekha Ubuntu 1 02-10-2009 05:48 PM
QjackCtl or Qsynth window consumes 100% of CPU (without actually starting services) Xdrummer Slackware 1 03-18-2008 01:20 PM
pdftotext consumes 100%cpu power alaios Linux - Software 1 04-02-2007 06:27 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 06:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration