-   Slackware (
-   -   pulse audio and slackbuilds issue (

rcorkum 11-24-2013 01:20 AM

pulse audio and slackbuilds issue

I am trying to build pulseaudio with slackbuilds.

I downloaded both the 2.0 from the link on the slackbuilds site and also tried 4.0 from the builders site.

I adjusted the slackbuilds script for 4.0 but run into the same error either way.

I downloaded json from the link on the slackbuilds for pulseaudio and also grabbed the latest I could find from the builders site again.

this is the error I get building pulseaudio


no package 'json' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBJSON_CFLAGS
and LIBJSON_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

hmm json built fine installed fine I am slackware64 but it installed to /usr/local/lib so I added that to /etc/ and ran ldconfig and pulseaudio not seeing it. scratching head, rebooted still same pulseaudio build error not finding json.

Drakeo 11-25-2013 12:45 AM


14.0 > Audio > pulseaudio (2.0)

pulseaudio is a networked sound server for Unix-like operating systems
and Microsoft Windows. It is intended to be an improved drop-in replacement
for the Enlightened Sound Daemon (ESOUND).

Pulseaudio will need a pulse group/user to run. You can add one with
# groupadd -g 216 pulse
# useradd -u 216 -g pulse -d /var/lib/pulse pulse
See for details on the uid/gid assignments.

Optional deps: jack-audio-connection-kit, avahi, lirc, libasyncns, orc

This requires: speex, json-c <=========================================

Maintained by: drhouse
Keywords: esound,daemon,pulsed,pulse,esd,sound,multimedia,server,pulseaudio
install those speex, json-c .
I do a lot of multimedia I have no use for pulse I used to keep a build of it for my friends. I think I still have the gpg-key some where :)
read the readme slackbuild team have done a great job. it is not finding json-c in you /usr/lib(64)/pkgconfig/ or is the wrong version. all these builds have been tested on a fresh system.

Oh yes those Optional deps: jack-audio-connection-kit, avahi, lirc, libasyncns, orc they really do help.
if I was you I would uninstall the json-c and rebuild it with the slack build scripts or at least configure set your prefix to the system 64 bit way and that is prefix=/usr libdir=/usr/lib64

it is a big deal to keep your programs in sync.
I just built it using the sbo scripts and it worked fine. but all my dependencies are the same/ pkgconfig is pointing it some where else.
this tell me the configure program on pulse looks for /usr/lib64 /usr/local/lib64

rcorkum 11-25-2013 07:25 AM

hmm I really appreciate all the feedback. this is a fresh install of 14.1 with a few slackbuild and tgz packages added nothing exotic (chrome, vlc, etc...) so I decided to do just that

I just did slackpkg clean-system and updated nothing to update so wanted to make sure I've moved all the sources and stuff I have already grabbed to a Downloads/Storage and made Downloads/fresh to figure this out.

so now to check my variable and start again.

All times are GMT -5. The time now is 11:47 PM.