-   Slackware (
-   -   Project FFMpeg (SlackBuild scripts) (

shilo 10-04-2005 09:56 PM

Project FFMpeg (SlackBuild scripts)
I've been working on getting FFMpeg installed from SlackBuild scripts. I have it all working at this point. Thought I'd share. Downloadable SlackBuild scripts are here:

Note that I do have some issues still. I'd love to get thosed ironed out before I move on to my next group of builds. Please post any questions or suggestions for the scripts here.

So you can get an idea what the end product is like:


Install prefix  /usr
Source path      /tmp/FFMpeg-20050921
C compiler      gcc
make            make
CPU              x86 (generic)
Big Endian      no
inttypes.h      yes
broken inttypes.h no
MMX enabled      yes
Vector Builtins  yes
gprof enabled    no
zlib enabled    yes
libgsm enabled  yes
mp3lame enabled  yes
libogg enabled  yes
vorbis enabled  yes
theora enabled  yes
faad enabled    yes
faadbin enabled  no
faac enabled    yes
xvid enabled    yes
x264 enabled    yes
a52 support      yes
a52 dlopened    no
dts support      no
pp support      yes
debug symbols    no
strip symbols    yes
optimize        yes
shared pp        yes
Video hooking    yes
SDL support      yes
Imlib2 support  yes
freetype support yes
Sun medialib support no
pthreads support yes
AMR-NB float support yes
AMR-NB fixed support yes
AMR-WB float support yes
AMR-WB IF2 support no
network support      yes
IPv6 support        yes
License: GPL

Here's the reasoning on the "no"s, in case anyone is interested:
Big Endian no ----- Not Applicable
broken inttypes.h no ----- Not Applicable(?)
gprof enabled no ----- No benefit
faadbin enabled no ----- No benefit(?)
a52 dlopened no ----- No benefit(?)
dts support no ----- Couldn't find the source code
debug symbols no ----- No benefit
Sun medialib support no ----- Seemed like a big hassle for non-free libraries
AMR-WB IF2 support no ----- No idea here. :)

Linux.tar.gz 10-04-2005 10:17 PM

If i understand right, you install some source packages and the script make the compile?

shilo 10-04-2005 10:28 PM


Originally posted by Linux.tar.gz
If i understand right, you install some source packages and the script make the compile?
Sure thing. The links to the source code are on the page. Works just like the SlackBuild scripts for Slackware.

As root:

Make a folder for each program

Download the SlackBuild, slack-desc, (if used), and the source tarball to that folder

cd to that folder


The package is in /tmp

Need to go in order (top to bottom).

Also, you'll probably want to read the scripts a little. FFMpeg needs you to download a couple other tarballs before you start.

Also, you probably want to right-click and "save as...". Easier than copy/paste.

tuxrules 10-05-2005 10:17 AM

good heavens...just what I was looking for.

I've been trying for a few days to install ffmpeg and I've had the same exact configure switches that Shilo mentions. However, everytime I do a make, it keeps giving me libavcodec errors which I think it should not since libavcodec is included in ffmpeg (pulled from CVS). So I tried the alternate route, and installed ffmpeg package from linuxpackages...thinking libavcodec would be installed. I then moved on to install libquicktime with libavcodec enabled but the libquicktime configure script can't find it. I've since removed the ffmpeg package from linuxpackages. To note that I had no such problem with slackware 10 & 10.1 where I installed all the deps without a problem.

I would like to capture my dv tapes onto my pc and make dvd's. So far I've managed to install libavc1394, libraw1394, libiec61883. libdv, libdc1394, libquicktime (linuxpackages), dvgrab (depends of libquicktime; from linuxpackages) and kino. However I must say it is less than desirable since dvgrab is not happy without libquicktime and I would really need ffmpeg to go.

Also i installed transcode yesterday but had to build it without libpostproc (included in ffmpeg). Anyway I am kinda confused here with so many packages and deps. I am still not an advanced slacker to write my build scripts although i've gone through a few of them.

Good job Shilo :D

All times are GMT -5. The time now is 09:33 PM.