-   Slackware (
-   -   Program Segmentation Fault when building with a Slackbuild (

Daedra 11-25-2010 10:41 PM

Program Segmentation Fault when building with a Slackbuild
This one has really got me,

So I've wanting to try out the new development branch of compiz (0.9). I made some slackbuilds a while back and installed all of the necessary packages for the compiz window manager. However when ever I tried to launch the program using "compiz --replace ccp &" I would get a segmentation fault. I forgot about it but today I decided to give it another go and after a few hours I decided to try and see what would happen if I just built compiz-core from source with out using a slackbuild, and sure enough it now works. I have hacked the script trying different combinations to try and make it work but no matter what I try unless I install from scratch (directly into the tree) it will not work. If anyone has any ideas on how to fix this so I can make an actual slack package please let me know. Also I used the main developers forum post as a referencem you can view his instructions here

I've attached my SlackBuild below for a reference.


Nevermind I got it, I had to remove the build-release cmake option.

archtoad6 11-28-2010 07:44 AM

Thanks for posting the solution. That's the LQ spirit.

A suggestion for the future: If you answer your own question, put the solution in a separate post; this does 2 good things:
  • It generates e-mail to anyone who subscribed to either the thread or the forum.
  • It avoids the creation of oxymoronic 0-reply solved threads.

All times are GMT -5. The time now is 08:07 PM.