LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   program run with wine cant find CD (https://www.linuxquestions.org/questions/slackware-14/program-run-with-wine-cant-find-cd-82175/)

veritas 08-15-2003 03:27 AM

program run with wine cant find CD
 
So i got wine installed, edited the config file to my specs. But when i first tried to test Diablo II,by wine'ing Game.exe, i get a Windows error box that says "Please Insert Expansion CD". So its not finding the CD.

things ive tried:
1. went into config and changed the cdrom device to "/dev/hdc" (since /dev/cdrom linked to it)
2. messed around with the permissions on /dev/hdc
But im not really sure if I did it right.

How would i fix this prob? Is it a matter of permissions, and what do i need to do to the permissions for the device?

BTW, im doing all of this while on root.

reclusivemonkey 08-15-2003 06:22 AM

Wine doesn't want to run as root. You should run it as a user. I have no idea about Diablo, but here's a HOWTO:

http://balgo.ath.cx/diablo/index2.html

munkeh

figadiablo 08-15-2003 07:42 AM

Try
chmod 755 /dev/hdc


Figa

veritas 08-15-2003 02:36 PM

ok, first ill try to wine Diablo II as a user. If that doesn't work, ill try that cmod command for the cdrom block. Then a followup.

veritas 08-15-2003 03:16 PM

Made a little progress with this.. i got my wine running under a normal user, but now its giving me cdrom permission errors..

fixme:cdrom:CDROM_Open Can't open configured CD-ROM drive at D:\ (device /dev/cdrom): Permission denied
fixme:cdrom:CDROM_GetStatusCode Unmapped error code 9: Bad file descriptor
fixme:ntdll:RtlNtStatusToDosError no mapping for 00000001

ill try to cmod /dev/hdc, because for some reason you can cmod /dev/cdrom. Then post a followup.

veritas 08-15-2003 03:32 PM

Back to square one
 
changed cdrom permissions, changed Windows mount permissions, ran wine with user.. but back to the same problem I had with root.. Please Insert Expansion CD.

Any ideas?

reclusivemonkey 08-17-2003 04:43 PM

Can you post your /etc/fstab?

veritas 08-19-2003 11:10 AM

Here's my /etc/fstab:

/dev/hda6 swap swap defaults 0 0
/dev/hda5 / ext3 defaults 1 1
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0
/dev/hda1 /mnt/dos ntfs ro,umask=000 0 0


All times are GMT -5. The time now is 10:51 PM.