LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-25-2004, 01:20 PM   #1
mrgrieves
Member
 
Registered: Apr 2004
Location: north of 52, south of 54
Distribution: slackware 10.0
Posts: 108

Rep: Reputation: 15
ProftpD doesn't work with Slackware!?


I've tried again and again to get it to work, but I have no idea why its not working, even after reading material on how to set it up.

I'm pretty sure (99.9%) its set to run on startup. When I type:
proftpd start
or
proftpd stop

in the command line, it spits this back out at me:
localhost - fatal: Socket operation on non-socket
localhost - (Running from command line? Use `ServerType standalone' in config file!)

I have the proper ports forwarded and everything. (I imagine the only ones that matter most are 20-23, but the higher passive ones are enabled too)

Have any of you had similar problems with proftp on slackware?

-Thanks
 
Old 04-25-2004, 01:50 PM   #2
Wynd
Member
 
Registered: Jul 2001
Distribution: Slackware 12
Posts: 511

Rep: Reputation: 32
Re: ProftpD doesn't work with Slackware!?

Quote:
Originally posted by mrgrieves

localhost - (Running from command line? Use `ServerType standalone' in config file!)
You are trying to run it from the command line. Edit /etc/proftpd.conf and change "ServerType inetd" to "ServerType standalone".
 
Old 04-25-2004, 02:15 PM   #3
mrgrieves
Member
 
Registered: Apr 2004
Location: north of 52, south of 54
Distribution: slackware 10.0
Posts: 108

Original Poster
Rep: Reputation: 15
It has been. Same error
 
Old 04-25-2004, 02:34 PM   #4
Y@bon
LQ Newbie
 
Registered: Oct 2003
Posts: 13

Rep: Reputation: 0
Use "netstat -l --inet" to determine ports which are listening (before et after start the demon).

If you use the standalone mode, comment the line :
"ftp stream tcp nowait root /usr/sbin/tcpd proftpd"
in /etc/inetd.conf...

You must be root to bind on ports < 1024.
 
Old 04-25-2004, 08:28 PM   #5
flamesrock
Member
 
Registered: Aug 2003
Distribution: Gentoo 2006.1
Posts: 405

Rep: Reputation: 30
Theres doesn't seem to be that line in /etc/inetd.conf.

Here's the output from that command:

root@localhost:~# netstat -l --inet
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0 *:time *:* LISTEN
tcp 0 0 *:3306 *:* LISTEN
tcp 0 0 *:submission *:* LISTEN
tcp 0 0 *:finger *:* LISTEN
tcp 0 0 *:http *:* LISTEN
tcp 0 0 *:auth *:* LISTEN
tcp 0 0 localhost.localh:domain *:* LISTEN
tcp 0 0 localhost:domain *:* LISTEN
tcp 0 0 *:ftp *:* LISTEN
tcp 0 0 *:ssh *:* LISTEN
tcp 0 0 *:smtp *:* LISTEN
tcp 0 0 localhost:953 *:* LISTEN
udp 0 0 *:biff *:*
udp 0 0 *:32769 *:*
udp 0 0 *:ntalk *:*
udp 0 0 *:time *:*
udp 0 0 localhost.localh:domain *:*
udp 0 0 localhost:domain *:*



?
 
Old 04-25-2004, 11:26 PM   #6
flamesrock
Member
 
Registered: Aug 2003
Distribution: Gentoo 2006.1
Posts: 405

Rep: Reputation: 30
EDIT:: Sorry, this is mrgrieves, my old username cached in a different browser.
 
Old 04-26-2004, 12:45 AM   #7
flashingcurser
Member
 
Registered: Jan 2003
Distribution: many win/nix/mac
Posts: 259

Rep: Reputation: 31
what does your config file look like?



(proftpd has always worked well for me--I think there is even a walkthrough here at linuxquestions)
 
Old 04-26-2004, 12:53 AM   #8
shilo
Senior Member
 
Registered: Nov 2002
Location: Stockton, CA
Distribution: Slackware 11 - kernel 2.6.19.1 - Dropline Gnome 2.16.2
Posts: 1,132

Rep: Reputation: 50
Maybe it's as simple as opening up the file /etc/inetd.conf and changing the line that looks like this:
Code:
# These are standard services:
#
# File Transfer Protocol (FTP) server:
#ftp     stream  tcp     nowait  root    /usr/sbin/tcpd  proftpd
#
# Telnet server:
#telnet	stream  tcp     nowait  root    /usr/sbin/tcpd	in.telnetd
to look like this:
Code:
# These are standard services:
#
# File Transfer Protocol (FTP) server:
ftp     stream  tcp     nowait  root    /usr/sbin/tcpd  proftpd
#
# Telnet server:
#telnet	stream  tcp     nowait  root    /usr/sbin/tcpd	in.telnetd
and rebooting. I'll bet there is even a way where you don't have to reboot, but I always figure, "Hey, I already spent hours fixing this. What a couple more seconds?"

Also, I'm not too sharp, but doesn't this
Quote:
tcp 0 0 *:ftp *:* LISTEN
mean that your FTP server is working? That's what I thought it meant on mine.

Last edited by shilo; 04-26-2004 at 12:58 AM.
 
Old 04-26-2004, 05:04 AM   #9
elp
Member
 
Registered: Aug 2003
Posts: 66

Rep: Reputation: 16
>and rebooting. I'll bet there is even a way where you don't have to reboot, but I always >figure, "Hey, I already spent hours fixing this. What a couple more seconds?"

Yep, ps ax and find the line inetd and its pid, and then kill -HUP "pid"

and it will restart.
 
Old 04-30-2004, 10:10 PM   #10
mrgrieves
Member
 
Registered: Apr 2004
Location: north of 52, south of 54
Distribution: slackware 10.0
Posts: 108

Original Poster
Rep: Reputation: 15
Sorry for replying so late...this has been a *really* busy week.

Unfortunately, Shilo, that line seems to be exactly as you recommended. Can you (or anyone else) spot the problems in the config?

Quote:
# See "man 8 inetd" for more information.

#
# If you make changes to this file, either reboot your machine or send the
# inetd a HUP signal:
# Do a "ps x" as root and look up the pid of inetd. Then do a
# "kill -HUP <pid of inetd>".

# The inetd will re-read this file whenever it gets that signal.
#
# <service_name> <sock_type> <proto> <flags> <user> <server_path> <args>

#
# The first 4 services are really only used for debugging purposes, so
# we comment them out since they can otherwise be used for some nasty
# denial-of-service attacks. If you need them, uncomment them.
# echo stream tcp nowait root internal
# echo dgram udp wait root internal
# discard stream tcp nowait root internal
# discard dgram udp wait root internal

# daytime stream tcp nowait root internal
# daytime dgram udp wait root internal
# chargen stream tcp nowait root internal
# chargen dgram udp wait root internal
time stream tcp nowait root internal
time dgram udp wait root internal

#
# These are standard services:
#
# File Transfer Protocol (FTP) server:
ftp stream tcp nowait root /usr/sbin/tcpd proftpd

#
# Telnet server:
#telnet stream tcp nowait root /usr/sbin/tcpd in.telnetd
#

# The comsat daemon notifies the user of new mail when biff is set to y:
comsat dgram udp wait root /usr/sbin/tcpd in.comsat

#
# Shell, login, exec and talk are BSD protocols
#
#shell stream tcp nowait root /usr/sbin/tcpd in.rshd -L
#login stream tcp nowait root /usr/sbin/tcpd in.rlogind
# exec stream tcp nowait root /usr/sbin/tcpd in.rexecd
# talk dgram udp wait root /usr/sbin/tcpd in.talkd
ntalk dgram udp wait root /usr/sbin/tcpd in.talkd


#
# To use the talk daemons from KDE, comment the talk and ntalk lines above
# and uncomment the ones below:
# talk dgram udp wait root /usr/sbin/tcpd /opt/kde/bin/kotalkd
# ntalk dgram udp wait root /usr/sbin/tcpd /opt/kde/bin/ktalkd

#
# Kerberos authenticated services
#

# klogin stream tcp nowait root /usr/sbin/tcpd rlogind -k
# eklogin stream tcp nowait root /usr/sbin/tcpd rlogind -k -x
# kshell stream tcp nowait root /usr/sbin/tcpd rshd -k


#
# Services run ONLY on the Kerberos server
#

# krbupdate stream tcp nowait root /usr/sbin/tcpd registerd
# kpasswd stream tcp nowait root /usr/sbin/tcpd kpasswdd

#
# POP and IMAP mail servers
#

# Post Office Protocol version 3 (POP3) server:
#pop3 stream tcp nowait root /usr/sbin/tcpd /usr/sbin/popa3d


# Internet Message Access Protocol (IMAP) server:
#imap2 stream tcp nowait root /usr/sbin/tcpd imapd

#
# The Internet Unix to Unix copy (UUCP) service:
# uucp stream tcp nowait uucp /usr/sbin/tcpd /usr/lib/uucp/uucico -l

#
# Tftp service is provided primarily for booting. Most sites
# run this only on machines acting as "boot servers."
# tftp dgram udp wait nobody /usr/sbin/tcpd in.tftpd
# bootps dgram udp wait root /usr/sbin/bootpd bootpd


#

# Finger, systat and netstat give out user information which may be
# valuable to potential "system crackers." Many sites choose to disable
# some or all of these services to improve security.
# Try "telnet localhost systat" and "telnet localhost netstat" to see that
# information yourself!
finger stream tcp nowait nobody /usr/sbin/tcpd in.fingerd -u

# systat stream tcp nowait nobody /usr/sbin/tcpd /bin/ps -auwwx
# netstat stream tcp nowait root /usr/sbin/tcpd /bin/netstat -a
#

# Ident service is used for net authentication
# Since we start identd as nobody, it can't write a .pid file in /var/run, so tell it
# to use /dev/null. This is of little importance unless you run identd as a
# standalone daemon anyway.

auth stream tcp wait nobody /usr/sbin/in.identd in.identd -P/dev/null

#
# These are to start Samba, an smb server that can export filesystems to
# Pathworks, Lanmanager for DOS, Windows for Workgroups, Windows95, Lanmanager

# for Windows, Lanmanager for OS/2, Windows NT, etc.
# If you're running smbd and nmbd as daemons in /etc/rc.d/rc.samba, then you

# shouldn't uncomment these lines.
#netbios-ssn stream tcp nowait root /usr/sbin/smbd smbd
#netbios-ns dgram udp wait root /usr/sbin/nmbd nmbd

#
#Samba Web Administration Tool:
#swat stream tcp nowait.400 root /usr/sbin/swat swat
#
# Sun-RPC based services.
# <service name/version><sock_type><rpc/prot><flags><user><server><args>

# rstatd/1-3 dgram rpc/udp wait root /usr/sbin/tcpd rpc.rstatd
# rusersd/2-3 dgram rpc/udp wait root /usr/sbin/tcpd rpc.rusersd
# walld/1 dgram rpc/udp wait root /usr/sbin/tcpd rpc.rwalld


#
# End of inetd.conf.
-Thanks for the help!

Last edited by mrgrieves; 04-30-2004 at 10:12 PM.
 
Old 04-30-2004, 10:19 PM   #11
shilo
Senior Member
 
Registered: Nov 2002
Location: Stockton, CA
Distribution: Slackware 11 - kernel 2.6.19.1 - Dropline Gnome 2.16.2
Posts: 1,132

Rep: Reputation: 50
Looks good to me. Do me a favor, go to a terminal and type
Code:
ftp localhost
and post the output here.
 
Old 04-30-2004, 10:24 PM   #12
mrgrieves
Member
 
Registered: Apr 2004
Location: north of 52, south of 54
Distribution: slackware 10.0
Posts: 108

Original Poster
Rep: Reputation: 15
Connected to localhost.
220 ProFTPD 1.2.8 Server (Flamesrocks' Flames Flames) [localhost]


-Thanks
 
Old 04-30-2004, 10:31 PM   #13
shilo
Senior Member
 
Registered: Nov 2002
Location: Stockton, CA
Distribution: Slackware 11 - kernel 2.6.19.1 - Dropline Gnome 2.16.2
Posts: 1,132

Rep: Reputation: 50
No problemo. Like my earlier post said,
Quote:
tcp 0 0 *:ftp *:* LISTEN
means that your ftp server is working. You may need to open up port 21 on your router so that you can access your ftp server from the internet. Let me know if you have any more problems.

Shilo
 
Old 04-30-2004, 10:33 PM   #14
mrgrieves
Member
 
Registered: Apr 2004
Location: north of 52, south of 54
Distribution: slackware 10.0
Posts: 108

Original Poster
Rep: Reputation: 15
Thumbs up ...

Thanks!

I'll let you know when its working.
 
Old 05-02-2004, 03:57 AM   #15
mrgrieves
Member
 
Registered: Apr 2004
Location: north of 52, south of 54
Distribution: slackware 10.0
Posts: 108

Original Poster
Rep: Reputation: 15
Ok, I think its working, but how do I add a user?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mount --bind doesn't work with proftpd Diotoir Linux - Newbie 2 08-23-2004 01:05 PM
Slackware 10 proftpd problem virus2547 Linux - Networking 5 08-20-2004 12:01 AM
Cant get proftpd to work ChrisNash Mandriva 8 08-25-2003 07:19 AM
ProFTPd Configuration Help on Slackware deesto Slackware 2 01-06-2003 05:58 PM
Proftpd 1.2.6 in Slackware 8.1 sitrus Slackware 3 11-10-2002 05:49 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration