LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-14-2019, 03:32 PM   #1
usr345
Member
 
Registered: Jan 2012
Posts: 118
Blog Entries: 1

Rep: Reputation: Disabled
Problems with wicd


I am using Linux Slackware 14.2. I have 2 locations:

1. Home - using cable connection, static IP:
PC address: 192.168.1.4/24
Default gateway: 192.168.1.1

2. External location - wi-fi with DHCP. I installed wicd package, and it's working fine.

Problem 1


After installing wicd at home when I unplug the cable, the IP address and the default gateway disappear. And don't reappear when I plug it back. So every time I have to switch to root and run these commands:

# ifconfig eth0 192.168.1.4/24
# route add default gw 192.168.1.1

Sometimes /etc/resolv.conf is being cleared, so I have to manually write nameservers at home.

How can I make it use my static address at home, so it won't destroy the configs? What about the name servers? I should rewrite them in external location and then back when I am at home.

Problem 2


wicd-client is being launched automatically when I start KDE. How to make it run on demand?

Even if close the laptop lid, the eth0 network connection is being destroyed.

Last edited by usr345; 01-14-2019 at 03:50 PM.
 
Old 01-14-2019, 06:57 PM   #2
Gordie
Member
 
Registered: Aug 2007
Location: Nolalu, Ontario, Canada
Posts: 521

Rep: Reputation: 179Reputation: 179
From the note on wicd that I keep:
To run wicd choose DHCP or anything else other than "NetworkManager" when configuring the network.
#
Install wicd from the extra directory
#
After installing this package, make sure the /etc/rc.d/rc.wicd
script is executable; if necessary, do:
chmod +x /etc/rc.d/rc.wicd

Results have varied, but you will probably need/want to remove
any references to interfaces from /etc/rc.d/rc.inet1.conf - in
other words, make that file look as if netconfig has never been
run.
(I have found that in every case where I have used NetworkManager and then changed to wicd there was no need to make any changes to /etc/rc.d/rc.inet1.conf
#
Use the Window Manager settings to autostart "wicd-client" upon startup.
#
When you start X, you should see a wicd icon in the system tray;
click on it to open the gui interface and configure as desired.
Your user account will need to be a member of the 'netdev' group
in order to use wicd.
#
Note that urwid will need to be installed if you want to use the
curses client. Also, if you don't have kde installed, you won't
have a graphical sudo client available.
 
Old 01-15-2019, 12:32 PM   #3
usr345
Member
 
Registered: Jan 2012
Posts: 118

Original Poster
Blog Entries: 1

Rep: Reputation: Disabled
Now the situation is better. But still 2 problems exist:

1. When I close the laptop lid and reopen it, eth0 connection disappears. And every time I have to run:

# ifconfig eth0 192.168.1.4/24
# route add default gw 192.168.1.1

2. I removed wicd-client link from /usr/share/autostart, but it still autostarts together with computer.
 
Old 01-15-2019, 01:51 PM   #4
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.2
Posts: 3,286

Rep: Reputation: 1648Reputation: 1648Reputation: 1648Reputation: 1648Reputation: 1648Reputation: 1648Reputation: 1648Reputation: 1648Reputation: 1648Reputation: 1648Reputation: 1648
Your desktop session is probably what's bringing wicd back up.
 
Old 01-15-2019, 04:42 PM   #5
rob.rice
Senior Member
 
Registered: Apr 2004
Distribution: slack what ever
Posts: 1,073

Rep: Reputation: 202Reputation: 202Reputation: 202
wicd runs on boot up
use DHCP on our home net work
configure eth0 to use DHCP in wicd
or
configure eth0 in wicd (highlight eth0 hit the right arrow in wicd-curses) you will need to check the always show wired connection box in wicd preferences ("P" in wicd-curses)
 
Old 01-16-2019, 12:11 PM   #6
usr345
Member
 
Registered: Jan 2012
Posts: 118

Original Poster
Blog Entries: 1

Rep: Reputation: Disabled
Quote:
Originally Posted by Richard Cranium View Post
Your desktop session is probably what's bringing wicd back up.
How to turn it off, so it won't run and spoil my connection?
 
Old 01-16-2019, 12:19 PM   #7
Gordie
Member
 
Registered: Aug 2007
Location: Nolalu, Ontario, Canada
Posts: 521

Rep: Reputation: 179Reputation: 179
Quote:
Originally Posted by usr345 View Post
How to turn it off, so it won't run and spoil my connection?

Settings / Session and Startup
 
Old 01-16-2019, 05:22 PM   #8
usr345
Member
 
Registered: Jan 2012
Posts: 118

Original Poster
Blog Entries: 1

Rep: Reputation: Disabled
Quote:
Originally Posted by Gordie View Post
Settings / Session and Startup
Sorry, can't find it in KDE. I have even turned off /etc/rc.d/rc.wicd, but it still runs somehow on lid open.
 
Old 01-16-2019, 05:30 PM   #9
Gordie
Member
 
Registered: Aug 2007
Location: Nolalu, Ontario, Canada
Posts: 521

Rep: Reputation: 179Reputation: 179
Quote:
Originally Posted by usr345 View Post
Sorry, can't find it in KDE. I have even turned off /etc/rc.d/rc.wicd, but it still runs somehow on lid open.
Oh, KDE. I just know it is in the settings but I don't run KDE but run XFCE. I have Plasma5. KDE is on my desktop but is Slackware-current there. You really can't find it?
 
Old 01-16-2019, 05:44 PM   #10
Gordie
Member
 
Registered: Aug 2007
Location: Nolalu, Ontario, Canada
Posts: 521

Rep: Reputation: 179Reputation: 179
Plasma5 - Settings / System Settings / Startup and Shutdown / Desktop Session / Desktop Session and Logout

KDE - System Settings / System Administration / Startup And Shutdown / Session Management

Last edited by Gordie; 01-18-2019 at 12:16 AM. Reason: More details
 
Old 01-16-2019, 07:27 PM   #11
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 6,017

Rep: Reputation: 3685Reputation: 3685Reputation: 3685Reputation: 3685Reputation: 3685Reputation: 3685Reputation: 3685Reputation: 3685Reputation: 3685Reputation: 3685Reputation: 3685
Most likely you're referring to KDE's Network Management icon, which is not part of wicd or Network Manager (but I believe it can work with both). The way to disable it is not very easy to find. You have to right click on the System Tray (not on any of the icons within the system tray as you'll get a context menu for that application) where you get the System Tray Settings option. Open that and you can uncheck "Network Management", which is under "Extra Items" on the "Display" tab/group/whatever (should be the default when the window comes up).

This is thanks to phenixia2003 on this post.
 
Old 01-17-2019, 01:34 AM   #12
usr345
Member
 
Registered: Jan 2012
Posts: 118

Original Poster
Blog Entries: 1

Rep: Reputation: Disabled
Quote:
Originally Posted by Gordie View Post
Oh, KDE. I just know it is in the settings but I don't run KDE but run XFCE. I have Plasma5. KDE is on my desktop but is Slackware-current there. You really can't find it?
No. After disabling /etc/rc.d/rc.wicd and rebooting it stopped breaking the network. But wicd-client still runs on startup.

Maybe I should setup it so that it will manage both eth0 and wlan0?

Click image for larger version

Name:	snapshot1.png
Views:	15
Size:	94.4 KB
ID:	29481

Last edited by usr345; 01-17-2019 at 01:35 AM.
 
Old 01-17-2019, 11:25 AM   #13
Gordie
Member
 
Registered: Aug 2007
Location: Nolalu, Ontario, Canada
Posts: 521

Rep: Reputation: 179Reputation: 179
You have to clear your saved sessions and don't save any new ones
 
Old 01-17-2019, 04:35 PM   #14
rob.rice
Senior Member
 
Registered: Apr 2004
Distribution: slack what ever
Posts: 1,073

Rep: Reputation: 202Reputation: 202Reputation: 202
Quote:
Originally Posted by Richard Cranium View Post
Your desktop session is probably what's bringing wicd back up.
wicd is a daemon it starts at boot and runs in the back ground
it's not being brought back up it was never shut down

if the OP would just configure his eth0 connection in wicd his problem would solved

this is linux not windoze there is no wizard to do this for hem HE must plug the numbers in to wicd himself the same numbers he is using in the ifconfig command lines

man wicd-wired-settings.conf
man wicd-manager-settings.conf

may be OP will tack the word of the man pages it looks like my advice is being dismissed out of hand
 
Old 01-17-2019, 04:39 PM   #15
rob.rice
Senior Member
 
Registered: Apr 2004
Distribution: slack what ever
Posts: 1,073

Rep: Reputation: 202Reputation: 202Reputation: 202
Quote:
Originally Posted by usr345 View Post
No. After disabling /etc/rc.d/rc.wicd and rebooting it stopped breaking the network. But wicd-client still runs on startup.

Maybe I should setup it so that it will manage both eth0 and wlan0?

Attachment 29481
YES!! YES !! yes !!
this is exactly what you should do let wicd manage both eth0 and wlan0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Wicd Could not connect to wicd's D-Bus interface GreenFireFly Slackware 6 04-29-2019 12:48 PM
[SOLVED] wicd or wicd-gtk problem Altoid Linux - Software 2 07-12-2017 09:03 AM
[SOLVED] Why `systemctl disable wicd.service`can't disable wicd ? luofeiyu Linux - Newbie 5 08-24-2016 11:54 AM
WICD tray icon says not connected, WICD manager says conneted to wired network?!?! intheshadows Linux - Newbie 1 12-24-2009 12:15 PM
Problems with WICD in XUbuntu Neej Suab Linux - Newbie 0 11-20-2007 08:41 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration