LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Problems with UTF-8 characters after installing the multilib in 14.2 (https://www.linuxquestions.org/questions/slackware-14/problems-with-utf-8-characters-after-installing-the-multilib-in-14-2-a-4175636219/)

panpo 08-12-2018 09:13 AM

Problems with UTF-8 characters after installing the multilib in 14.2
 
Hi,

I am experiencing some problems when I type UTF-8 characters. I have an issue with nvi, vim and less.

With nvi, if I type a non-ascii character, the program exited with the message: "Aborted (core dumped)".

With vim, non-ascii characters are not properly rendered. For example, the "" character is inserted as " ", "" as "�~B�", etc. I have the same problem with elvis.

With less, some UTF-8 are print in hex value, for exemple, "" is printed as "<C3><A9>".

Other informations :

- I am running Slackware 14.2,
- I have commented the "export LANG=en_US" line in /etc/profile.d/lang.sh file and uncommented the "export LANG=en_US.UTF-8" line,
- when I have installed the multilib, I did it with slackpkg+ but I seleccted the wrong slackware version. I
installed the multilib for -current. So I tried to remove it install the 14.2 one instead,
- I have a quick fix for those problems:

Code:

# slackpkg upgrade-all
# slackpkg upgrade multilib
# slackpkg install multilib

But I did not find when and why the problem appears again. Is there a way to fix it?

Thanks !

business_kid 08-13-2018 08:39 AM

It generally annoys people when you duplicate question posts.

Are you opening those in xterms, or runlevel 3 before you start X?
I would try a different codepage, perhaps 850 instead of 437 and look at the bash profile settings. You seem to be fond of Vi clones, though not vim. For xterms, there's also ~/.bashrc.
For those matters the general line of attack is 'keep messing about with adjustments until you're satifsfied, then stop.' I would also go through the individual program's config.


All times are GMT -5. The time now is 04:45 AM.