LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-03-2018, 03:02 PM   #1
coralfang
Member
 
Registered: Nov 2010
Location: Bristol, UK
Distribution: Slackware, FreeBSD
Posts: 736
Blog Entries: 3

Rep: Reputation: 227Reputation: 227Reputation: 227
Problems with time synchronization with multiple OS


I've recently hooked up a HDD with a Windows 10 install on it, which i have been using for nothing more than a few games.

Basically, if i boot into Windows, even if just for an hour. When i boot back into Slackware, the system clock is always 1 hour ahead.

It's funny because i keep going to bed an hour before i need to, or i think i'm late for something. It's only occured to me just now, that my clock keeps getting pushed 1 hour ahead.

Now why is this happening. I have /etc/rc.d/rc.ntp executable, the daemon is running from boot.

I also have in /etc/ntp.conf
Code:
server 0.pool.ntp.org iburst
The daemon seems to do nothing. I always have to do this manually:

Code:
root@darkstar:~# ntpdate  0.pool.ntp.org
 3 Jun 22:00:22 ntpdate[1762]: the NTP socket is in use, exiting
root@darkstar:~# /etc/rc.d/rc.ntpd  stop
Stopping NTP daemon...
root@darkstar:~# ntpdate  0.pool.ntp.org
 3 Jun 21:00:40 ntpdate[1804]: step time server 185.51.192.34 offset -3599.335881 sec
root@darkstar:~#
I realise Windows is at fault here for changing the system clock, but how can i stop this?

If it means anything, i'm currently in BST timezone (British summertime), which is UTC+1.
 
Old 06-03-2018, 03:06 PM   #2
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 19.1 MATE
Posts: 7,135
Blog Entries: 2

Rep: Reputation: 2489Reputation: 2489Reputation: 2489Reputation: 2489Reputation: 2489Reputation: 2489Reputation: 2489Reputation: 2489Reputation: 2489Reputation: 2489Reputation: 2489
I thought I had seen someone with this problem before:

https://www.howtogeek.com/323390/how...-dual-booting/

Is that of any help?
 
Old 06-03-2018, 04:03 PM   #3
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.2
Posts: 3,215

Rep: Reputation: 1576Reputation: 1576Reputation: 1576Reputation: 1576Reputation: 1576Reputation: 1576Reputation: 1576Reputation: 1576Reputation: 1576Reputation: 1576Reputation: 1576
Run /usr/sbin/timeconfig and when it asks if the hardware clock is set to UTC, say NO.
 
1 members found this post helpful.
Old 06-03-2018, 05:15 PM   #4
coralfang
Member
 
Registered: Nov 2010
Location: Bristol, UK
Distribution: Slackware, FreeBSD
Posts: 736

Original Poster
Blog Entries: 3

Rep: Reputation: 227Reputation: 227Reputation: 227
Quote:
Originally Posted by Richard Cranium View Post
Run /usr/sbin/timeconfig and when it asks if the hardware clock is set to UTC, say NO.
Ah i believe that is the problem. I remember years ago having this issue when i was dual booting on vista, that just rung a bell with setting either UTC or localtime. I just set Slackware's time to localtime using pkgtool, which i assume runs timeconfig also. Thanks, this seems to be the best solution.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
time synchronization - NTP tractng Linux - Newbie 1 04-02-2008 08:28 PM
Time Synchronization joeflomo Linux - Networking 1 03-10-2006 10:39 AM
Time synchronization kornerr Linux - General 2 02-18-2006 09:02 AM
time synchronization on HPUX11 ntoughe Other *NIX 2 10-25-2005 10:46 AM
Time Synchronization mykrob SUSE / openSUSE 4 10-23-2004 04:09 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration