-   Slackware (
-   -   Problems with Slackware-current (

gmartin 06-13-2009 03:38 PM

Problems with Slackware-current
I'm beginning work on my new PC. Thought I would load -current on it to get started then rebuild it once Slackware 13 hits the streets. The PC is a Dell Optiplex 760 - Core 2 Duo. Thinking I'd experiment, I built with Slackware64 then when that didn't work, I switched to 32-bit but have the same problem. Hope someone can help.

The install goes great, I partition my drive, run the install which moves quickly along. Once complete, lilo goes well (as MBR), I reboot and the trouble begins.

While booting, after the line

ppdev: user space parallel port driver
is displayed, everything pauses. Once paused, I have to press a key in order to get another line displayed. Sometimes a line is displayed every time I press enter, and other times, it will take 20-30 seconds before another line is displayed. Eventually, the system will stop responding all together.

FWIW, I've tried this with different -current builds. Both the June 3rd and with the June 11th.

Any ideas on what could be wrong?

Bruce Hill 06-13-2009 05:52 PM

Have you checked the md5sum of the ISO you used, and the md5sum of the CD/DVD you burned? Sounds like a corrupt media to me.

gmartin 06-13-2009 09:10 PM


Originally Posted by Bruce Hill (Post 3573019)
Sounds like a corrupt media to me.

Seems unlikely given that three different ISOs exhibited the same exact behavior. But I'll give it a shot.

samac 06-14-2009 04:02 AM

If it is installed, it is not bad media. If you google for "Dell Optiplex 760 Linux" you will find the answer, but here is a quote from another site that should explain the problem

If you rely on Linux for imaging, you probably have been swearing a lot since HP released their dc7900 and Dell released the Optiplex 760.

These models use the Intel's latest ICH10 SATA controller which is not supported in Linux Automation.
I believe that drivers are available, and you will have to download them and patch the kernel.


gmartin 06-14-2009 12:18 PM

OK, this sounds familiar. I've seen the same problem on Xp installs where the SATA drivers aren't part of the original install. On XP, changing the BIOS would allow the OS ti install. I tried changing the BIOS setting to ATA but had the same issue. I wonder if I need to reload the OS to make it work.

Any chance this is a popular enough machine that the driver will get built in the kernel? I'm not big on customizing my kernel.

gmartin 06-14-2009 08:26 PM

Hate to answer my own message, but can I build an initrd for this driver?

rworkman 06-30-2009 12:00 PM

I replied privately with this, but for the sake of anyone else who might be having issues with the 760, have a look at this:

gmartin 06-30-2009 11:53 PM


Originally Posted by rworkman (Post 3591732)
I replied privately with this, but for the sake of anyone else who might be having issues with the 760, have a look at this:

Thanks for the link, Rob. I ran a few test and have good news to report.

Both of these solutions resulted in a bootable/usable systems or me. Not sure which is the 'optimal' fix. There seems no need to do both.

- Turning C States Control off in the BIOS
(However, some report that this option is not available for certain CPU models)

- Adding the boot option 'hpet=disabled'

Someone else noted that the boot option 'acpi_skip_timer_override' fixed the problem for them. It did NOT work for me.

Last thing is there is a BIOS update A02 -> A03 that is supposed to fix the problem. I haven't worked out how to upgrade from within Slackware. Once I do, I'll post back.

All times are GMT -5. The time now is 06:02 PM.