-   Slackware (
-   -   Problems with Java Web Start (java 1.4.2 - 1.5.0) on Slackware (

Egy 01-25-2005 01:33 PM

Problems with Java Web Start (java 1.4.2 - 1.5.0) on Slackware

I have a problem with Java Web Start from j2sdk1.4.2_04 and j2sdk1.5.0_1 on Slackware 10 with kde and glibc upgraded to -current. When I run /usr/lib/java/jre/javaws /javaws it starts and do nothing while using all CPU power. The funny thing is that old version of Java Web Start (1.0.1 as opposed to 1.2 which shipped with j2sdk1.4.2 and j2sdk1.50 ) works just fine. I suspect it somehow related to glibc upgrade but the sad thing is that I dont remember whether it worked before my upgrades.

Any suggestions ?

carboncopy 01-26-2005 05:50 AM

Maybe you want to roll back glibc update just to try out? Just removepkg glibc<-current> and installpkg glibc<-previous>. :) Any better idea?

Egy 01-26-2005 09:46 AM

Thanks for reply.

I'll try it but currently I have no time. Andit will screw up my bright&shiny KDE 3.3 :).
If you can please try to run javaws on fully update slack-current.

keefaz 01-26-2005 10:01 AM

Be very carefull when removepkg glibc as you may able to do just nothing after that as nearly all
programs are linked to libc (rm, bash, ls, login etc..).

I would even not try the upgradepkg --reinstall, instead I would boot from a live CD to do this
(to be sure) . It happened to me once (I solved the problem by copy the from the live
slackware CD to /lib of my root partition)

carboncopy 01-26-2005 12:12 PM

Thanks for pointing that out keefaz, cause I have no idea that would happen. BUT shouldn't pkgtool and installpkg, removepkg etc. compiled statically? So, after removing glibc and installpkg again, without logging out should be fine? Correct me if I am wrong. am still learning.

keefaz 01-26-2005 12:44 PM

There are not binaries executables, they are plain text scripts that rely on binaries compiled
with libc (/bin/dialog, /bin/rm, /bin/mkdir, /bin/chmod, /bin/cat...)

Egy 01-26-2005 01:04 PM

Thanks for advice about LiveCD, keefaz. I would probably missed it and completely break my system :)

I'd like to ask anybody with slack -current or 10.1 try to run javaws and share his results if it runs properly at all.

Thanks in advance.

keefaz 01-26-2005 01:06 PM

I have the same result as you : nothing and 99.9% CPU usage (barton 2600+ xp here...)
showed by top

Egy 01-26-2005 01:14 PM

That's funny :) I don't think it's problem with java itself - i've seem it working on SUSE 9.2 and FC3. May be it's time to submit bug to Patrick ?

abrb220 05-10-2005 06:57 AM

Did you manage to sort this out, as I am getting the same.
Running Redhat advanced server 4 though.

Egy 05-10-2005 07:18 AM

Yes I did, and it was the problem with Sun JDK.

If you need 1.4.2 JDK you can take this one from - it works :

Sun's 1.5 Update 3 works fine, too.

abrb220 05-10-2005 07:30 AM

You are a star, scholar and gentleman.

All times are GMT -5. The time now is 10:16 AM.