-   Slackware (
-   -   Problems with corrupt files/logging in (

Atmchicago 06-03-2004 12:20 AM

Problems with corrupt files/logging in
Here goes:

I'm running Slackware 9.1 and have compiled my own 2.6 kernel. However, for some reason, I've started getting a lot of errors on my hard drive (I think they're related to my kernel, but I'm not sure). The errors have messed up a lot of packages on my system - real basic ones like uname, whereis.... and they seem to be random ones.

So I loaded up knoppix and the slack cd and used that to copy over the un-corrupted files so I can boot up normally again. This has worked so far, except that when I try to login (I'm not booting into X) it does the following:

Enter username:

[pause 5 secs]

Enter username:

[pause 5 secs]

and so on. I never get to say what my password is, and so I can't log in. Is there a package that's still corrupt? If so, which one? I'm going to back up all my stuff and reinstall once I can log in, or else use Knoppix as the last resort to bakup with, but it would be nice if I could do without knoppix.

Thanks in advance.

keefaz 06-03-2004 06:38 AM

No one can help you if you don't post your errors, I did an error in the past which breaked glibc package so I hadn't able to open tty, I copied from /lib in CD to /lib in HD and /sbin/agetty from CD to HD, it worked by luck.

Atmchicago 06-03-2004 10:35 AM

Well right now my most prominent error is that I can't log in... can't do much if I can't log in. Therefore I was wondering if there is/are package(s) relating to the login.

keefaz 06-03-2004 02:54 PM

The packages are :

and if it will fail, install the package :

Atmchicago 06-04-2004 06:10 PM

Thanks, I'll try those and see how it goes.

Atmchicago 06-07-2004 10:09 PM

Didn't manage to get it working, so I backed up, reformatted etc. Thanks anyways.

ringwraith 06-08-2004 08:44 AM

Probably would be best not to try to make changes to a Slackware installation with Knoppix in the future. Sometimes it is okay for a config file like X but not actual apps. Knoppix is a debian clone not Slackware.

Atmchicago 06-08-2004 12:58 PM

Well slackware packages are just zipped files with directions for where to put em - so I boot up knoppix, load the slack cd, and copy in the missing, individual files from packages. i suppose being able to run pkgtool would be nice, but I couldn't do that. I originally tried booting from slack cd #2 but getting it to read the 2nd cdrom wasn't working.

If you have a better idea, I'm up for it!

motub 06-08-2004 02:17 PM


Originally posted by Atmchicago
i suppose being able to run pkgtool would be nice, but I couldn't do that.
Don't see why not... couldn't you boot Knoppix, mount the Slack root partition, use the chroot command to switch to the Slack filetree, and then run pkgtool?

Atmchicago 06-08-2004 02:19 PM

well I guess I could then. Didn't know about chroot. Learn every day :)

All times are GMT -5. The time now is 06:01 PM.